]> git.pld-linux.org Git - packages/python3-pyrsistent.git/blob - python3-pyrsistent.spec
- updated to 0.18.1
[packages/python3-pyrsistent.git] / python3-pyrsistent.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define         module  pyrsistent
6 Summary:        Persistent/Functional/Immutable data structures
7 Summary(pl.UTF-8):      Trwałe/funkcyjne/niezmienne struktury danych
8 Name:           python3-pyrsistent
9 Version:        0.18.1
10 Release:        1
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/pyrsistent/
14 Source0:        https://files.pythonhosted.org/packages/source/p/pyrsistent/%{module}-%{version}.tar.gz
15 # Source0-md5:  cef3da08455664bf917dcf8cd00d49a4
16 URL:            http://github.com/tobgu/pyrsistent/
17 BuildRequires:  python3-devel >= 1:3.7
18 BuildRequires:  python3-setuptools
19 %if %{with tests}
20 BuildRequires:  python3-hypothesis < 7
21 BuildRequires:  python3-pytest < 7
22 BuildRequires:  python3-six
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.714
26 Requires:       python3-modules >= 1:3.7
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Pyrsistent is a number of persistent collections (by some referred to
31 as functional data structures). Persistent in the sense that they are
32 immutable.
33
34 %description -l pl.UTF-8
35 Pyrsistent to zbiór trwałych kolekcji (nazywanych także funkcyjnymi
36 strukturami danych). Są trwałe w tym sensie, że są niezmienne.
37
38 %prep
39 %setup -q -n %{module}-%{version}
40
41 # Remove bundled egg-info
42 %{__rm} -r %{module}.egg-info
43
44 %build
45 %py3_build
46
47 %if %{with tests}
48 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
49 %{__python3} -m pytest tests
50 %endif
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %py3_install
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc CHANGES.txt README.rst
63 %attr(755,root,root) %{py3_sitedir}/pvectorc.cpython-*.so
64 %{py3_sitedir}/_pyrsistent_version.py
65 %{py3_sitedir}/__pycache__/_pyrsistent_version.cpython-*.py[co]
66 %{py3_sitedir}/pyrsistent
67 %{py3_sitedir}/pyrsistent-%{version}-py*.egg-info
This page took 0.109684 seconds and 4 git commands to generate.