]> git.pld-linux.org Git - packages/python3-pyrsistent.git/blob - python3-pyrsistent.spec
f5e955e7af56b600464f68b4e073b3af101c74e9
[packages/python3-pyrsistent.git] / python3-pyrsistent.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define         module  pyrsistent
6 Summary:        Persistent/Functional/Immutable data structures
7 Summary(pl.UTF-8):      Trwałe/funkcyjne/niezmienne struktury danych
8 Name:           python3-pyrsistent
9 Version:        0.18.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/pyrsistent/
14 Source0:        https://files.pythonhosted.org/packages/source/p/pyrsistent/%{module}-%{version}.tar.gz
15 # Source0-md5:  1b335355d3eb40d0870988a1a41894b3
16 URL:            http://github.com/tobgu/pyrsistent/
17 BuildRequires:  python3-devel >= 1:3.5
18 BuildRequires:  python3-setuptools
19 %if %{with tests}
20 BuildRequires:  python3-hypothesis
21 BuildRequires:  python3-pytest
22 BuildRequires:  python3-six
23 %endif
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.714
26 Requires:       python3-modules >= 1:3.5
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Pyrsistent is a number of persistent collections (by some referred to
31 as functional data structures). Persistent in the sense that they are
32 immutable.
33
34 %description -l pl.UTF-8
35 Pyrsistent to zbiór trwałych kolekcji (nazywanych także funkcyjnymi
36 strukturami danych). Są trwałe w tym sensie, że są niezmienne.
37
38 %prep
39 %setup -q -n %{module}-%{version}
40
41 # Remove bundled egg-info
42 %{__rm} -r %{module}.egg-info
43
44 %build
45 %py3_build
46
47 %if %{with tests}
48 %{__python3} -m pytest tests
49 %endif
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %py3_install
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc CHANGES.txt README.rst
62 %attr(755,root,root) %{py3_sitedir}/pvectorc.cpython-*.so
63 %{py3_sitedir}/_pyrsistent_version.py
64 %{py3_sitedir}/__pycache__/_pyrsistent_version.cpython-*.py[co]
65 %{py3_sitedir}/pyrsistent
66 %{py3_sitedir}/pyrsistent-%{version}-py*.egg-info
This page took 0.048133 seconds and 2 git commands to generate.