]> git.pld-linux.org Git - packages/python3-pyrsistent.git/blob - python3-pyrsistent.spec
- moved from python-pyrsistent.spec, updated to 0.16.0; python2 support withdrawn...
[packages/python3-pyrsistent.git] / python3-pyrsistent.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define         module  pyrsistent
6 Summary:        Persistent/Functional/Immutable data structures
7 Summary(pl.UTF-8):      Trwałe/funkcyjne/niezmienne struktury danych
8 Name:           python3-pyrsistent
9 Version:        0.16.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/pyrsistent/
14 Source0:        https://files.pythonhosted.org/packages/source/p/pyrsistent/%{module}-%{version}.tar.gz
15 # Source0-md5:  4ba30da6f0a63554e70ac6c4c1904929
16 URL:            http://github.com/tobgu/pyrsistent/
17 BuildRequires:  python3-devel >= 1:3.5
18 BuildRequires:  python3-setuptools
19 %if %{with tests}
20 BuildRequires:  python3-hypothesis
21 # < 5? works also with 5.4.1
22 BuildRequires:  python3-pytest < 5
23 BuildRequires:  python3-six
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python3-modules >= 1:3.5
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Pyrsistent is a number of persistent collections (by some referred to
32 as functional data structures). Persistent in the sense that they are
33 immutable.
34
35 %description -l pl.UTF-8
36 Pyrsistent to zbiór trwałych kolekcji (nazywanych także funkcyjnymi
37 strukturami danych). Są trwałe w tym sensie, że są niezmienne.
38
39 %prep
40 %setup -q -n %{module}-%{version}
41
42 # Remove bundled egg-info
43 %{__rm} -r %{module}.egg-info
44
45 %build
46 %py3_build
47
48 %if %{with tests}
49 %{__python3} -m pytest tests
50 %endif
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %py3_install
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc CHANGES.txt LICENCE.mit README.rst
63 %attr(755,root,root) %{py3_sitedir}/pvectorc.cpython-*.so
64 %{py3_sitedir}/_pyrsistent_version.py
65 %{py3_sitedir}/__pycache__/_pyrsistent_version.cpython-*.py[co]
66 %{py3_sitedir}/pyrsistent
67 %{py3_sitedir}/pyrsistent-%{version}-py*.egg-info
This page took 0.059806 seconds and 3 git commands to generate.