]> git.pld-linux.org Git - packages/python3-pygments.git/commitdiff
- updated to 2.4.2
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 17 Sep 2019 18:56:25 +0000 (20:56 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 17 Sep 2019 18:56:25 +0000 (20:56 +0200)
- removed obsolete py3.7 patch

python-pygments-py3.7.patch [deleted file]
python-pygments.spec

diff --git a/python-pygments-py3.7.patch b/python-pygments-py3.7.patch
deleted file mode 100644 (file)
index 18ac39c..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
---- Pygments-2.2.0/pygments/lexers/lisp.py.orig        2017-01-22 22:01:32.000000000 +0100
-+++ Pygments-2.2.0/pygments/lexers/lisp.py     2018-07-18 21:48:02.153318157 +0200
-@@ -2327,13 +2327,13 @@
-             token = Name.Function if token == Literal else token
-             yield index, token, value
--        raise StopIteration
-+        return
-     def _process_signature(self, tokens):
-         for index, token, value in tokens:
-             if token == Literal and value == '}':
-                 yield index, Punctuation, value
--                raise StopIteration
-+                return
-             elif token in (Literal, Name.Function):
-                 token = Name.Variable if value.istitle() else Keyword.Type
-             yield index, token, value
---- Pygments-2.2.0/pygments/lexers/sql.py.orig 2017-01-22 22:01:32.000000000 +0100
-+++ Pygments-2.2.0/pygments/lexers/sql.py      2018-07-18 21:49:02.033317475 +0200
-@@ -347,7 +347,10 @@
-             # Emit the output lines
-             out_token = Generic.Output
-             while 1:
--                line = next(lines)
-+                try:
-+                    line = next(lines)
-+                except StopIteration:
-+                    return
-                 mprompt = re_prompt.match(line)
-                 if mprompt is not None:
-                     # push the line back to have it processed by the prompt
index 78243927170c5ef8e890c4e599db5ad7dd6aa81d..1ead9c205422e62fa4326d5786573eb12a87f284 100644 (file)
@@ -9,33 +9,37 @@
 Summary:       A generic syntax highlighter as Python 2.x module
 Summary(pl.UTF-8):     Moduł Pythona 2.x do ogólnego podświetlania składni
 Name:          python-%{module}
-Version:       2.2.0
-Release:       3
+Version:       2.4.2
+Release:       1
 License:       BSD
 Group:         Development/Languages/Python
 #Source0Download: https://pypi.org/simple/Pygments/
 Source0:       https://files.pythonhosted.org/packages/source/P/Pygments/Pygments-%{version}.tar.gz
-# Source0-md5: 13037baca42f16917cbd5ad2fab50844
+# Source0-md5: 5ecc3fbb2a783e917b369271fc0e6cd1
 Patch0:                rpmspec.patch
-Patch1:                %{name}-py3.7.patch
 URL:           http://pygments.org/
 BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with python2}
-BuildRequires: python >= 1:2.6
-BuildRequires: python-devel >= 1:2.6
-BuildRequires: python-modules >= 1:2.6
+BuildRequires: python >= 1:2.7
+BuildRequires: python-devel >= 1:2.7
+BuildRequires: python-modules >= 1:2.7
 BuildRequires: python-setuptools
+%if %{with tests}
+BuildRequires: python-nose
+%endif
 %endif
 %if %{with python3}
-BuildRequires: python3 >= 1:3.2
-BuildRequires: python3-2to3 >= 1:3.2
-BuildRequires: python3-devel >= 1:3.2
-BuildRequires: python3-modules >= 1:3.2
+BuildRequires: python3 >= 1:3.5
+BuildRequires: python3-devel >= 1:3.5
+BuildRequires: python3-modules >= 1:3.5
 BuildRequires: python3-setuptools
+%if %{with tests}
+BuildRequires: python3-nose
+%endif
 %endif
 BuildRequires: rpm-pythonprov
 %{?with_doc:BuildRequires:     sphinx-pdg}
-Requires:      python-modules >= 1:2.6
+Requires:      python-modules >= 1:2.7
 Requires:      python-setuptools
 Provides:      python-Pygments = %{version}-%{release}
 Obsoletes:     python-Pygments
@@ -76,7 +80,7 @@ forów, wiki i inne plikacje wymagające ładnego wyświetlania kodu
 Summary:       Generic syntax highlighter as Python 3.x module
 Summary(pl.UTF-8):     Moduł Pythona 3.x do ogólnego podświetlania składni
 Group:         Development/Languages/Python
-Requires:      python3-modules >= 1:3.2
+Requires:      python3-modules >= 1:3.5
 Requires:      python3-setuptools
 
 %description -n python3-%{module}
@@ -123,7 +127,6 @@ Dokumentacja API modułu Pythona Pygments.
 %prep
 %setup -q -n Pygments-%{version}
 %patch0 -p1
-%patch1 -p1
 
 %build
 %if %{with python2}
This page took 0.136486 seconds and 4 git commands to generate.