]> git.pld-linux.org Git - packages/python3-numpy.git/blobdiff - python3-numpy.spec
- updated to 1.22.4
[packages/python3-numpy.git] / python3-numpy.spec
index 42dc45cdcbf8a190adffff94b980e9ec59ee885f..ba2dfdf93686ac65753bd48e293c7237f2649b49 100644 (file)
@@ -1,3 +1,12 @@
+# TODO: failing tests with 32-bit ABIs:
+# - i686:
+# FAILED numpy/core/tests/test_mem_policy.py::test_new_policy - AssertionError:...
+# FAILED numpy/core/tests/test_ufunc.py::TestUfunc::test_identityless_reduction_huge_array
+# FAILED numpy/core/tests/test_umath.py::TestRemainder::test_float_remainder_overflow
+# FAILED numpy/random/tests/test_generator_mt19937.py::TestRandomDist::test_pareto
+# - x32:
+# Fatal Python error: Segmentation fault
+# File ".../BUILD/numpy-1.22.2/build/testenv/libx32/python3.10/site-packages/numpy/random/tests/test_direct.py", line 250 in test_pickle
 #
 # Conditional build:
 %bcond_without tests   # unit tests
 Summary:       Python 3.x numerical facilities
 Summary(pl.UTF-8):     Moduły do obliczeń numerycznych dla języka Python 3.x
 Name:          python3-%{module}
-Version:       1.21.4
+Version:       1.22.4
 Release:       1
 Epoch:         1
 License:       BSD
 Group:         Libraries/Python
 #Source0Download: https://github.com/numpy/numpy/releases/
 Source0:       https://github.com/numpy/numpy/releases/download/v%{version}/%{module}-%{version}.tar.gz
-# Source0-md5: 06019c1116b3e2791bd507f898257e7f
-Patch0:                bpo-45167.patch
+# Source0-md5: 09b3a41ea0b9bc20bd1691cf88f0b0d3
+Patch0:                %{name}-deprecated.patch
 URL:           https://github.com/numpy/numpy
+%if "%(test -w /dev/shm ; echo $?)" != "0"
+BuildRequires: WRITABLE(/dev/shm)
+%endif
 BuildRequires: gcc-fortran
 BuildRequires: lapack-devel >= 3.1.1-2
-BuildRequires: python3-Cython >= 0.29.24
-BuildRequires: python3-devel >= 1:3.6
-BuildRequires: python3-setuptools
+BuildRequires: python3-Cython >= 0.29.30
+BuildRequires: python3-devel >= 1:3.8
+BuildRequires: python3-setuptools >= 1:59.2.0
 %if %{with tests}
-BuildRequires: python3-pytest
+%if "%{ver_lt '%{py3_ver}' '3.10'}" == "1"
+BuildRequires: python3-cffi
+%endif
+BuildRequires: python3-hypothesis >= 6.24.1
+#BuildRequires:        python3-mypy >= 0.940
+BuildRequires: python3-pytest >= 6.2.5
+BuildRequires: python3-pytz >= 2021.3
 %endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
-Requires:      python3-libs >= 1:3.6
+Requires:      python3-libs >= 1:3.8
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -45,7 +63,7 @@ Ten pakiet zawiera moduły Pythona 3.
 Summary:       C header files for Python 3 numerical modules
 Summary(pl.UTF-8):     Pliki nagłówkowe języka C modułów numerycznych Pythona 3
 Group:         Development/Languages/Python
-%pyrequires_eq python-devel
+%pyrequires_eq python3-devel
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description devel
@@ -79,6 +97,7 @@ LDFLAGS="%{rpmldflags} -shared"
 %py3_build
 
 %if %{with tests}
+PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
 %{__python3} runtests.py --mode=full
 %endif
 
@@ -106,6 +125,9 @@ rm -rf $RPM_BUILD_ROOT
 %{py3_sitedir}/%{module}/*.pyi
 %{py3_sitedir}/%{module}/py.typed
 %{py3_sitedir}/%{module}/__pycache__
+%dir %{py3_sitedir}/%{module}/array_api
+%{py3_sitedir}/%{module}/array_api/*.py
+%{py3_sitedir}/%{module}/array_api/__pycache__
 %dir %{py3_sitedir}/%{module}/compat
 %{py3_sitedir}/%{module}/compat/*.py
 %{py3_sitedir}/%{module}/compat/__pycache__
@@ -118,6 +140,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py3_sitedir}/%{module}/distutils/*.py
 %{py3_sitedir}/%{module}/distutils/*.pyi
 %{py3_sitedir}/%{module}/distutils/__pycache__
+%{py3_sitedir}/%{module}/distutils/checks
 %dir %{py3_sitedir}/%{module}/distutils/command
 %{py3_sitedir}/%{module}/distutils/command/*.py
 %{py3_sitedir}/%{module}/distutils/command/__pycache__
This page took 0.029767 seconds and 4 git commands to generate.