]> git.pld-linux.org Git - packages/python3-markupsafe.git/commitdiff
automatic change: use py_build/py_install macros
authorJacek Konieczny <jajcus@jajcus.net>
Sat, 28 Nov 2015 17:06:43 +0000 (18:06 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Sat, 28 Nov 2015 17:06:43 +0000 (18:06 +0100)
python-markupsafe.spec

index 4ff432fbe94d250275b1dfb35c92143e51d6276c..e27bfc79d1cb71ef3325399ebf1db9c0b660bed7 100644 (file)
@@ -67,18 +67,14 @@ cp -a py2 py3
 %if %{with python2}
 cd py3
 # CFLAGS is only for arch packages - remove on noarch packages
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python} setup.py build
+%py_build
 %{?with_tests:%{__python} setup.py test}
 cd ..
 %endif
 
 %if %{with python3}
 cd py3
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python3} setup.py build
+%py3_build
 %{?with_tests:%{__python3} setup.py test}
 cd ..
 %endif
@@ -87,9 +83,7 @@ cd ..
 rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 cd py2
-%{__python} setup.py install \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 
 # C code errantly gets installed
 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/markupsafe/_speedups.c
@@ -101,9 +95,7 @@ cd ..
 
 %if %{with python3}
 cd py3
-%{__python3} setup.py install \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 
 
 # C code errantly gets installed
This page took 0.063936 seconds and 4 git commands to generate.