]> git.pld-linux.org Git - packages/python3-markupsafe.git/blobdiff - python-markupsafe.spec
- release 2 (by relup.sh)
[packages/python3-markupsafe.git] / python-markupsafe.spec
index 6115ae0c899cacd249099025e80e80cddb263730..54f1f6151ccac0d36bde09867d66e2fe672796a2 100644 (file)
@@ -5,25 +5,27 @@
 %bcond_without python3 # CPython 3.x module
 
 %define        module  markupsafe
-Summary:       Implements a XML/HTML/XHTML Markup safe string for Python
+Summary:       MarkupSafe - a XML/HTML/XHTML Markup safe string for Python 2
+Summary(pl.UTF-8):     MarkupSafe - łańcuch dla Pythona 2 bezpieczny pod kątem znaczników XML/HTML/XHTML
 Name:          python-%{module}
-Version:       0.15
+Version:       1.0
 Release:       2
 License:       BSD
 Group:         Development/Languages/Python
-Source0:       http://pypi.python.org/packages/source/M/MarkupSafe/MarkupSafe-%{version}.tar.gz
-# Source0-md5: 4e7c4d965fe5e033fa2d7bb7746bb186
-URL:           http://www.pocoo.org/
+#Source0Download: https://pypi.python.org/pypi/MarkupSafe
+Source0:       https://files.pythonhosted.org/packages/source/M/MarkupSafe/MarkupSafe-%{version}.tar.gz
+# Source0-md5: 2fcedc9284d50e577b5192e8e3578355
+URL:           http://www.pocoo.org/projects/markupsafe/#markupsafe
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: rpmbuild(macros) >= 1.710
 %if %{with python2}
 BuildRequires: python-devel
-BuildRequires: python-distribute
+BuildRequires: python-setuptools
 %endif
 %if %{with python3}
 BuildRequires: python-2to3
 BuildRequires: python3-devel
-BuildRequires: python3-distribute
+BuildRequires: python3-setuptools
 %endif
 Requires:      python-modules
 Provides:      python-MarkupSafe = %{version}-%{release}
@@ -31,75 +33,51 @@ Obsoletes:  python-MarkupSafe < 0.15-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Implements a XML/HTML/XHTML Markup safe string for Python.
+MarkupSafe implements a XML/HTML/XHTML Markup safe string for Python.
+
+%description -l pl.UTF-8
+MarkupSafe to implementacja łańcucha znaków dla Pythona bezpiecznego
+pod kątem znaczników XML/HTML/XHTML.
 
 %package -n python3-markupsafe
-Summary:       Implements a XML/HTML/XHTML Markup safe string for Python
+Summary:       Implements a XML/HTML/XHTML Markup safe string for Python 3
+Summary(pl.UTF-8):     MarkupSafe - łańcuch dla Pythona 3 bezpieczny pod kątem znaczników XML/HTML/XHTML
 Group:         Development/Languages
+Requires:      python3-modules
 
 %description -n python3-markupsafe
-Implements a XML/HTML/XHTML Markup safe string for Python.
+MarkupSafe implements a XML/HTML/XHTML Markup safe string for Python.
 
-%prep
-%setup -qc
-mv MarkupSafe-%{version} py2
-# for %doc
-cp -p py2/{AUTHORS,LICENSE,README.rst} .
+%description -n python3-markupsafe -l pl.UTF-8
+MarkupSafe to implementacja łańcucha znaków dla Pythona bezpiecznego
+pod kątem znaczników XML/HTML/XHTML.
 
-%if %{with python3}
-cp -a py2 py3
-2to3 --write --nobackups py3
-%endif
+%prep
+%setup -q -n MarkupSafe-%{version}
 
 %build
 %if %{with python2}
-cd py3
-# CFLAGS is only for arch packages - remove on noarch packages
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python} setup.py build
-%{?with_tests:%{__python} setup.py test}
-cd ..
+%py_build %{?with_tests:test}
 %endif
 
 %if %{with python3}
-cd py3
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python3} setup.py build
-%{?with_tests:%{__python3} setup.py test}
-cd ..
+%py3_build %{?with_tests:test}
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
-cd py2
-%{__python} setup.py install \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 
+%py_postclean
 # C code errantly gets installed
 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/markupsafe/_speedups.c
-%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
-%py_comp $RPM_BUILD_ROOT%{py_sitedir}
-%py_postclean
-cd ..
 %endif
 
 %if %{with python3}
-cd py3
-%{__python3} setup.py install \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
-
+%py3_install
 
-# err the unversioned one is duplicate
-%{__rm} -r $RPM_BUILD_ROOT%{py3_sitedir}/MarkupSafe.egg-info
-
-# C code errantly gets installed
 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/markupsafe/_speedups.c
-cd ..
 %endif
 
 %clean
@@ -111,7 +89,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS LICENSE README.rst
 %dir %{py_sitedir}/markupsafe
 %{py_sitedir}/markupsafe/*.py[co]
-%attr(755,root,root) %{py_sitedir}/markupsafe/*.so
+%attr(755,root,root) %{py_sitedir}/markupsafe/_speedups.so
 %{py_sitedir}/MarkupSafe-%{version}-py*.egg-info
 %endif
 
@@ -122,6 +100,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py3_sitedir}/markupsafe
 %{py3_sitedir}/markupsafe/*.py
 %{py3_sitedir}/markupsafe/__pycache__
-%attr(755,root,root) %{py3_sitedir}/markupsafe/*.so
+%attr(755,root,root) %{py3_sitedir}/markupsafe/_speedups.cpython-*.so
 %{py3_sitedir}/MarkupSafe-%{version}-py*.egg-info
 %endif
This page took 0.034578 seconds and 4 git commands to generate.