]> git.pld-linux.org Git - packages/python3-markupsafe.git/blob - python-markupsafe.spec
e27bfc79d1cb71ef3325399ebf1db9c0b660bed7
[packages/python3-markupsafe.git] / python-markupsafe.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         module  markupsafe
8 Summary:        MarkupSafe - a XML/HTML/XHTML Markup safe string for Python 2
9 Summary(pl.UTF-8):      MarkupSafe - łańcuch dla Pythona 2 bezpieczny pod kątem znaczników XML/HTML/XHTML
10 Name:           python-%{module}
11 Version:        0.23
12 Release:        5
13 License:        BSD
14 Group:          Development/Languages/Python
15 #Source0Download: https://pypi.python.org/pypi/MarkupSafe
16 Source0:        https://pypi.python.org/packages/source/M/MarkupSafe/MarkupSafe-%{version}.tar.gz
17 # Source0-md5:  f5ab3deee4c37cd6a922fb81e730da6e
18 URL:            http://www.pocoo.org/
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.219
21 %if %{with python2}
22 BuildRequires:  python-devel
23 BuildRequires:  python-setuptools
24 %endif
25 %if %{with python3}
26 BuildRequires:  python-2to3
27 BuildRequires:  python3-devel
28 BuildRequires:  python3-setuptools
29 %endif
30 Requires:       python-modules
31 Provides:       python-MarkupSafe = %{version}-%{release}
32 Obsoletes:      python-MarkupSafe < 0.15-2
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 MarkupSafe implements a XML/HTML/XHTML Markup safe string for Python.
37
38 %description -l pl.UTF-8
39 MarkupSafe to implementacja łańcucha znaków dla Pythona bezpiecznego
40 pod kątem znaczników XML/HTML/XHTML.
41
42 %package -n python3-markupsafe
43 Summary:        Implements a XML/HTML/XHTML Markup safe string for Python 3
44 Summary(pl.UTF-8):      MarkupSafe - łańcuch dla Pythona 3 bezpieczny pod kątem znaczników XML/HTML/XHTML
45 Group:          Development/Languages
46 Requires:       python3-modules
47
48 %description -n python3-markupsafe
49 MarkupSafe implements a XML/HTML/XHTML Markup safe string for Python.
50
51 %description -n python3-markupsafe -l pl.UTF-8
52 MarkupSafe to implementacja łańcucha znaków dla Pythona bezpiecznego
53 pod kątem znaczników XML/HTML/XHTML.
54
55 %prep
56 %setup -qc
57 mv MarkupSafe-%{version} py2
58 # for %doc
59 cp -p py2/{AUTHORS,LICENSE,README.rst} .
60
61 %if %{with python3}
62 cp -a py2 py3
63 2to3 --write --nobackups py3
64 %endif
65
66 %build
67 %if %{with python2}
68 cd py3
69 # CFLAGS is only for arch packages - remove on noarch packages
70 %py_build
71 %{?with_tests:%{__python} setup.py test}
72 cd ..
73 %endif
74
75 %if %{with python3}
76 cd py3
77 %py3_build
78 %{?with_tests:%{__python3} setup.py test}
79 cd ..
80 %endif
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 %if %{with python2}
85 cd py2
86 %py_install
87
88 # C code errantly gets installed
89 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/markupsafe/_speedups.c
90 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
91 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
92 %py_postclean
93 cd ..
94 %endif
95
96 %if %{with python3}
97 cd py3
98 %py3_install
99
100
101 # C code errantly gets installed
102 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/markupsafe/_speedups.c
103 cd ..
104 %endif
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %if %{with python2}
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS LICENSE README.rst
113 %dir %{py_sitedir}/markupsafe
114 %{py_sitedir}/markupsafe/*.py[co]
115 %attr(755,root,root) %{py_sitedir}/markupsafe/_speedups.so
116 %{py_sitedir}/MarkupSafe-%{version}-py*.egg-info
117 %endif
118
119 %if %{with python3}
120 %files -n python3-markupsafe
121 %defattr(644,root,root,755)
122 %doc AUTHORS LICENSE README.rst
123 %dir %{py3_sitedir}/markupsafe
124 %{py3_sitedir}/markupsafe/*.py
125 %{py3_sitedir}/markupsafe/__pycache__
126 %attr(755,root,root) %{py3_sitedir}/markupsafe/_speedups.cpython-*.so
127 %{py3_sitedir}/MarkupSafe-%{version}-py*.egg-info
128 %endif
This page took 0.036119 seconds and 3 git commands to generate.