]> git.pld-linux.org Git - packages/python3-markupsafe.git/blame_incremental - python3-markupsafe.spec
- updated to 2.1.1
[packages/python3-markupsafe.git] / python3-markupsafe.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
4%bcond_without tests # unit tests
5
6%define module markupsafe
7Summary: Implements a XML/HTML/XHTML Markup safe string for Python 3
8Summary(pl.UTF-8): MarkupSafe - łańcuch dla Pythona 3 bezpieczny pod kątem znaczników XML/HTML/XHTML
9Name: python3-%{module}
10Version: 2.1.1
11Release: 1
12License: BSD
13Group: Development/Languages/Python
14#Source0Download: https://pypi.org/simple/markupsafe/
15Source0: https://files.pythonhosted.org/packages/source/M/MarkupSafe/MarkupSafe-%{version}.tar.gz
16# Source0-md5: 9809f9fdd98bc835b0c21aa8f79cbf30
17URL: https://markupsafe.palletsprojects.com/
18BuildRequires: python3-devel >= 1:3.7
19BuildRequires: python3-setuptools
20BuildRequires: rpm-pythonprov
21BuildRequires: rpmbuild(macros) >= 1.714
22%if %{with tests}
23BuildRequires: python3-pytest
24%endif
25%if %{with doc}
26BuildRequires: python3-pallets-sphinx-themes >= 1.1.0
27BuildRequires: python3-sphinx_issues >= 1.2.0
28BuildRequires: python3-sphinxcontrib-log-cabinet >= 1.0.1
29BuildRequires: sphinx-pdg-3 >= 1.8.0
30%endif
31Requires: python3-modules >= 1:3.7
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35MarkupSafe implements a XML/HTML/XHTML Markup safe string for Python.
36
37%description -l pl.UTF-8
38MarkupSafe to implementacja łańcucha znaków dla Pythona bezpiecznego
39pod kątem znaczników XML/HTML/XHTML.
40
41%package apidocs
42Summary: API documentation for Python MarkupSafe module
43Summary(pl.UTF-8): Dokumentacja API modułu Pythona MarkupSafe
44Group: Documentation
45
46%description apidocs
47API documentation for Python MarkupSafe module.
48
49%description apidocs -l pl.UTF-8
50Dokumentacja API modułu Pythona MarkupSafe.
51
52%prep
53%setup -q -n MarkupSafe-%{version}
54
55%build
56%py3_build
57
58%if %{with tests}
59PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
60PYTHONPATH=$(pwd)/$(echo build-3/lib.*) \
61%{__python3} -m pytest tests
62%endif
63
64%if %{with doc}
65%{__make} -C docs html \
66 SPHINXBUILD=sphinx-build-3
67%endif
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72%py3_install
73
74%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/markupsafe/_speedups.c
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%files
80%defattr(644,root,root,755)
81%doc CHANGES.rst LICENSE.rst README.rst
82%dir %{py3_sitedir}/markupsafe
83%{py3_sitedir}/markupsafe/*.py
84%{py3_sitedir}/markupsafe/__pycache__
85%{py3_sitedir}/markupsafe/_speedups.pyi
86%{py3_sitedir}/markupsafe/py.typed
87%attr(755,root,root) %{py3_sitedir}/markupsafe/_speedups.cpython-*.so
88%{py3_sitedir}/MarkupSafe-%{version}-py*.egg-info
89
90%if %{with doc}
91%files apidocs
92%defattr(644,root,root,755)
93%doc docs/_build/html/{_static,*.html,*.js}
94%endif
This page took 0.066063 seconds and 4 git commands to generate.