]> git.pld-linux.org Git - packages/python3-markupsafe.git/blame_incremental - python-markupsafe.spec
- updated to 1.1.1
[packages/python3-markupsafe.git] / python-markupsafe.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
4%bcond_without tests # unit tests
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8%define module markupsafe
9Summary: MarkupSafe - a XML/HTML/XHTML Markup safe string for Python 2
10Summary(pl.UTF-8): MarkupSafe - łańcuch dla Pythona 2 bezpieczny pod kątem znaczników XML/HTML/XHTML
11Name: python-%{module}
12Version: 1.1.1
13Release: 1
14License: BSD
15Group: Development/Languages/Python
16#Source0Download: https://pypi.org/simple/markupsafe/
17Source0: https://files.pythonhosted.org/packages/source/M/MarkupSafe/MarkupSafe-%{version}.tar.gz
18# Source0-md5: 43fd756864fe42063068e092e220c57b
19URL: http://www.pocoo.org/projects/markupsafe/#markupsafe
20BuildRequires: rpm-pythonprov
21BuildRequires: rpmbuild(macros) >= 1.714
22%if %{with python2}
23BuildRequires: python-devel >= 1:2.7
24BuildRequires: python-setuptools
25%if %{with tests}
26BuildRequires: python-pytest
27%endif
28%endif
29%if %{with python3}
30BuildRequires: python-2to3
31BuildRequires: python3-devel >= 1:3.4
32BuildRequires: python3-setuptools
33%if %{with tests}
34BuildRequires: python3-pytest
35%endif
36%endif
37%if %{with doc}
38BuildRequires: python3-pallets-sphinx-themes >= 1.1.0
39# docs/requirements.txt says 1.8.0, but 1.7.6 also works
40#BuildRequires: sphinx-pdg-3 >= 1.8.0
41BuildRequires: sphinx-pdg-3 >= 1.7.0
42%endif
43Requires: python-modules >= 1:2.7
44Provides: python-MarkupSafe = %{version}-%{release}
45Obsoletes: python-MarkupSafe < 0.15-2
46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48%description
49MarkupSafe implements a XML/HTML/XHTML Markup safe string for Python.
50
51%description -l pl.UTF-8
52MarkupSafe to implementacja łańcucha znaków dla Pythona bezpiecznego
53pod kątem znaczników XML/HTML/XHTML.
54
55%package -n python3-markupsafe
56Summary: Implements a XML/HTML/XHTML Markup safe string for Python 3
57Summary(pl.UTF-8): MarkupSafe - łańcuch dla Pythona 3 bezpieczny pod kątem znaczników XML/HTML/XHTML
58Group: Development/Languages
59Requires: python3-modules >= 1:3.4
60
61%description -n python3-markupsafe
62MarkupSafe implements a XML/HTML/XHTML Markup safe string for Python.
63
64%description -n python3-markupsafe -l pl.UTF-8
65MarkupSafe to implementacja łańcucha znaków dla Pythona bezpiecznego
66pod kątem znaczników XML/HTML/XHTML.
67
68%package apidocs
69Summary: API documentation for Python MarkupSafe module
70Summary(pl.UTF-8): Dokumentacja API modułu Pythona MarkupSafe
71Group: Documentation
72
73%description apidocs
74API documentation for Python MarkupSafe module.
75
76%description apidocs -l pl.UTF-8
77Dokumentacja API modułu Pythona MarkupSafe.
78
79%prep
80%setup -q -n MarkupSafe-%{version}
81
82%build
83%if %{with python2}
84%py_build
85
86%if %{with tests}
87PYTHONPATH=$(pwd)/$(echo build-2/lib.*) \
88%{__python} -m pytest tests
89%endif
90%endif
91
92%if %{with python3}
93%py3_build
94
95%if %{with tests}
96PYTHONPATH=$(pwd)/$(echo build-3/lib.*) \
97%{__python3} -m pytest tests
98%endif
99%endif
100
101%if %{with doc}
102%{__make} -C docs html \
103 SPHINXBUILD=sphinx-build-3
104%endif
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109%if %{with python2}
110%py_install
111
112%py_postclean
113# C code errantly gets installed
114%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/markupsafe/_speedups.c
115%endif
116
117%if %{with python3}
118%py3_install
119
120%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/markupsafe/_speedups.c
121%endif
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%if %{with python2}
127%files
128%defattr(644,root,root,755)
129%doc CHANGES.rst LICENSE.rst README.rst
130%dir %{py_sitedir}/markupsafe
131%{py_sitedir}/markupsafe/*.py[co]
132%attr(755,root,root) %{py_sitedir}/markupsafe/_speedups.so
133%{py_sitedir}/MarkupSafe-%{version}-py*.egg-info
134%endif
135
136%if %{with python3}
137%files -n python3-markupsafe
138%defattr(644,root,root,755)
139%doc CHANGES.rst LICENSE.rst README.rst
140%dir %{py3_sitedir}/markupsafe
141%{py3_sitedir}/markupsafe/*.py
142%{py3_sitedir}/markupsafe/__pycache__
143%attr(755,root,root) %{py3_sitedir}/markupsafe/_speedups.cpython-*.so
144%{py3_sitedir}/MarkupSafe-%{version}-py*.egg-info
145%endif
146
147%if %{with doc}
148%files apidocs
149%defattr(644,root,root,755)
150%doc docs/_build/html/{_static,*.html,*.js}
151%endif
This page took 0.063302 seconds and 4 git commands to generate.