]> git.pld-linux.org Git - packages/python3-markupsafe.git/blame_incremental - python-markupsafe.spec
- rebuild with python 3.8
[packages/python3-markupsafe.git] / python-markupsafe.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # unit tests
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7%define module markupsafe
8Summary: MarkupSafe - a XML/HTML/XHTML Markup safe string for Python 2
9Summary(pl.UTF-8): MarkupSafe - łańcuch dla Pythona 2 bezpieczny pod kątem znaczników XML/HTML/XHTML
10Name: python-%{module}
11Version: 1.1.0
12Release: 2
13License: BSD
14Group: Development/Languages/Python
15#Source0Download: https://pypi.org/pypi/MarkupSafe/
16Source0: https://files.pythonhosted.org/packages/source/M/MarkupSafe/MarkupSafe-%{version}.tar.gz
17# Source0-md5: 49e3f3230cedb7ae34faf06913db83fc
18URL: http://www.pocoo.org/projects/markupsafe/#markupsafe
19BuildRequires: rpm-pythonprov
20BuildRequires: rpmbuild(macros) >= 1.710
21%if %{with python2}
22BuildRequires: python-devel
23BuildRequires: python-setuptools
24%endif
25%if %{with python3}
26BuildRequires: python-2to3
27BuildRequires: python3-devel
28BuildRequires: python3-setuptools
29%endif
30Requires: python-modules
31Provides: python-MarkupSafe = %{version}-%{release}
32Obsoletes: python-MarkupSafe < 0.15-2
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36MarkupSafe implements a XML/HTML/XHTML Markup safe string for Python.
37
38%description -l pl.UTF-8
39MarkupSafe to implementacja łańcucha znaków dla Pythona bezpiecznego
40pod kątem znaczników XML/HTML/XHTML.
41
42%package -n python3-markupsafe
43Summary: Implements a XML/HTML/XHTML Markup safe string for Python 3
44Summary(pl.UTF-8): MarkupSafe - łańcuch dla Pythona 3 bezpieczny pod kątem znaczników XML/HTML/XHTML
45Group: Development/Languages
46Requires: python3-modules
47
48%description -n python3-markupsafe
49MarkupSafe implements a XML/HTML/XHTML Markup safe string for Python.
50
51%description -n python3-markupsafe -l pl.UTF-8
52MarkupSafe to implementacja łańcucha znaków dla Pythona bezpiecznego
53pod kątem znaczników XML/HTML/XHTML.
54
55%prep
56%setup -q -n MarkupSafe-%{version}
57
58%build
59%if %{with python2}
60%py_build %{?with_tests:test}
61%endif
62
63%if %{with python3}
64%py3_build %{?with_tests:test}
65%endif
66
67%install
68rm -rf $RPM_BUILD_ROOT
69%if %{with python2}
70%py_install
71
72%py_postclean
73# C code errantly gets installed
74%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/markupsafe/_speedups.c
75%endif
76
77%if %{with python3}
78%py3_install
79
80%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/markupsafe/_speedups.c
81%endif
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%if %{with python2}
87%files
88%defattr(644,root,root,755)
89%doc LICENSE.rst README.rst
90%dir %{py_sitedir}/markupsafe
91%{py_sitedir}/markupsafe/*.py[co]
92%attr(755,root,root) %{py_sitedir}/markupsafe/_speedups.so
93%{py_sitedir}/MarkupSafe-%{version}-py*.egg-info
94%endif
95
96%if %{with python3}
97%files -n python3-markupsafe
98%defattr(644,root,root,755)
99%doc LICENSE.rst README.rst
100%dir %{py3_sitedir}/markupsafe
101%{py3_sitedir}/markupsafe/*.py
102%{py3_sitedir}/markupsafe/__pycache__
103%attr(755,root,root) %{py3_sitedir}/markupsafe/_speedups.cpython-*.so
104%{py3_sitedir}/MarkupSafe-%{version}-py*.egg-info
105%endif
This page took 0.05029 seconds and 4 git commands to generate.