]> git.pld-linux.org Git - packages/python3-markupsafe.git/blame_incremental - python-MarkupSafe.spec
build python3 package
[packages/python3-markupsafe.git] / python-MarkupSafe.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7%define module MarkupSafe
8Summary: Implements a XML/HTML/XHTML Markup safe string for Python
9Name: python-%{module}
10Version: 0.15
11Release: 2
12License: BSD
13Group: Development/Languages/Python
14Source0: http://pypi.python.org/packages/source/M/MarkupSafe/%{module}-%{version}.tar.gz
15# Source0-md5: 4e7c4d965fe5e033fa2d7bb7746bb186
16URL: http://www.pocoo.org/
17BuildRequires: rpm-pythonprov
18BuildRequires: rpmbuild(macros) >= 1.219
19%if %{with python2}
20BuildRequires: python-devel
21BuildRequires: python-distribute
22%endif
23%if %{with python3}
24BuildRequires: python-2to3
25BuildRequires: python3-devel
26BuildRequires: python3-distribute
27%endif
28Requires: python-modules
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32Implements a XML/HTML/XHTML Markup safe string for Python.
33
34%package -n python3-markupsafe
35Summary: Implements a XML/HTML/XHTML Markup safe string for Python
36Group: Development/Languages
37
38%description -n python3-markupsafe
39Implements a XML/HTML/XHTML Markup safe string for Python.
40
41%prep
42%setup -qc
43mv %{module}-%{version} py2
44# for %doc
45cp -p py2/{AUTHORS,LICENSE,README.rst} .
46
47%if %{with python3}
48cp -a py2 py3
492to3 --write --nobackups py3
50%endif
51
52%build
53%if %{with python2}
54cd py3
55# CFLAGS is only for arch packages - remove on noarch packages
56CC="%{__cc}" \
57CFLAGS="%{rpmcflags}" \
58%{__python} setup.py build
59%{?with_tests:%{__python} setup.py test}
60cd ..
61%endif
62
63%if %{with python3}
64cd py3
65CC="%{__cc}" \
66CFLAGS="%{rpmcflags}" \
67%{__python3} setup.py build
68%{?with_tests:%{__python3} setup.py test}
69cd ..
70%endif
71
72%install
73rm -rf $RPM_BUILD_ROOT
74%if %{with python2}
75cd py2
76%{__python} setup.py install \
77 --optimize=2 \
78 --root=$RPM_BUILD_ROOT
79
80# C code errantly gets installed
81%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/markupsafe/_speedups.c
82%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
83%py_comp $RPM_BUILD_ROOT%{py_sitedir}
84%py_postclean
85cd ..
86%endif
87
88%if %{with python3}
89cd py3
90%{__python3} setup.py install \
91 --optimize=2 \
92 --root=$RPM_BUILD_ROOT
93
94
95# err the unversioned one is duplicate
96%{__rm} -r $RPM_BUILD_ROOT%{py3_sitedir}/MarkupSafe.egg-info
97
98# C code errantly gets installed
99%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/markupsafe/_speedups.c
100cd ..
101%endif
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%if %{with python2}
107%files
108%defattr(644,root,root,755)
109%doc AUTHORS LICENSE README.rst
110%dir %{py_sitedir}/markupsafe
111%{py_sitedir}/markupsafe/*.py[co]
112%attr(755,root,root) %{py_sitedir}/markupsafe/*.so
113%{py_sitedir}/MarkupSafe-%{version}-py*.egg-info
114%endif
115
116%if %{with python3}
117%files -n python3-markupsafe
118%defattr(644,root,root,755)
119%doc AUTHORS LICENSE README.rst
120%dir %{py3_sitedir}/markupsafe
121%{py3_sitedir}/markupsafe/*.py
122%{py3_sitedir}/markupsafe/__pycache__
123%attr(755,root,root) %{py3_sitedir}/markupsafe/*.so
124%{py3_sitedir}/MarkupSafe-%{version}-py*.egg-info
125%endif
This page took 0.035055 seconds and 4 git commands to generate.