]> git.pld-linux.org Git - packages/python3-markupsafe.git/blame - python3-markupsafe.spec
Build only python3 package
[packages/python3-markupsafe.git] / python3-markupsafe.spec
CommitLineData
d1b3c515
ER
1#
2# Conditional build:
f17806b5 3%bcond_without doc # Sphinx documentation
37cbba9f 4%bcond_without tests # unit tests
d1b3c515 5
a8646d2c 6%define module markupsafe
102e358b
ER
7Summary: Implements a XML/HTML/XHTML Markup safe string for Python 3
8Summary(pl.UTF-8): MarkupSafe - łańcuch dla Pythona 3 bezpieczny pod kątem znaczników XML/HTML/XHTML
9Name: python3-%{module}
f17806b5 10Version: 1.1.1
8ab2d47c 11Release: 3
a79f2bec 12License: BSD
13Group: Development/Languages/Python
f17806b5 14#Source0Download: https://pypi.org/simple/markupsafe/
4cbda2d2 15Source0: https://files.pythonhosted.org/packages/source/M/MarkupSafe/MarkupSafe-%{version}.tar.gz
f17806b5 16# Source0-md5: 43fd756864fe42063068e092e220c57b
4cbda2d2 17URL: http://www.pocoo.org/projects/markupsafe/#markupsafe
a79f2bec 18BuildRequires: rpm-pythonprov
f17806b5 19BuildRequires: rpmbuild(macros) >= 1.714
f17806b5 20BuildRequires: python3-devel >= 1:3.4
b15ed0c4 21BuildRequires: python3-setuptools
f17806b5
JB
22%if %{with tests}
23BuildRequires: python3-pytest
24%endif
f17806b5
JB
25%if %{with doc}
26BuildRequires: python3-pallets-sphinx-themes >= 1.1.0
27# docs/requirements.txt says 1.8.0, but 1.7.6 also works
28#BuildRequires: sphinx-pdg-3 >= 1.8.0
29BuildRequires: sphinx-pdg-3 >= 1.7.0
30%endif
102e358b 31Requires: python3-modules >= 1:3.4
a79f2bec 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
02f65cc7
JB
35MarkupSafe implements a XML/HTML/XHTML Markup safe string for Python.
36
37%description -l pl.UTF-8
38MarkupSafe to implementacja łańcucha znaków dla Pythona bezpiecznego
39pod kątem znaczników XML/HTML/XHTML.
a79f2bec 40
f17806b5
JB
41%package apidocs
42Summary: API documentation for Python MarkupSafe module
43Summary(pl.UTF-8): Dokumentacja API modułu Pythona MarkupSafe
44Group: Documentation
45
46%description apidocs
47API documentation for Python MarkupSafe module.
48
49%description apidocs -l pl.UTF-8
50Dokumentacja API modułu Pythona MarkupSafe.
51
a79f2bec 52%prep
4cbda2d2 53%setup -q -n MarkupSafe-%{version}
a79f2bec 54
55%build
f17806b5
JB
56%py3_build
57
58%if %{with tests}
59PYTHONPATH=$(pwd)/$(echo build-3/lib.*) \
60%{__python3} -m pytest tests
61%endif
f17806b5
JB
62
63%if %{with doc}
64%{__make} -C docs html \
65 SPHINXBUILD=sphinx-build-3
d1b3c515 66%endif
a79f2bec 67
68%install
69rm -rf $RPM_BUILD_ROOT
e2092c77 70%py3_install
d1b3c515 71
d1b3c515 72%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/markupsafe/_speedups.c
a79f2bec 73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%files
78%defattr(644,root,root,755)
f17806b5 79%doc CHANGES.rst LICENSE.rst README.rst
d1b3c515
ER
80%dir %{py3_sitedir}/markupsafe
81%{py3_sitedir}/markupsafe/*.py
82%{py3_sitedir}/markupsafe/__pycache__
02f65cc7 83%attr(755,root,root) %{py3_sitedir}/markupsafe/_speedups.cpython-*.so
d1b3c515 84%{py3_sitedir}/MarkupSafe-%{version}-py*.egg-info
f17806b5
JB
85
86%if %{with doc}
87%files apidocs
88%defattr(644,root,root,755)
89%doc docs/_build/html/{_static,*.html,*.js}
90%endif
This page took 0.040531 seconds and 4 git commands to generate.