]> git.pld-linux.org Git - packages/python3-jinja2.git/blobdiff - python3-jinja2.spec
Build only Python3
[packages/python3-jinja2.git] / python3-jinja2.spec
index b65ce6ffa8f7fb29892fa8d2b8105dbe1701f136..ee7aca6eeb713960474312367ceb7542a91e357e 100644 (file)
@@ -1,63 +1,93 @@
-%bcond_without doc
-%define module jinja2
-Summary:       Template engine
-Summary(pl.UTF-8):     Silnik szablonów
+#
+# Conditional build:
+%bcond_without doc     # API documentation
+%bcond_without tests   # unit tests
+
+%define                module  jinja2
+Summary:       Template engine Jinja2 for Python 3.x
+Summary(pl.UTF-8):     Silnik szablonów Jinja2 dla Pythona 3.x
 Name:          python3-%{module}
-Version:       2.3.1
-Release:       2
+Version:       2.11.3
+Release:       1
 License:       BSD
 Group:         Development/Languages/Python
-Source0:       http://pypi.python.org/packages/source/J/Jinja2/Jinja2-%{version}.tar.gz
-# Source0-md5: 391c7dd06c62dfe7e30ebaad7af0a401
-URL:           http://pypi.python.org/pypi/Jinja2
-BuildRequires: python3-devel
-BuildRequires: python3-distribute
+#Source0Download: https://pypi.org/simple/Jinja2
+Source0:       https://files.pythonhosted.org/packages/source/J/Jinja2/Jinja2-%{version}.tar.gz
+# Source0-md5: 231dc00d34afb2672c497713fa9cdaaa
+URL:           http://jinja.pocoo.org/
+BuildRequires: rpmbuild(macros) >= 1.714
+BuildRequires: rpm-pythonprov
+BuildRequires: python3-devel >= 1:3.5
+BuildRequires: python3-modules >= 1:3.5
+BuildRequires: python3-setuptools
+%if %{with tests}
+BuildRequires: python3-markupsafe >= 0.23
+BuildRequires: python3-pytest
+%endif
 %if %{with doc}
-BuildRequires: sphinx-pdg
+BuildRequires: python3-pallets-sphinx-themes >= 1.2.0
+BuildRequires: python3-sphinxcontrib-log-cabinet >= 1.0.1
+BuildRequires: python3-sphinx_issues >= 1.2.0
+BuildRequires: sphinx-pdg-3 >= 2.1.2
 %endif
-%pyrequires_eq python3-modules
+BuildArch:     noarch
+Requires:      python3-modules >= 1:3.5
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 A small but fast and easy to use stand-alone template engine written
-in pure python. Provides a Django inspired non-XML syntax but supports
+in pure Python. Provides a Django inspired non-XML syntax but supports
 inline expressions and an optional sandboxed environment.
 
-
 %description -l pl.UTF-8
-Mały ale szybkie i łatwy w użyciu samodzielny silnik szablonów
-napisany w czystym Pythonie. Dostarcza podobne do Django, o odmiennej
-od XMLa składni i kompliowane do kodu Pythona szablony w opcjonalnie
+Mały ale szybki i łatwy w użyciu samodzielny silnik szablonów napisany
+w czystym Pythonie. Udostępnia podobne do Django, o odmiennej od XML-a
+składni i kompilowane do kodu Pythona szablony w opcjonalnie
 ograniczonym środowisku.
 
+%package apidoc
+Summary:       Jinja2 template engine API documentation
+Summary(pl.UTF-8):     Dokumentacja API silnika szablonów Jinja2
+Group:         Development/Languages/Python
+
+%description apidoc
+API documentation for Jinja2 template engine.
+
+%description apidoc -l pl.UTF-8
+Dokumentacja API silnika szablonów Jinja2.
+
 %prep
 %setup -q -n Jinja2-%{version}
 
 %build
-%{__python3} setup.py build
+%py3_build
+
+%if %{with tests}
+PYTHONPATH=$(pwd)/src \
+%{__python3} -m pytest tests
+%endif
+
 %if %{with doc}
-cd docs
-make html
-rm -rf _build/html/_sources
+PYTHONPATH=$(pwd) \
+%{__make} -C docs -j1 html \
+       SPHINXBUILD=sphinx-build-3
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
-%{__python3} setup.py install \
-               --optimize=2 \
-               --root=$RPM_BUILD_ROOT
-
-%py3_postclean
+%py3_install
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc PKG-INFO AUTHORS CHANGES
+%doc CHANGES.rst LICENSE.rst README.rst
+%{py3_sitescriptdir}/%{module}
+%{py3_sitescriptdir}/Jinja2-%{version}-py*.egg-info
+
 %if %{with doc}
-%doc docs/_build/html
+%files apidoc
+%defattr(644,root,root,755)
+%doc docs/_build/html/{_static,*.html,*.js}
 %endif
-%{py3_sitescriptdir}/%{module}
-%{py3_sitescriptdir}/*Jinja*.egg*
This page took 0.053447 seconds and 4 git commands to generate.