]> git.pld-linux.org Git - packages/python3-itsdangerous.git/commitdiff
Initial. NFY.
authorMateusz Korniak <matkor@pld-linux.org>
Thu, 2 Oct 2014 11:22:21 +0000 (13:22 +0200)
committerMateusz Korniak <matkor@pld-linux.org>
Thu, 2 Oct 2014 11:22:21 +0000 (13:22 +0200)
python-itsdangeorous.spec [new file with mode: 0644]

diff --git a/python-itsdangeorous.spec b/python-itsdangeorous.spec
new file mode 100644 (file)
index 0000000..f923303
--- /dev/null
@@ -0,0 +1,163 @@
+#
+# Conditional build:
+%bcond_without doc             # don't build doc
+%bcond_without tests   # do not perform "make test"
+%bcond_without python2 # CPython 2.x module
+%bcond_without python3 # CPython 3.x module
+
+%define        module  itsdangerous
+Summary:       Various helpers to pass trusted data to untrusted environments and back.
+Summary(pl.UTF-8):     Wspomaganie przekazywania danych do i z niebezpiecznych środowisk
+Name:          python-%{module}
+Version:       0.24
+Release:       1
+License:       BSD
+Group:         Libraries/Python
+# https://pypi.python.org/packages/source/i/itsdangerous/itsdangerous-0.24.tar.gz#md5=a3d55aa79369aef5345c036a8a26307f
+Source0:       https://pypi.python.org/packages/source/i/%{module}/%{module}-%{version}.tar.gz
+# Source0-md5: -
+URL:           http://github.com/mitsuhiko/itsdangerous
+# remove BR: python-devel for 'noarch' packages.
+BuildRequires: rpm-pythonprov
+# if py_postclean is used
+BuildRequires: rpmbuild(macros) >= 1.219
+# when using /usr/bin/env or other in-place substitutions
+#BuildRequires:        sed >= 4.0
+%if %{with python2}
+BuildRequires: python-devel
+BuildRequires: python-distribute
+%endif
+%if %{with python3}
+BuildRequires: python3-devel
+BuildRequires: python3-distribute
+BuildRequires: python3-modules
+%endif
+# Below Rs only work for main package (python2)
+#Requires:             python-libs
+Requires:              python-modules
+#BuildArch:    noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Various helpers to pass data to untrusted environments and to get it back safe and sound.
+
+# %description -l pl.UTF-8
+
+%package -n python3-%{module}
+Summary:       Various helpers to pass data to untrusted environments and to get it back safe and sound.
+Summary(pl.UTF-8):     Wspomaganie przekazywania danych do i z niebezpiecznych środowisk
+Group:         Libraries/Python
+Requires:              python3-modules
+
+%description -n python3-%{module}
+
+%description -n python3-%{module} -l pl.UTF-8
+
+%package apidocs
+Summary:       %{module} API documentation
+Summary(pl.UTF-8):     Dokumentacja API %{module}
+Group:         Documentation
+
+%description apidocs
+API documentation for %{module}.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API %{module}.
+
+%prep
+%setup -q -n %{module}-%{version}
+
+# fix #!/usr/bin/env python -> #!/usr/bin/python:
+#%{__sed} -i -e '1s,^#!.*python,#!%{__python},' %{name}.py
+
+%build
+%if %{with python2}
+# CC/CFLAGS is only for arch packages - remove on noarch packages
+CC="%{__cc}" \
+CFLAGS="%{rpmcflags}" \
+%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+%endif
+
+%if %{with python3}
+# CC/CFLAGS is only for arch packages - remove on noarch packages
+CC="%{__cc}" \
+CFLAGS="%{rpmcflags}" \
+%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%endif
+
+%if %{with doc}
+cd docs
+%{__make} -j1 html
+rm -rf _build/html/_sources
+%endif
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%if %{with python2}
+%{__python} setup.py \
+       build --build-base build-2 \
+       install --skip-build \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+
+%py_postclean
+%endif
+
+%if %{with python3}
+%{__python3} setup.py \
+       build --build-base build-3 \
+       install --skip-build \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+%endif
+
+# in case there are examples provided
+%if %{with python2}
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+%endif
+%if %{with python3}
+install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
+cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
+find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version} -name '*.py' \
+       | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
+%endif
+
+# when files are installed in other way that standard 'setup.py
+# they need to be (re-)compiled
+## change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
+#%%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+#%%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+#%%py_postclean
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%if %{with python2}
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
+# change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
+%{py_sitedir}/*.py[co]
+%attr(755,root,root) %{py_sitedir}/*.so
+%if "%{py_ver}" > "2.4"
+%{py_sitedir}/%{module}-%{version}-py*.egg-info
+%endif
+%{_examplesdir}/%{name}-%{version}
+%endif
+
+%if %{with python3}
+%files -n python3-%{module}
+%defattr(644,root,root,755)
+%doc AUTHORS CHANGES LICENSE
+%{py3_sitescriptdir}/%{module}
+%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
+%{_examplesdir}/python3-%{module}-%{version}
+%endif
+
+%if %{with doc}
+%files apidocs
+%defattr(644,root,root,755)
+%doc docs/_build/html/*
+%endif
This page took 0.209433 seconds and 4 git commands to generate.