]> git.pld-linux.org Git - packages/python3-itsdangerous.git/blame - python-itsdangerous.spec
- python 3.5 rebuild
[packages/python3-itsdangerous.git] / python-itsdangerous.spec
CommitLineData
0c5794b0
MK
1#
2# Conditional build:
3%bcond_without doc # don't build doc
4%bcond_without tests # do not perform "make test"
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8%define module itsdangerous
9Summary: Various helpers to pass trusted data to untrusted environments and back
10Summary(pl.UTF-8): Wspomaganie przekazywania danych do i z niebezpiecznych środowisk
11Name: python-%{module}
12Version: 0.24
463b705d 13Release: 3
0c5794b0
MK
14License: BSD
15Group: Libraries/Python
16Source0: http://pypi.python.org/packages/source/i/%{module}/%{module}-%{version}.tar.gz
17# Source0-md5: a3d55aa79369aef5345c036a8a26307f
18URL: http://github.com/mitsuhiko/itsdangerous
19BuildRequires: rpm-pythonprov
20BuildRequires: rpmbuild(macros) >= 1.219
21%if %{with python2}
22BuildRequires: python-devel
23BuildRequires: python-distribute
24%endif
25%if %{with python3}
26BuildRequires: python3-devel
27BuildRequires: python3-distribute
28BuildRequires: python3-modules
29%endif
30Requires: python-modules
31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35Various helpers to pass data to untrusted environments and to get it
36back safe and sound.
37
38# %description -l pl.UTF-8
39
40%package -n python3-%{module}
41Summary: Various helpers to pass data to untrusted environments and to get it back safe and sound
42Summary(pl.UTF-8): Wspomaganie przekazywania danych do i z niebezpiecznych środowisk
43Group: Libraries/Python
44Requires: python3-modules
45
46%description -n python3-%{module}
47
48%description -n python3-%{module} -l pl.UTF-8
49
50%package apidocs
51Summary: %{module} API documentation
52Summary(pl.UTF-8): Dokumentacja API %{module}
53Group: Documentation
54
55%description apidocs
56API documentation for %{module}.
57
58%description apidocs -l pl.UTF-8
59Dokumentacja API %{module}.
60
61%prep
62%setup -q -n %{module}-%{version}
63
64
65%build
66%if %{with python2}
67%{__python} setup.py build --build-base build-2 %{?with_tests:test}
68%endif
69
70%if %{with python3}
71%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
72%endif
73
74%if %{with doc}
75cd docs
76%{__make} -j1 html
77rm -rf _build/html/_sources
78%endif
79
80%install
81rm -rf $RPM_BUILD_ROOT
82
83%if %{with python2}
84%{__python} setup.py \
85 build --build-base build-2 \
86 install --skip-build \
87 --optimize=2 \
88 --root=$RPM_BUILD_ROOT
89
90%py_postclean
91%endif
92
93%if %{with python3}
94%{__python3} setup.py \
95 build --build-base build-3 \
96 install --skip-build \
97 --optimize=2 \
98 --root=$RPM_BUILD_ROOT
99%endif
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%if %{with python2}
105%files
106%defattr(644,root,root,755)
107# %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
108%{py_sitescriptdir}/%{module}.py[co]
109%if "%{py_ver}" > "2.4"
110%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
111%endif
112%endif
113
114%if %{with python3}
115%files -n python3-%{module}
116%defattr(644,root,root,755)
117# %doc AUTHORS CHANGES LICENSE
118%{py3_sitescriptdir}/%{module}.py
119%{py3_sitescriptdir}/__pycache__/*.py[co]
120%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
121%endif
122
123%if %{with doc}
124%files apidocs
125%defattr(644,root,root,755)
126%doc docs/_build/html/*
127%endif
This page took 0.135426 seconds and 4 git commands to generate.