]> git.pld-linux.org Git - packages/python3-filelock.git/blobdiff - python-filelock.spec
use use pytest for running tests
[packages/python3-filelock.git] / python-filelock.spec
index 5d2c9e30050da035c90a6f4ea79166a3de9cb49b..3424646bb59f655548a4be87d8c9f44edccdb014 100644 (file)
@@ -2,29 +2,36 @@
 # Conditional build:
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
+%bcond_without tests   # unit tests (250+ processes created, max processes ulimit must allow it)
 
 Summary:       A platform independent file lock
 Summary(pl.UTF-8):     Niezależne od platformy blokady plikowe
 Name:          python-filelock
-Version:       3.0.10
-Release:       2
-License:       MIT
+Version:       3.2.1
+Release:       1
+License:       Public Domain
 Group:         Libraries/Python
 #Source0Download: https://pypi.org/simple/filelock/
 Source0:       https://files.pythonhosted.org/packages/source/f/filelock/filelock-%{version}.tar.gz
-# Source0-md5: df0006d2b1ec96473bfc0927de123aa6
+# Source0-md5: 92fea9fb4ebf39d746c77ec6c4c87be0
 URL:           https://pypi.org/project/filelock/
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with python2}
-BuildRequires: python-modules >= 1:2.5
+BuildRequires: python-modules >= 1:2.7
 BuildRequires: python-setuptools
+%if %{with tests}
+BuildRequires: python-pytest
+%endif
 %endif
 %if %{with python3}
-BuildRequires: python3-modules >= 1:3.2
+BuildRequires: python3-modules >= 1:3.4
 BuildRequires: python3-setuptools
+%if %{with tests}
+BuildRequires: python3-pytest
+%endif
 %endif
-Requires:      python-modules >= 1:2.5
+Requires:      python-modules >= 1:2.7
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -42,7 +49,7 @@ komunikacji międzyprocesowej.
 Summary:       A platform independent file lock
 Summary(pl.UTF-8):     Niezależne od platformy blokady plikowe
 Group:         Libraries/Python
-Requires:      python3-modules >= 1:3.2
+Requires:      python3-modules >= 1:3.4
 
 %description -n python3-filelock
 This package contains a single module, which implements a platform
@@ -60,10 +67,20 @@ komunikacji międzyprocesowej.
 %build
 %if %{with python2}
 %py_build
+
+%if %{with tests}
+PYTHONPATH=$(pwd)/src \
+%{__python} -m pytest tests
+%endif
 %endif
 
 %if %{with python3}
 %py3_build
+
+%if %{with tests}
+PYTHONPATH=$(pwd)/src \
+%{__python3} -m pytest tests
+%endif
 %endif
 
 %install
@@ -85,16 +102,15 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc LICENSE.rst README.rst
-%{py_sitescriptdir}/filelock.py[co]
+%doc LICENSE README.md
+%{py_sitescriptdir}/filelock
 %{py_sitescriptdir}/filelock-%{version}-py*.egg-info
 %endif
 
 %if %{with python3}
 %files -n python3-filelock
 %defattr(644,root,root,755)
-%doc LICENSE.rst README.rst
-%{py3_sitescriptdir}/filelock.py
-%{py3_sitescriptdir}/__pycache__/filelock.cpython-*.py[co]
+%doc LICENSE README.md
+%{py3_sitescriptdir}/filelock
 %{py3_sitescriptdir}/filelock-%{version}-py*.egg-info
 %endif
This page took 0.175976 seconds and 4 git commands to generate.