]> git.pld-linux.org Git - packages/python3-filelock.git/blame - python3-filelock.spec
- BR: setuptools_scm
[packages/python3-filelock.git] / python3-filelock.spec
CommitLineData
ca3a53d5
JB
1# TODO: finish doc
2#
3# Conditional build:
4%bcond_without tests # unit tests (250+ processes created, max processes ulimit must allow it)
5%bcond_with doc # Sphinx documentation
6
7Summary: A platform independent file lock
8Summary(pl.UTF-8): Niezależne od platformy blokady plikowe
9Name: python3-filelock
e8fce8d2
JB
10Version: 3.7.1
11Release: 1
ca3a53d5
JB
12License: Public Domain
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/filelock/
15Source0: https://files.pythonhosted.org/packages/source/f/filelock/filelock-%{version}.tar.gz
e8fce8d2 16# Source0-md5: cda4ead6a7ee1e6103d27aaf67c8d327
ca3a53d5
JB
17URL: https://pypi.org/project/filelock/
18BuildRequires: python3-modules >= 1:3.7
6b3ee063
JB
19BuildRequires: python3-setuptools >= 1:41.0.0
20BuildRequires: python3-setuptools_scm >= 2
ca3a53d5
JB
21%if %{with tests}
22BuildRequires: python3-pytest >= 4
23BuildRequires: python3-pytest-timeout >= 1.4.2
24%endif
25BuildRequires: rpm-pythonprov
26BuildRequires: rpmbuild(macros) >= 1.714
27%if %{with doc}
28BuildRequires: python3-furo >= 2021.8.17b43
29BuildRequires: python3-sphinx-autodoc-typehints >= 1.12
30BuildRequires: sphinx-pdg >= 4.1
31%endif
32Requires: python3-modules >= 1:3.7
33BuildArch: noarch
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37This package contains a single module, which implements a platform
38independent file lock in Python, which provides a simple way of
39inter-process communication.
40
41%description -l pl.UTF-8
42Ten pakiet zawiera pojedynczny moduł implementujący niezależne od
43platformy blokady plikowe w Pythonie. Zapewniają one prosty sposób
44komunikacji międzyprocesowej.
45
46%prep
47%setup -q -n filelock-%{version}
48
49%build
50%py3_build
51
52%if %{with tests}
53PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
54PYTEST_PLUGINS=pytest_timeout \
55PYTHONPATH=$(pwd)/src \
56%{__python3} -m pytest tests
57%endif
58
59%if %{with doc}
60sphinx-build -b html -d docs/_build/doctree docs docs/_build/html
61%endif
62
63%install
64rm -rf $RPM_BUILD_ROOT
65
66%py3_install
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%files
72%defattr(644,root,root,755)
73%doc LICENSE README.md
74%{py3_sitescriptdir}/filelock
75%{py3_sitescriptdir}/filelock-%{version}-py*.egg-info
This page took 2.647794 seconds and 4 git commands to generate.