]> git.pld-linux.org Git - packages/python3-filelock.git/blame - python-filelock.spec
- release 2 (by relup.sh)
[packages/python3-filelock.git] / python-filelock.spec
CommitLineData
a93e6fa9
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
d2f5553e 5%bcond_without tests # unit tests (250+ processes created, max processes ulimit must allow it)
a93e6fa9
JB
6
7Summary: A platform independent file lock
8Summary(pl.UTF-8): Niezależne od platformy blokady plikowe
9Name: python-filelock
d2f5553e 10Version: 3.0.12
c18c4d2f 11Release: 2
d2f5553e 12License: Public Domain
a93e6fa9
JB
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/filelock/
15Source0: https://files.pythonhosted.org/packages/source/f/filelock/filelock-%{version}.tar.gz
d2f5553e 16# Source0-md5: c1fe6d9a7433a7ca6ce4f36e273317d1
a93e6fa9
JB
17URL: https://pypi.org/project/filelock/
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
d2f5553e 21BuildRequires: python-modules >= 1:2.7
a93e6fa9
JB
22BuildRequires: python-setuptools
23%endif
24%if %{with python3}
d2f5553e 25BuildRequires: python3-modules >= 1:3.4
a93e6fa9
JB
26BuildRequires: python3-setuptools
27%endif
d2f5553e 28Requires: python-modules >= 1:2.7
a93e6fa9
JB
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33This package contains a single module, which implements a platform
34independent file lock in Python, which provides a simple way of
35inter-process communication.
36
37%description -l pl.UTF-8
38Ten pakiet zawiera pojedynczny moduł implementujący niezależne od
39platformy blokady plikowe w Pythonie. Zapewniają one prosty sposób
40komunikacji międzyprocesowej.
41
42%package -n python3-filelock
43Summary: A platform independent file lock
44Summary(pl.UTF-8): Niezależne od platformy blokady plikowe
45Group: Libraries/Python
d2f5553e 46Requires: python3-modules >= 1:3.4
a93e6fa9
JB
47
48%description -n python3-filelock
49This package contains a single module, which implements a platform
50independent file lock in Python, which provides a simple way of
51inter-process communication.
52
53%description -n python3-filelock -l pl.UTF-8
54Ten pakiet zawiera pojedynczny moduł implementujący niezależne od
55platformy blokady plikowe w Pythonie. Zapewniają one prosty sposób
56komunikacji międzyprocesowej.
57
58%prep
59%setup -q -n filelock-%{version}
60
61%build
62%if %{with python2}
63%py_build
d2f5553e
JB
64
65%if %{with tests}
66%{__python} test.py
67%endif
a93e6fa9
JB
68%endif
69
70%if %{with python3}
71%py3_build
d2f5553e
JB
72
73%if %{with tests}
74%{__python3} test.py
75%endif
a93e6fa9
JB
76%endif
77
78%install
79rm -rf $RPM_BUILD_ROOT
80
81%if %{with python2}
82%py_install
83
84%py_postclean
85%endif
86
87%if %{with python3}
88%py3_install
89%endif
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%if %{with python2}
95%files
96%defattr(644,root,root,755)
d2f5553e 97%doc LICENSE README.md
a93e6fa9
JB
98%{py_sitescriptdir}/filelock.py[co]
99%{py_sitescriptdir}/filelock-%{version}-py*.egg-info
100%endif
101
102%if %{with python3}
103%files -n python3-filelock
104%defattr(644,root,root,755)
d2f5553e 105%doc LICENSE README.md
a93e6fa9
JB
106%{py3_sitescriptdir}/filelock.py
107%{py3_sitescriptdir}/__pycache__/filelock.cpython-*.py[co]
108%{py3_sitescriptdir}/filelock-%{version}-py*.egg-info
109%endif
This page took 0.099877 seconds and 4 git commands to generate.