]> git.pld-linux.org Git - packages/python3-filelock.git/blame - python-filelock.spec
- new
[packages/python3-filelock.git] / python-filelock.spec
CommitLineData
a93e6fa9
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: A platform independent file lock
7Summary(pl.UTF-8): Niezależne od platformy blokady plikowe
8Name: python-filelock
9Version: 3.0.10
10Release: 1
11License: MIT
12Group: Libraries/Python
13#Source0Download: https://pypi.org/simple/filelock/
14Source0: https://files.pythonhosted.org/packages/source/f/filelock/filelock-%{version}.tar.gz
15# Source0-md5: df0006d2b1ec96473bfc0927de123aa6
16URL: https://pypi.org/project/filelock/
17BuildRequires: rpm-pythonprov
18BuildRequires: rpmbuild(macros) >= 1.714
19%if %{with python2}
20BuildRequires: python-modules >= 1:2.5
21BuildRequires: python-setuptools
22%endif
23%if %{with python3}
24BuildRequires: python3-modules >= 1:3.2
25BuildRequires: python3-setuptools
26%endif
27Requires: python-modules >= 1:2.5
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32This package contains a single module, which implements a platform
33independent file lock in Python, which provides a simple way of
34inter-process communication.
35
36%description -l pl.UTF-8
37Ten pakiet zawiera pojedynczny moduł implementujący niezależne od
38platformy blokady plikowe w Pythonie. Zapewniają one prosty sposób
39komunikacji międzyprocesowej.
40
41%package -n python3-filelock
42Summary: A platform independent file lock
43Summary(pl.UTF-8): Niezależne od platformy blokady plikowe
44Group: Libraries/Python
45Requires: python3-modules >= 1:3.2
46
47%description -n python3-filelock
48This package contains a single module, which implements a platform
49independent file lock in Python, which provides a simple way of
50inter-process communication.
51
52%description -n python3-filelock -l pl.UTF-8
53Ten pakiet zawiera pojedynczny moduł implementujący niezależne od
54platformy blokady plikowe w Pythonie. Zapewniają one prosty sposób
55komunikacji międzyprocesowej.
56
57%prep
58%setup -q -n filelock-%{version}
59
60%build
61%if %{with python2}
62%py_build
63%endif
64
65%if %{with python3}
66%py3_build
67%endif
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72%if %{with python2}
73%py_install
74
75%py_postclean
76%endif
77
78%if %{with python3}
79%py3_install
80%endif
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%if %{with python2}
86%files
87%defattr(644,root,root,755)
88%doc LICENSE.rst README.rst
89%{py_sitescriptdir}/filelock.py[co]
90%{py_sitescriptdir}/filelock-%{version}-py*.egg-info
91%endif
92
93%if %{with python3}
94%files -n python3-filelock
95%defattr(644,root,root,755)
96%doc LICENSE.rst README.rst
97%{py3_sitescriptdir}/filelock.py
98%{py3_sitescriptdir}/__pycache__/filelock.cpython-*.py[co]
99%{py3_sitescriptdir}/filelock-%{version}-py*.egg-info
100%endif
This page took 0.104538 seconds and 4 git commands to generate.