]> git.pld-linux.org Git - packages/python3-cryptography.git/commitdiff
- updated to 1.3.1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 24 Mar 2016 16:03:24 +0000 (17:03 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 24 Mar 2016 16:03:24 +0000 (17:03 +0100)
python-cryptography.spec

index 67396c3449a2e50a1e5b8e4b358302c7b71e7220..b3f93665f21e92d771d32037df540a5a0cdbbc01 100644 (file)
@@ -1,35 +1,61 @@
 #
 # Conditional build:
-%bcond_without  python2 # CPython 2.x module
-%bcond_without  python3 # CPython 3.x module
+%bcond_without python2 # CPython 2.x module
+%bcond_without python3 # CPython 3.x module
+%bcond_with    tests   # test target [not all dependencies are currently available in PLD]
 
 Summary:       Crypthography library for Python 2
 Summary(pl.UTF-8):     Biblioteka Cryptography dla Pythona 2
 Name:          python-cryptography
-Version:       1.2.3
-Release:       3
+Version:       1.3.1
+Release:       1
 License:       Apache v2.0 or BSD
 Group:         Libraries/Python
+#Source0Download: https://pypi.python.org/simple/cryptography/
 Source0:       https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
-# Source0-md5: 5474d2b3e8c7555a60852e48d2743f85
+# Source0-md5: bc8148d2ff2d80fef8ef2d2e856b3a7f
 URL:           https://cryptography.io/
 BuildRequires: openssl-devel >= 0.9.8
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.710
+BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with python2}
 BuildRequires: python-cffi >= 1.4.1
 BuildRequires: python-devel >= 1:2.6
 BuildRequires: python-enum34
 BuildRequires: python-pyasn1 >= 0.1.8
-BuildRequires: python-setuptools
+BuildRequires: python-setuptools >= 11.3
 BuildRequires: python-six >= 1.4.1
+%if %{with tests}
+BuildRequires: python-cryptography_vectors
+%if "%{py_ver}" >= "2.7"
+BuildRequires: python-hypothesis >= 1.11.4
+%endif
+BuildRequires: python-idna >= 2.0
+BuildRequires: python-ipaddress
+BuildRequires: python-iso8601
+BuildRequires: python-pretend
+BuildRequires: python-pyasn1_modules
+BuildRequires: python-pytest
+%endif
 %endif
 %if %{with python3}
 BuildRequires: python3-cffi >= 1.4.1
-BuildRequires: python3-devel >= 1:3.2
+BuildRequires: python3-devel >= 1:3.3
+%if "%{py3_ver}" < "3.4"
+BuildRequires: python3-enum34
+%endif
 BuildRequires: python3-pyasn1 >= 0.1.8
-BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools >= 11.3
 BuildRequires: python3-six >= 1.4.1
+%if %{with tests}
+BuildRequires: python3-cryptography_vectors
+BuildRequires: python3-hypothesis >= 1.11.4
+BuildRequires: python3-idna >= 2.0
+BuildRequires: python3-iso8601
+BuildRequires: python3-pretend
+BuildRequires: python3-pyasn1_modules
+BuildRequires: python3-pytest
+%endif
 %endif
 Requires:      python-cffi >= 1.4.1
 Requires:      python-six >= 1.4.1
@@ -65,6 +91,9 @@ Summary:      Crypthography library for Python 3
 Summary(pl.UTF-8):     Biblioteka Cryptography dla Pythona 3
 Group:         Libraries/Python
 Requires:      python3-cffi >= 1.4.1
+%if "%{py3_ver}" < "3.4"
+BuildRequires: python3-enum34
+%endif
 Requires:      python3-six >= 1.4.1
 
 %description -n python3-cryptography
@@ -99,13 +128,11 @@ Ten pakiet zawiera moduĊ‚y Pythona 3.
 export CFLAGS="%{rpmcflags}"
 
 %if %{with python2}
-%py_build \
-       --build-base build-2
+%py_build %{?with_tests:test}
 %endif
 
 %if %{with python2}
-%py3_build \
-       --build-base build-3
+%py3_build %{?with_tests:test}
 %endif
 
 %install
@@ -127,7 +154,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
+%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
 %dir %{py_sitedir}/cryptography
 %{py_sitedir}/cryptography/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat
@@ -165,7 +192,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-cryptography
 %defattr(644,root,root,755)
-%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
+%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
 %dir %{py3_sitedir}/cryptography
 %{py3_sitedir}/cryptography/*.py
 %{py3_sitedir}/cryptography/__pycache__
This page took 0.192043 seconds and 4 git commands to generate.