]> git.pld-linux.org Git - packages/python3-cryptography.git/blobdiff - python-cryptography.spec
- rel 2; bump cffi deps
[packages/python3-cryptography.git] / python-cryptography.spec
index d188b3cea9baa976c663380e8754208f1d7aab3b..8cb876beabe23fcb6ad702ee71a81cb6eb4c35d2 100644 (file)
@@ -6,27 +6,32 @@
 Summary:       Crypthography library for Python 2
 Summary(pl.UTF-8):     Biblioteka Cryptography dla Pythona 2
 Name:          python-cryptography
-Version:       0.5.2
+Version:       1.2.3
 Release:       2
-License:       Apache v2.0
+License:       Apache v2.0 or BSD
 Group:         Libraries/Python
 Source0:       https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
-# Source0-md5: 8c2d381ef263653b640a7a5d14618e4c
+# Source0-md5: 5474d2b3e8c7555a60852e48d2743f85
 URL:           https://cryptography.io/
 BuildRequires: openssl-devel >= 0.9.8
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.710
 %if %{with python2}
+BuildRequires: python-cffi >= 1.4.1
 BuildRequires: python-devel >= 1:2.6
-BuildRequires: python-cffi >= 0.8
+BuildRequires: python-enum34
+BuildRequires: python-pyasn1
+BuildRequires: python-setuptools
 BuildRequires: python-six >= 1.4.1
 %endif
 %if %{with python3}
+BuildRequires: python3-cffi >= 1.4.1
 BuildRequires: python3-devel >= 1:3.2
-BuildRequires: python3-cffi >= 0.8
+BuildRequires: python3-pyasn1
+BuildRequires: python3-setuptools
 BuildRequires: python3-six >= 1.4.1
 %endif
-BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.612
-Requires:      python-cffi >= 0.8
+Requires:      python-cffi >= 1.4.1
 Requires:      python-six >= 1.4.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -50,7 +55,7 @@ Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
 
 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
-takich jak szyfry symetryczne, skróty wiadomości czy funkcje 
+takich jak szyfry symetryczne, skróty wiadomości czy funkcje
 wyprowadzające klucze.
 
 Ten pakiet zawiera moduły Pythona 2.
@@ -59,7 +64,7 @@ Ten pakiet zawiera moduły Pythona 2.
 Summary:       Crypthography library for Python 3
 Summary(pl.UTF-8):     Biblioteka Cryptography dla Pythona 3
 Group:         Libraries/Python
-Requires:      python3-cffi >= 0.8
+Requires:      python3-cffi >= 1.4.1
 Requires:      python3-six >= 1.4.1
 
 %description -n python3-cryptography
@@ -82,7 +87,7 @@ Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
 
 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
-takich jak szyfry symetryczne, skróty wiadomości czy funkcje 
+takich jak szyfry symetryczne, skróty wiadomości czy funkcje
 wyprowadzające klucze.
 
 Ten pakiet zawiera moduły Pythona 3.
@@ -94,12 +99,12 @@ Ten pakiet zawiera moduły Pythona 3.
 export CFLAGS="%{rpmcflags}"
 
 %if %{with python2}
-%{__python} setup.py build \
+%py_build \
        --build-base build-2
 %endif
 
 %if %{with python2}
-%{__python3} setup.py build \
+%py3_build \
        --build-base build-3
 %endif
 
@@ -107,21 +112,13 @@ export CFLAGS="%{rpmcflags}"
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
-%{__python} setup.py \
-       build   --build-base build-2 \
-       install --skip-build \
-               --optimize=2 \
-               --root=$RPM_BUILD_ROOT
+%py_install
 
 %py_postclean
 %endif
 
 %if %{with python3}
-%{__python3} setup.py \
-       build   --build-base build-3 \
-       install --skip-build \
-               --optimize=2 \
-               --root=$RPM_BUILD_ROOT
+%py3_install
 %endif
 
 %clean
@@ -130,9 +127,8 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS.rst README.rst
+%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
 %dir %{py_sitedir}/cryptography
-%attr(755,root,root) %{py_sitedir}/cryptography/_*_cffi_*.so
 %{py_sitedir}/cryptography/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat
 %{py_sitedir}/cryptography/hazmat/*.py[co]
@@ -144,10 +140,13 @@ rm -rf $RPM_BUILD_ROOT
 %{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/bindings
 %{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
+%attr(755,root,root) %{py_sitedir}/cryptography/hazmat/bindings/_*.so
 %dir %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto
 %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
 %{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
+%dir %{py_sitedir}/cryptography/hazmat/primitives/interfaces
+%{py_sitedir}/cryptography/hazmat/primitives/interfaces/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/primitives
 %{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
@@ -158,15 +157,16 @@ rm -rf $RPM_BUILD_ROOT
 %{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
 %{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
+%dir %{py_sitedir}/cryptography/x509
+%{py_sitedir}/cryptography/x509/*.py[co]
 %{py_sitedir}/cryptography-%{version}-py*.egg-info
 %endif
 
 %if %{with python3}
 %files -n python3-cryptography
 %defattr(644,root,root,755)
-%doc AUTHORS.rst README.rst
+%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
 %dir %{py3_sitedir}/cryptography
-%attr(755,root,root) %{py3_sitedir}/cryptography/_*_cffi_*.so
 %{py3_sitedir}/cryptography/*.py
 %{py3_sitedir}/cryptography/__pycache__
 %dir %{py3_sitedir}/cryptography/hazmat
@@ -184,12 +184,16 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py3_sitedir}/cryptography/hazmat/bindings
 %{py3_sitedir}/cryptography/hazmat/bindings/*.py
 %{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
+%attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
 %dir %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto
 %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py
 %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/__pycache__
 %dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
+%dir %{py3_sitedir}/cryptography/hazmat/primitives/interfaces
+%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/*.py
+%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/__pycache__
 %dir %{py3_sitedir}/cryptography/hazmat/primitives
 %{py3_sitedir}/cryptography/hazmat/primitives/*.py
 %{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
@@ -205,5 +209,8 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
 %{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
 %{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
+%dir %{py3_sitedir}/cryptography/x509
+%{py3_sitedir}/cryptography/x509/*.py
+%{py3_sitedir}/cryptography/x509/__pycache__
 %{py3_sitedir}/cryptography-%{version}-py*.egg-info
 %endif
This page took 0.103595 seconds and 4 git commands to generate.