]> git.pld-linux.org Git - packages/python3-cryptography.git/blobdiff - python-cryptography.spec
- require fixed rpm-pythonprov instead
[packages/python3-cryptography.git] / python-cryptography.spec
index 35cc20df1b7365e402b2df2098afa933c053c38a..551ab8724255f9ea2ac73068c56bc51b50e5a96c 100644 (file)
@@ -1,37 +1,61 @@
 #
 # Conditional build:
-%bcond_without  python2 # CPython 2.x module
-%bcond_without  python3 # CPython 3.x module
+%bcond_without python2 # CPython 2.x module
+%bcond_without python3 # CPython 3.x module
+%bcond_with    tests   # test target [not all dependencies are currently available in PLD]
 
 Summary:       Crypthography library for Python 2
 Summary(pl.UTF-8):     Biblioteka Cryptography dla Pythona 2
 Name:          python-cryptography
-Version:       1.2.3
-Release:       1
+Version:       2.3.1
+Release:       2
 License:       Apache v2.0 or BSD
 Group:         Libraries/Python
-Source0:       https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
-# Source0-md5: 5474d2b3e8c7555a60852e48d2743f85
+#Source0Download: https://pypi.python.org/simple/cryptography/
+Source0:       https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
+# Source0-md5: 2b5e8269c43c9b9ab54fc8c75ba3c7ac
 URL:           https://cryptography.io/
-BuildRequires: openssl-devel >= 0.9.8
-BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.710
+BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: rpm-pythonprov >= 5.4.15-48
+BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with python2}
-BuildRequires: python-cffi >= 0.8
+BuildRequires: python-cffi >= 1.4.1
 BuildRequires: python-devel >= 1:2.6
 BuildRequires: python-enum34
-BuildRequires: python-pyasn1
-BuildRequires: python-setuptools
+BuildRequires: python-pyasn1 >= 0.1.8
+BuildRequires: python-setuptools >= 11.3
 BuildRequires: python-six >= 1.4.1
+%if %{with tests}
+BuildRequires: python-cryptography_vectors
+%if "%{py_ver}" >= "2.7"
+BuildRequires: python-hypothesis >= 1.11.4
+%endif
+BuildRequires: python-idna >= 2.0
+BuildRequires: python-ipaddress
+BuildRequires: python-iso8601
+BuildRequires: python-pretend
+BuildRequires: python-pyasn1_modules
+BuildRequires: python-pytest
+%endif
 %endif
 %if %{with python3}
-BuildRequires: python3-cffi >= 0.8
-BuildRequires: python3-devel >= 1:3.2
-BuildRequires: python3-pyasn1
-BuildRequires: python3-setuptools
+BuildRequires: python3-cffi >= 1.4.1
+BuildRequires: python3-devel >= 1:3.4
+BuildRequires: python3-pyasn1 >= 0.1.8
+BuildRequires: python3-setuptools >= 11.3
 BuildRequires: python3-six >= 1.4.1
+%if %{with tests}
+BuildRequires: python3-cryptography_vectors
+BuildRequires: python3-hypothesis >= 1.11.4
+BuildRequires: python3-idna >= 2.0
+BuildRequires: python3-iso8601
+BuildRequires: python3-pretend
+BuildRequires: python3-pyasn1_modules
+BuildRequires: python3-pytest
+%endif
 %endif
-Requires:      python-cffi >= 0.8
+Requires:      openssl >= 1.0.1
+Requires:      python-cffi >= 1.4.1
 Requires:      python-six >= 1.4.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -64,7 +88,8 @@ Ten pakiet zawiera moduły Pythona 2.
 Summary:       Crypthography library for Python 3
 Summary(pl.UTF-8):     Biblioteka Cryptography dla Pythona 3
 Group:         Libraries/Python
-Requires:      python3-cffi >= 0.8
+Requires:      openssl >= 1.0.1
+Requires:      python3-cffi >= 1.4.1
 Requires:      python3-six >= 1.4.1
 
 %description -n python3-cryptography
@@ -99,13 +124,11 @@ Ten pakiet zawiera moduły Pythona 3.
 export CFLAGS="%{rpmcflags}"
 
 %if %{with python2}
-%py_build \
-       --build-base build-2
+%py_build %{?with_tests:test}
 %endif
 
 %if %{with python2}
-%py3_build \
-       --build-base build-3
+%py3_build %{?with_tests:test}
 %endif
 
 %install
@@ -127,26 +150,20 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
+%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
 %dir %{py_sitedir}/cryptography
 %{py_sitedir}/cryptography/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat
 %{py_sitedir}/cryptography/hazmat/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/backends
 %{py_sitedir}/cryptography/hazmat/backends/*.py[co]
-%dir %{py_sitedir}/cryptography/hazmat/backends/commoncrypto
-%{py_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/backends/openssl
 %{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/bindings
 %{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
 %attr(755,root,root) %{py_sitedir}/cryptography/hazmat/bindings/_*.so
-%dir %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto
-%{py_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
 %{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
-%dir %{py_sitedir}/cryptography/hazmat/primitives/interfaces
-%{py_sitedir}/cryptography/hazmat/primitives/interfaces/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/primitives
 %{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
 %dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
@@ -165,7 +182,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-cryptography
 %defattr(644,root,root,755)
-%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
+%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
 %dir %{py3_sitedir}/cryptography
 %{py3_sitedir}/cryptography/*.py
 %{py3_sitedir}/cryptography/__pycache__
@@ -175,9 +192,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{py3_sitedir}/cryptography/hazmat/backends
 %{py3_sitedir}/cryptography/hazmat/backends/*.py
 %{py3_sitedir}/cryptography/hazmat/backends/__pycache__
-%dir %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto
-%{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py
-%{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/__pycache__
 %dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
 %{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
 %{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
@@ -185,15 +199,9 @@ rm -rf $RPM_BUILD_ROOT
 %{py3_sitedir}/cryptography/hazmat/bindings/*.py
 %{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
 %attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
-%dir %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto
-%{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py
-%{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/__pycache__
 %dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
-%dir %{py3_sitedir}/cryptography/hazmat/primitives/interfaces
-%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/*.py
-%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/__pycache__
 %dir %{py3_sitedir}/cryptography/hazmat/primitives
 %{py3_sitedir}/cryptography/hazmat/primitives/*.py
 %{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
This page took 0.038329 seconds and 4 git commands to generate.