]> git.pld-linux.org Git - packages/python3-cryptography.git/blob - python-cryptography.spec
up to 0.8.2, dual licensed ASL 2.0 and BSD
[packages/python3-cryptography.git] / python-cryptography.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Crypthography library for Python 2
7 Summary(pl.UTF-8):      Biblioteka Cryptography dla Pythona 2
8 Name:           python-cryptography
9 Version:        0.8.2
10 Release:        1
11 License:        Apache v2.0 or BSD
12 Group:          Libraries/Python
13 Source0:        https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
14 # Source0-md5:  7d33499e851300c194cbb0396de72462
15 URL:            https://cryptography.io/
16 BuildRequires:  openssl-devel >= 0.9.8
17 %if %{with python2}
18 BuildRequires:  python-devel >= 1:2.6
19 BuildRequires:  python-cffi >= 0.8
20 BuildRequires:  python-six >= 1.4.1
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-devel >= 1:3.2
24 BuildRequires:  python3-cffi >= 0.8
25 BuildRequires:  python3-six >= 1.4.1
26 %endif
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.612
29 Requires:       python-cffi >= 0.8
30 Requires:       python-six >= 1.4.1
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 cryptography is a package designed to expose cryptographic recipes and
35 primitives to Python developers. Our goal is for it to be your
36 "cryptographic standard library". It supports Python 2.6-2.7, Python
37 3.2+, and PyPy.
38
39 cryptography includes both high level recipes, and low level
40 interfaces to common cryptographic algorithms such as symmetric
41 ciphers, message digests and key derivation functions.
42
43 This package contains Python 2 modules.
44
45 %description -l pl.UTF-8
46 cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
47 obiektów kryptograficznych programistom Pythona. Celem jest
48 dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
49 Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
50
51 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
52 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
53 takich jak szyfry symetryczne, skróty wiadomości czy funkcje 
54 wyprowadzające klucze.
55
56 Ten pakiet zawiera moduły Pythona 2.
57
58 %package -n python3-cryptography
59 Summary:        Crypthography library for Python 3
60 Summary(pl.UTF-8):      Biblioteka Cryptography dla Pythona 3
61 Group:          Libraries/Python
62 Requires:       python3-cffi >= 0.8
63 Requires:       python3-six >= 1.4.1
64
65 %description -n python3-cryptography
66 cryptography is a package designed to expose cryptographic recipes and
67 primitives to Python developers. Our goal is for it to be your
68 "cryptographic standard library". It supports Python 2.6-2.7, Python
69 3.2+, and PyPy.
70
71 cryptography includes both high level recipes, and low level
72 interfaces to common cryptographic algorithms such as symmetric
73 ciphers, message digests and key derivation functions.
74
75 This package contains Python 3 modules.
76
77 %description -n python3-cryptography -l pl.UTF-8
78 cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
79 obiektów kryptograficznych programistom Pythona. Celem jest
80 dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
81 Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
82
83 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
84 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
85 takich jak szyfry symetryczne, skróty wiadomości czy funkcje 
86 wyprowadzające klucze.
87
88 Ten pakiet zawiera moduły Pythona 3.
89
90 %prep
91 %setup -q -n cryptography-%{version}
92
93 %build
94 export CFLAGS="%{rpmcflags}"
95
96 %if %{with python2}
97 %{__python} setup.py build \
98         --build-base build-2
99 %endif
100
101 %if %{with python2}
102 %{__python3} setup.py build \
103         --build-base build-3
104 %endif
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %if %{with python2}
110 %{__python} setup.py \
111         build   --build-base build-2 \
112         install --skip-build \
113                 --optimize=2 \
114                 --root=$RPM_BUILD_ROOT
115
116 %py_postclean
117 %endif
118
119 %if %{with python3}
120 %{__python3} setup.py \
121         build   --build-base build-3 \
122         install --skip-build \
123                 --optimize=2 \
124                 --root=$RPM_BUILD_ROOT
125 %endif
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %if %{with python2}
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
134 %dir %{py_sitedir}/cryptography
135 %attr(755,root,root) %{py_sitedir}/cryptography/_*_cffi_*.so
136 %{py_sitedir}/cryptography/*.py[co]
137 %dir %{py_sitedir}/cryptography/hazmat
138 %{py_sitedir}/cryptography/hazmat/*.py[co]
139 %dir %{py_sitedir}/cryptography/hazmat/backends
140 %{py_sitedir}/cryptography/hazmat/backends/*.py[co]
141 %dir %{py_sitedir}/cryptography/hazmat/backends/commoncrypto
142 %{py_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py[co]
143 %dir %{py_sitedir}/cryptography/hazmat/backends/openssl
144 %{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
145 %dir %{py_sitedir}/cryptography/hazmat/bindings
146 %{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
147 %dir %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto
148 %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py[co]
149 %dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
150 %{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
151 %dir %{py_sitedir}/cryptography/hazmat/primitives
152 %{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
153 %dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
154 %{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
155 %dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
156 %{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
157 %dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
158 %{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
159 %dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
160 %{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
161 %{py_sitedir}/cryptography-%{version}-py*.egg-info
162 %endif
163
164 %if %{with python3}
165 %files -n python3-cryptography
166 %defattr(644,root,root,755)
167 %doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
168 %dir %{py3_sitedir}/cryptography
169 %attr(755,root,root) %{py3_sitedir}/cryptography/_*_cffi_*.so
170 %{py3_sitedir}/cryptography/*.py
171 %{py3_sitedir}/cryptography/__pycache__
172 %dir %{py3_sitedir}/cryptography/hazmat
173 %{py3_sitedir}/cryptography/hazmat/*.py
174 %{py3_sitedir}/cryptography/hazmat/__pycache__
175 %dir %{py3_sitedir}/cryptography/hazmat/backends
176 %{py3_sitedir}/cryptography/hazmat/backends/*.py
177 %{py3_sitedir}/cryptography/hazmat/backends/__pycache__
178 %dir %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto
179 %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py
180 %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/__pycache__
181 %dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
182 %{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
183 %{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
184 %dir %{py3_sitedir}/cryptography/hazmat/bindings
185 %{py3_sitedir}/cryptography/hazmat/bindings/*.py
186 %{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
187 %dir %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto
188 %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py
189 %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/__pycache__
190 %dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
191 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
192 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
193 %dir %{py3_sitedir}/cryptography/hazmat/primitives
194 %{py3_sitedir}/cryptography/hazmat/primitives/*.py
195 %{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
196 %dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
197 %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
198 %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
199 %dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
200 %{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
201 %{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
202 %dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
203 %{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
204 %{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
205 %dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
206 %{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
207 %{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
208 %{py3_sitedir}/cryptography-%{version}-py*.egg-info
209 %endif
This page took 0.073363 seconds and 4 git commands to generate.