]> git.pld-linux.org Git - packages/python3-cryptography.git/blob - python-cryptography.spec
- python 3.6
[packages/python3-cryptography.git] / python-cryptography.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5 %bcond_with     tests   # test target [not all dependencies are currently available in PLD]
6
7 Summary:        Crypthography library for Python 2
8 Summary(pl.UTF-8):      Biblioteka Cryptography dla Pythona 2
9 Name:           python-cryptography
10 Version:        1.3.1
11 Release:        2
12 License:        Apache v2.0 or BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/simple/cryptography/
15 Source0:        https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
16 # Source0-md5:  bc8148d2ff2d80fef8ef2d2e856b3a7f
17 URL:            https://cryptography.io/
18 BuildRequires:  openssl-devel >= 0.9.8
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 %if %{with python2}
22 BuildRequires:  python-cffi >= 1.4.1
23 BuildRequires:  python-devel >= 1:2.6
24 BuildRequires:  python-enum34
25 BuildRequires:  python-pyasn1 >= 0.1.8
26 BuildRequires:  python-setuptools >= 11.3
27 BuildRequires:  python-six >= 1.4.1
28 %if %{with tests}
29 BuildRequires:  python-cryptography_vectors
30 %if "%{py_ver}" >= "2.7"
31 BuildRequires:  python-hypothesis >= 1.11.4
32 %endif
33 BuildRequires:  python-idna >= 2.0
34 BuildRequires:  python-ipaddress
35 BuildRequires:  python-iso8601
36 BuildRequires:  python-pretend
37 BuildRequires:  python-pyasn1_modules
38 BuildRequires:  python-pytest
39 %endif
40 %endif
41 %if %{with python3}
42 BuildRequires:  python3-cffi >= 1.4.1
43 BuildRequires:  python3-devel >= 1:3.3
44 %if "%{py3_ver}" < "3.4"
45 BuildRequires:  python3-enum34
46 %endif
47 BuildRequires:  python3-pyasn1 >= 0.1.8
48 BuildRequires:  python3-setuptools >= 11.3
49 BuildRequires:  python3-six >= 1.4.1
50 %if %{with tests}
51 BuildRequires:  python3-cryptography_vectors
52 BuildRequires:  python3-hypothesis >= 1.11.4
53 BuildRequires:  python3-idna >= 2.0
54 BuildRequires:  python3-iso8601
55 BuildRequires:  python3-pretend
56 BuildRequires:  python3-pyasn1_modules
57 BuildRequires:  python3-pytest
58 %endif
59 %endif
60 Requires:       python-cffi >= 1.4.1
61 Requires:       python-six >= 1.4.1
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 cryptography is a package designed to expose cryptographic recipes and
66 primitives to Python developers. Our goal is for it to be your
67 "cryptographic standard library". It supports Python 2.6-2.7, Python
68 3.2+, and PyPy.
69
70 cryptography includes both high level recipes, and low level
71 interfaces to common cryptographic algorithms such as symmetric
72 ciphers, message digests and key derivation functions.
73
74 This package contains Python 2 modules.
75
76 %description -l pl.UTF-8
77 cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
78 obiektów kryptograficznych programistom Pythona. Celem jest
79 dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
80 Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
81
82 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
83 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
84 takich jak szyfry symetryczne, skróty wiadomości czy funkcje
85 wyprowadzające klucze.
86
87 Ten pakiet zawiera moduły Pythona 2.
88
89 %package -n python3-cryptography
90 Summary:        Crypthography library for Python 3
91 Summary(pl.UTF-8):      Biblioteka Cryptography dla Pythona 3
92 Group:          Libraries/Python
93 Requires:       python3-cffi >= 1.4.1
94 %if "%{py3_ver}" < "3.4"
95 BuildRequires:  python3-enum34
96 %endif
97 Requires:       python3-six >= 1.4.1
98
99 %description -n python3-cryptography
100 cryptography is a package designed to expose cryptographic recipes and
101 primitives to Python developers. Our goal is for it to be your
102 "cryptographic standard library". It supports Python 2.6-2.7, Python
103 3.2+, and PyPy.
104
105 cryptography includes both high level recipes, and low level
106 interfaces to common cryptographic algorithms such as symmetric
107 ciphers, message digests and key derivation functions.
108
109 This package contains Python 3 modules.
110
111 %description -n python3-cryptography -l pl.UTF-8
112 cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
113 obiektów kryptograficznych programistom Pythona. Celem jest
114 dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
115 Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
116
117 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
118 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
119 takich jak szyfry symetryczne, skróty wiadomości czy funkcje
120 wyprowadzające klucze.
121
122 Ten pakiet zawiera moduły Pythona 3.
123
124 %prep
125 %setup -q -n cryptography-%{version}
126
127 %build
128 export CFLAGS="%{rpmcflags}"
129
130 %if %{with python2}
131 %py_build %{?with_tests:test}
132 %endif
133
134 %if %{with python2}
135 %py3_build %{?with_tests:test}
136 %endif
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %if %{with python2}
142 %py_install
143
144 %py_postclean
145 %endif
146
147 %if %{with python3}
148 %py3_install
149 %endif
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %if %{with python2}
155 %files
156 %defattr(644,root,root,755)
157 %doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
158 %dir %{py_sitedir}/cryptography
159 %{py_sitedir}/cryptography/*.py[co]
160 %dir %{py_sitedir}/cryptography/hazmat
161 %{py_sitedir}/cryptography/hazmat/*.py[co]
162 %dir %{py_sitedir}/cryptography/hazmat/backends
163 %{py_sitedir}/cryptography/hazmat/backends/*.py[co]
164 %dir %{py_sitedir}/cryptography/hazmat/backends/commoncrypto
165 %{py_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py[co]
166 %dir %{py_sitedir}/cryptography/hazmat/backends/openssl
167 %{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
168 %dir %{py_sitedir}/cryptography/hazmat/bindings
169 %{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
170 %attr(755,root,root) %{py_sitedir}/cryptography/hazmat/bindings/_*.so
171 %dir %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto
172 %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py[co]
173 %dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
174 %{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
175 %dir %{py_sitedir}/cryptography/hazmat/primitives/interfaces
176 %{py_sitedir}/cryptography/hazmat/primitives/interfaces/*.py[co]
177 %dir %{py_sitedir}/cryptography/hazmat/primitives
178 %{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
179 %dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
180 %{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
181 %dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
182 %{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
183 %dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
184 %{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
185 %dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
186 %{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
187 %dir %{py_sitedir}/cryptography/x509
188 %{py_sitedir}/cryptography/x509/*.py[co]
189 %{py_sitedir}/cryptography-%{version}-py*.egg-info
190 %endif
191
192 %if %{with python3}
193 %files -n python3-cryptography
194 %defattr(644,root,root,755)
195 %doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
196 %dir %{py3_sitedir}/cryptography
197 %{py3_sitedir}/cryptography/*.py
198 %{py3_sitedir}/cryptography/__pycache__
199 %dir %{py3_sitedir}/cryptography/hazmat
200 %{py3_sitedir}/cryptography/hazmat/*.py
201 %{py3_sitedir}/cryptography/hazmat/__pycache__
202 %dir %{py3_sitedir}/cryptography/hazmat/backends
203 %{py3_sitedir}/cryptography/hazmat/backends/*.py
204 %{py3_sitedir}/cryptography/hazmat/backends/__pycache__
205 %dir %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto
206 %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py
207 %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/__pycache__
208 %dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
209 %{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
210 %{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
211 %dir %{py3_sitedir}/cryptography/hazmat/bindings
212 %{py3_sitedir}/cryptography/hazmat/bindings/*.py
213 %{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
214 %attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
215 %dir %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto
216 %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py
217 %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/__pycache__
218 %dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
219 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
220 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
221 %dir %{py3_sitedir}/cryptography/hazmat/primitives/interfaces
222 %{py3_sitedir}/cryptography/hazmat/primitives/interfaces/*.py
223 %{py3_sitedir}/cryptography/hazmat/primitives/interfaces/__pycache__
224 %dir %{py3_sitedir}/cryptography/hazmat/primitives
225 %{py3_sitedir}/cryptography/hazmat/primitives/*.py
226 %{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
227 %dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
228 %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
229 %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
230 %dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
231 %{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
232 %{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
233 %dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
234 %{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
235 %{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
236 %dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
237 %{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
238 %{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
239 %dir %{py3_sitedir}/cryptography/x509
240 %{py3_sitedir}/cryptography/x509/*.py
241 %{py3_sitedir}/cryptography/x509/__pycache__
242 %{py3_sitedir}/cryptography-%{version}-py*.egg-info
243 %endif
This page took 0.088066 seconds and 4 git commands to generate.