]> git.pld-linux.org Git - packages/python3-cryptography.git/blob - python-cryptography.spec
- rel 2; bump cffi deps
[packages/python3-cryptography.git] / python-cryptography.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Crypthography library for Python 2
7 Summary(pl.UTF-8):      Biblioteka Cryptography dla Pythona 2
8 Name:           python-cryptography
9 Version:        1.2.3
10 Release:        2
11 License:        Apache v2.0 or BSD
12 Group:          Libraries/Python
13 Source0:        https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
14 # Source0-md5:  5474d2b3e8c7555a60852e48d2743f85
15 URL:            https://cryptography.io/
16 BuildRequires:  openssl-devel >= 0.9.8
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.710
19 %if %{with python2}
20 BuildRequires:  python-cffi >= 1.4.1
21 BuildRequires:  python-devel >= 1:2.6
22 BuildRequires:  python-enum34
23 BuildRequires:  python-pyasn1
24 BuildRequires:  python-setuptools
25 BuildRequires:  python-six >= 1.4.1
26 %endif
27 %if %{with python3}
28 BuildRequires:  python3-cffi >= 1.4.1
29 BuildRequires:  python3-devel >= 1:3.2
30 BuildRequires:  python3-pyasn1
31 BuildRequires:  python3-setuptools
32 BuildRequires:  python3-six >= 1.4.1
33 %endif
34 Requires:       python-cffi >= 1.4.1
35 Requires:       python-six >= 1.4.1
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 cryptography is a package designed to expose cryptographic recipes and
40 primitives to Python developers. Our goal is for it to be your
41 "cryptographic standard library". It supports Python 2.6-2.7, Python
42 3.2+, and PyPy.
43
44 cryptography includes both high level recipes, and low level
45 interfaces to common cryptographic algorithms such as symmetric
46 ciphers, message digests and key derivation functions.
47
48 This package contains Python 2 modules.
49
50 %description -l pl.UTF-8
51 cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
52 obiektów kryptograficznych programistom Pythona. Celem jest
53 dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
54 Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
55
56 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
57 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
58 takich jak szyfry symetryczne, skróty wiadomości czy funkcje
59 wyprowadzające klucze.
60
61 Ten pakiet zawiera moduły Pythona 2.
62
63 %package -n python3-cryptography
64 Summary:        Crypthography library for Python 3
65 Summary(pl.UTF-8):      Biblioteka Cryptography dla Pythona 3
66 Group:          Libraries/Python
67 Requires:       python3-cffi >= 1.4.1
68 Requires:       python3-six >= 1.4.1
69
70 %description -n python3-cryptography
71 cryptography is a package designed to expose cryptographic recipes and
72 primitives to Python developers. Our goal is for it to be your
73 "cryptographic standard library". It supports Python 2.6-2.7, Python
74 3.2+, and PyPy.
75
76 cryptography includes both high level recipes, and low level
77 interfaces to common cryptographic algorithms such as symmetric
78 ciphers, message digests and key derivation functions.
79
80 This package contains Python 3 modules.
81
82 %description -n python3-cryptography -l pl.UTF-8
83 cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
84 obiektów kryptograficznych programistom Pythona. Celem jest
85 dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
86 Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
87
88 cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
89 niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
90 takich jak szyfry symetryczne, skróty wiadomości czy funkcje
91 wyprowadzające klucze.
92
93 Ten pakiet zawiera moduły Pythona 3.
94
95 %prep
96 %setup -q -n cryptography-%{version}
97
98 %build
99 export CFLAGS="%{rpmcflags}"
100
101 %if %{with python2}
102 %py_build \
103         --build-base build-2
104 %endif
105
106 %if %{with python2}
107 %py3_build \
108         --build-base build-3
109 %endif
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %if %{with python2}
115 %py_install
116
117 %py_postclean
118 %endif
119
120 %if %{with python3}
121 %py3_install
122 %endif
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %if %{with python2}
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
131 %dir %{py_sitedir}/cryptography
132 %{py_sitedir}/cryptography/*.py[co]
133 %dir %{py_sitedir}/cryptography/hazmat
134 %{py_sitedir}/cryptography/hazmat/*.py[co]
135 %dir %{py_sitedir}/cryptography/hazmat/backends
136 %{py_sitedir}/cryptography/hazmat/backends/*.py[co]
137 %dir %{py_sitedir}/cryptography/hazmat/backends/commoncrypto
138 %{py_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py[co]
139 %dir %{py_sitedir}/cryptography/hazmat/backends/openssl
140 %{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
141 %dir %{py_sitedir}/cryptography/hazmat/bindings
142 %{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
143 %attr(755,root,root) %{py_sitedir}/cryptography/hazmat/bindings/_*.so
144 %dir %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto
145 %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py[co]
146 %dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
147 %{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
148 %dir %{py_sitedir}/cryptography/hazmat/primitives/interfaces
149 %{py_sitedir}/cryptography/hazmat/primitives/interfaces/*.py[co]
150 %dir %{py_sitedir}/cryptography/hazmat/primitives
151 %{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
152 %dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
153 %{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
154 %dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
155 %{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
156 %dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
157 %{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
158 %dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
159 %{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
160 %dir %{py_sitedir}/cryptography/x509
161 %{py_sitedir}/cryptography/x509/*.py[co]
162 %{py_sitedir}/cryptography-%{version}-py*.egg-info
163 %endif
164
165 %if %{with python3}
166 %files -n python3-cryptography
167 %defattr(644,root,root,755)
168 %doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
169 %dir %{py3_sitedir}/cryptography
170 %{py3_sitedir}/cryptography/*.py
171 %{py3_sitedir}/cryptography/__pycache__
172 %dir %{py3_sitedir}/cryptography/hazmat
173 %{py3_sitedir}/cryptography/hazmat/*.py
174 %{py3_sitedir}/cryptography/hazmat/__pycache__
175 %dir %{py3_sitedir}/cryptography/hazmat/backends
176 %{py3_sitedir}/cryptography/hazmat/backends/*.py
177 %{py3_sitedir}/cryptography/hazmat/backends/__pycache__
178 %dir %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto
179 %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py
180 %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/__pycache__
181 %dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
182 %{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
183 %{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
184 %dir %{py3_sitedir}/cryptography/hazmat/bindings
185 %{py3_sitedir}/cryptography/hazmat/bindings/*.py
186 %{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
187 %attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
188 %dir %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto
189 %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py
190 %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/__pycache__
191 %dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
192 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
193 %{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
194 %dir %{py3_sitedir}/cryptography/hazmat/primitives/interfaces
195 %{py3_sitedir}/cryptography/hazmat/primitives/interfaces/*.py
196 %{py3_sitedir}/cryptography/hazmat/primitives/interfaces/__pycache__
197 %dir %{py3_sitedir}/cryptography/hazmat/primitives
198 %{py3_sitedir}/cryptography/hazmat/primitives/*.py
199 %{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
200 %dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
201 %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
202 %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
203 %dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
204 %{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
205 %{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
206 %dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
207 %{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
208 %{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
209 %dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
210 %{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
211 %{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
212 %dir %{py3_sitedir}/cryptography/x509
213 %{py3_sitedir}/cryptography/x509/*.py
214 %{py3_sitedir}/cryptography/x509/__pycache__
215 %{py3_sitedir}/cryptography-%{version}-py*.egg-info
216 %endif
This page took 0.058134 seconds and 4 git commands to generate.