]> git.pld-linux.org Git - packages/python3-cryptography.git/blame_incremental - python-cryptography.spec
_noautoreq for some modules included in Python 3
[packages/python3-cryptography.git] / python-cryptography.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5%bcond_with tests # test target [not all dependencies are currently available in PLD]
6
7Summary: Crypthography library for Python 2
8Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 2
9Name: python-cryptography
10Version: 2.3.1
11Release: 2
12License: Apache v2.0 or BSD
13Group: Libraries/Python
14#Source0Download: https://pypi.python.org/simple/cryptography/
15Source0: https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
16# Source0-md5: 2b5e8269c43c9b9ab54fc8c75ba3c7ac
17URL: https://cryptography.io/
18BuildRequires: openssl-devel >= 1.0.1
19BuildRequires: rpm-pythonprov
20BuildRequires: rpmbuild(macros) >= 1.714
21%if %{with python2}
22BuildRequires: python-cffi >= 1.4.1
23BuildRequires: python-devel >= 1:2.6
24BuildRequires: python-enum34
25BuildRequires: python-pyasn1 >= 0.1.8
26BuildRequires: python-setuptools >= 11.3
27BuildRequires: python-six >= 1.4.1
28%if %{with tests}
29BuildRequires: python-cryptography_vectors
30%if "%{py_ver}" >= "2.7"
31BuildRequires: python-hypothesis >= 1.11.4
32%endif
33BuildRequires: python-idna >= 2.0
34BuildRequires: python-ipaddress
35BuildRequires: python-iso8601
36BuildRequires: python-pretend
37BuildRequires: python-pyasn1_modules
38BuildRequires: python-pytest
39%endif
40%endif
41%if %{with python3}
42BuildRequires: python3-cffi >= 1.4.1
43BuildRequires: python3-devel >= 1:3.3
44BuildRequires: python3-pyasn1 >= 0.1.8
45BuildRequires: python3-setuptools >= 11.3
46BuildRequires: python3-six >= 1.4.1
47%if %{with tests}
48BuildRequires: python3-cryptography_vectors
49BuildRequires: python3-hypothesis >= 1.11.4
50BuildRequires: python3-idna >= 2.0
51BuildRequires: python3-iso8601
52BuildRequires: python3-pretend
53BuildRequires: python3-pyasn1_modules
54BuildRequires: python3-pytest
55%endif
56%endif
57Requires: openssl >= 1.0.1
58Requires: python-cffi >= 1.4.1
59Requires: python-six >= 1.4.1
60BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62# modern Python provides those
63%define _noautoreq python3egg.ipaddress python3egg.enum34
64
65%description
66cryptography is a package designed to expose cryptographic recipes and
67primitives to Python developers. Our goal is for it to be your
68"cryptographic standard library". It supports Python 2.6-2.7, Python
693.2+, and PyPy.
70
71cryptography includes both high level recipes, and low level
72interfaces to common cryptographic algorithms such as symmetric
73ciphers, message digests and key derivation functions.
74
75This package contains Python 2 modules.
76
77%description -l pl.UTF-8
78cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
79obiektów kryptograficznych programistom Pythona. Celem jest
80dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
81Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
82
83cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
84niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
85takich jak szyfry symetryczne, skróty wiadomości czy funkcje
86wyprowadzające klucze.
87
88Ten pakiet zawiera moduły Pythona 2.
89
90%package -n python3-cryptography
91Summary: Crypthography library for Python 3
92Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 3
93Group: Libraries/Python
94Requires: openssl >= 1.0.1
95Requires: python3-cffi >= 1.4.1
96%if "%{py3_ver}" < "3.4"
97Requires: python3-enum34
98%endif
99Requires: python3-six >= 1.4.1
100
101%description -n python3-cryptography
102cryptography is a package designed to expose cryptographic recipes and
103primitives to Python developers. Our goal is for it to be your
104"cryptographic standard library". It supports Python 2.6-2.7, Python
1053.2+, and PyPy.
106
107cryptography includes both high level recipes, and low level
108interfaces to common cryptographic algorithms such as symmetric
109ciphers, message digests and key derivation functions.
110
111This package contains Python 3 modules.
112
113%description -n python3-cryptography -l pl.UTF-8
114cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
115obiektów kryptograficznych programistom Pythona. Celem jest
116dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
117Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
118
119cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
120niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
121takich jak szyfry symetryczne, skróty wiadomości czy funkcje
122wyprowadzające klucze.
123
124Ten pakiet zawiera moduły Pythona 3.
125
126%prep
127%setup -q -n cryptography-%{version}
128
129%build
130export CFLAGS="%{rpmcflags}"
131
132%if %{with python2}
133%py_build %{?with_tests:test}
134%endif
135
136%if %{with python2}
137%py3_build %{?with_tests:test}
138%endif
139
140%install
141rm -rf $RPM_BUILD_ROOT
142
143%if %{with python2}
144%py_install
145
146%py_postclean
147%endif
148
149%if %{with python3}
150%py3_install
151%endif
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%if %{with python2}
157%files
158%defattr(644,root,root,755)
159%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
160%dir %{py_sitedir}/cryptography
161%{py_sitedir}/cryptography/*.py[co]
162%dir %{py_sitedir}/cryptography/hazmat
163%{py_sitedir}/cryptography/hazmat/*.py[co]
164%dir %{py_sitedir}/cryptography/hazmat/backends
165%{py_sitedir}/cryptography/hazmat/backends/*.py[co]
166%dir %{py_sitedir}/cryptography/hazmat/backends/openssl
167%{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
168%dir %{py_sitedir}/cryptography/hazmat/bindings
169%{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
170%attr(755,root,root) %{py_sitedir}/cryptography/hazmat/bindings/_*.so
171%dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
172%{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
173%dir %{py_sitedir}/cryptography/hazmat/primitives
174%{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
175%dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
176%{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
177%dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
178%{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
179%dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
180%{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
181%dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
182%{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
183%dir %{py_sitedir}/cryptography/x509
184%{py_sitedir}/cryptography/x509/*.py[co]
185%{py_sitedir}/cryptography-%{version}-py*.egg-info
186%endif
187
188%if %{with python3}
189%files -n python3-cryptography
190%defattr(644,root,root,755)
191%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
192%dir %{py3_sitedir}/cryptography
193%{py3_sitedir}/cryptography/*.py
194%{py3_sitedir}/cryptography/__pycache__
195%dir %{py3_sitedir}/cryptography/hazmat
196%{py3_sitedir}/cryptography/hazmat/*.py
197%{py3_sitedir}/cryptography/hazmat/__pycache__
198%dir %{py3_sitedir}/cryptography/hazmat/backends
199%{py3_sitedir}/cryptography/hazmat/backends/*.py
200%{py3_sitedir}/cryptography/hazmat/backends/__pycache__
201%dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
202%{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
203%{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
204%dir %{py3_sitedir}/cryptography/hazmat/bindings
205%{py3_sitedir}/cryptography/hazmat/bindings/*.py
206%{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
207%attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
208%dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
209%{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
210%{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
211%dir %{py3_sitedir}/cryptography/hazmat/primitives
212%{py3_sitedir}/cryptography/hazmat/primitives/*.py
213%{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
214%dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
215%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
216%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
217%dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
218%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
219%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
220%dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
221%{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
222%{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
223%dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
224%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
225%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
226%dir %{py3_sitedir}/cryptography/x509
227%{py3_sitedir}/cryptography/x509/*.py
228%{py3_sitedir}/cryptography/x509/__pycache__
229%{py3_sitedir}/cryptography-%{version}-py*.egg-info
230%endif
This page took 0.080114 seconds and 4 git commands to generate.