]> git.pld-linux.org Git - packages/python3-cryptography.git/blame_incremental - python-cryptography.spec
- enable tests
[packages/python3-cryptography.git] / python-cryptography.spec
... / ...
CommitLineData
1# TODO: when updating try to reenable all tests (two were failing in 2.7 with openssl 1.1.1d)
2#
3# Conditional build:
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6%bcond_without doc # Sphinx documentation
7%bcond_without tests # unit test
8
9Summary: Crypthography library for Python 2
10Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 2
11Name: python-cryptography
12Version: 2.7
13Release: 1
14License: Apache v2.0 or BSD
15Group: Libraries/Python
16#Source0Download: https://pypi.org/simple/cryptography/
17Source0: https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
18# Source0-md5: 7dfe1035cae43569e571318f000462a4
19#Source1Download: https://pypi.org/simple/cryptography_vectors/
20Source1: https://files.pythonhosted.org/packages/source/c/cryptography-vectors/cryptography_vectors-%{version}.tar.gz
21# Source1-md5: 1a518a28ed9c924ca6c570aa8ea0c334
22URL: https://cryptography.io/
23BuildRequires: openssl-devel >= 1.0.1
24BuildRequires: rpm-pythonprov >= 5.4.15-48
25BuildRequires: rpmbuild(macros) >= 1.714
26%if %{with python2}
27BuildRequires: python-cffi >= 1.8
28BuildRequires: python-devel >= 1:2.7
29BuildRequires: python-enum34
30BuildRequires: python-pytz
31BuildRequires: python-setuptools >= 18.5
32BuildRequires: python-six >= 1.4.1
33%if %{with tests}
34BuildRequires: python-asn1crypto >= 0.21.0
35%if "%{py_ver}" >= "2.7"
36BuildRequires: python-hypothesis >= 1.11.4
37%endif
38BuildRequires: python-idna >= 2.1
39BuildRequires: python-ipaddress
40BuildRequires: python-iso8601
41BuildRequires: python-pretend
42BuildRequires: python-pytest >= 3.6.0
43BuildRequires: python-pytz
44%endif
45%endif
46%if %{with python3}
47BuildRequires: python3-cffi >= 1.8
48BuildRequires: python3-devel >= 1:3.4
49BuildRequires: python3-setuptools >= 18.5
50BuildRequires: python3-six >= 1.4.1
51%if %{with tests}
52BuildRequires: python3-asn1crypto >= 0.21.0
53BuildRequires: python3-hypothesis >= 1.11.4
54BuildRequires: python3-idna >= 2.1
55BuildRequires: python3-iso8601
56BuildRequires: python3-pretend
57BuildRequires: python3-pytest >= 3.6.0
58BuildRequires: python3-pytz
59%endif
60%endif
61%if %{with doc}
62BuildRequires: python3-sphinx_rtd_theme
63BuildRequires: sphinx-pdg-3 >= 1.6.5
64%endif
65Requires: openssl >= 1.0.1
66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68%description
69cryptography is a package designed to expose cryptographic recipes and
70primitives to Python developers. Our goal is for it to be your
71"cryptographic standard library". It supports Python 2.7, Python 3.4+,
72and PyPy.
73
74cryptography includes both high level recipes, and low level
75interfaces to common cryptographic algorithms such as symmetric
76ciphers, message digests and key derivation functions.
77
78This package contains Python 2 modules.
79
80%description -l pl.UTF-8
81cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
82obiektów kryptograficznych programistom Pythona. Celem jest
83dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
84Pythona 2.7, Pythona 3.4+ oraz PyPy.
85
86cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
87niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
88takich jak szyfry symetryczne, skróty wiadomości czy funkcje
89wyprowadzające klucze.
90
91Ten pakiet zawiera moduły Pythona 2.
92
93%package -n python3-cryptography
94Summary: Crypthography library for Python 3
95Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 3
96Group: Libraries/Python
97Requires: openssl >= 1.0.1
98
99%description -n python3-cryptography
100cryptography is a package designed to expose cryptographic recipes and
101primitives to Python developers. Our goal is for it to be your
102"cryptographic standard library". It supports Python 2.7, Python 3.4+,
103and PyPy.
104
105cryptography includes both high level recipes, and low level
106interfaces to common cryptographic algorithms such as symmetric
107ciphers, message digests and key derivation functions.
108
109This package contains Python 3 modules.
110
111%description -n python3-cryptography -l pl.UTF-8
112cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
113obiektów kryptograficznych programistom Pythona. Celem jest
114dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
115Pythona 2.7, Pythona 3.4+ oraz PyPy.
116
117cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
118niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
119takich jak szyfry symetryczne, skróty wiadomości czy funkcje
120wyprowadzające klucze.
121
122Ten pakiet zawiera moduły Pythona 3.
123
124%package apidocs
125Summary: API documentation for cryptography module
126Summary(pl.UTF-8): Dokumentacja API modułu cryptography
127Group: Documentation
128%if "%{_rpmversion}" >= "5"
129BuildArch: noarch
130%endif
131
132%description apidocs
133API documentation for cryptography module.
134
135%description apidocs -l pl.UTF-8
136Dokumentacja API modułu cryptography.
137
138%prep
139%setup -q -n cryptography-%{version} %{?with_tests:-a1}
140
141%if %{with tests}
142%{__mv} cryptography_vectors-%{version}/cryptography_vectors .
143%endif
144
145%build
146export CFLAGS="%{rpmcflags}"
147
148%if %{with python2}
149%py_build
150
151%if %{with tests}
152PYTHONPATH=$(pwd) \
153%{__python} -m pytest tests -k 'not test_dh_parameters_supported and not test_load_ecdsa_no_named_curve'
154%endif
155%endif
156
157%if %{with python2}
158%py3_build
159
160%if %{with tests}
161PYTHONPATH=$(pwd) \
162%{__python3} -m pytest tests -k 'not test_dh_parameters_supported and not test_load_ecdsa_no_named_curve'
163%endif
164%endif
165
166%if %{with doc}
167%{__make} -C docs html \
168 SPHINXBUILD=sphinx-build-3
169%endif
170
171%install
172rm -rf $RPM_BUILD_ROOT
173
174%if %{with python2}
175%py_install
176
177%py_postclean
178%endif
179
180%if %{with python3}
181%py3_install
182%endif
183
184%clean
185rm -rf $RPM_BUILD_ROOT
186
187%if %{with python2}
188%files
189%defattr(644,root,root,755)
190%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
191%dir %{py_sitedir}/cryptography
192%{py_sitedir}/cryptography/*.py[co]
193%dir %{py_sitedir}/cryptography/hazmat
194%{py_sitedir}/cryptography/hazmat/*.py[co]
195%dir %{py_sitedir}/cryptography/hazmat/backends
196%{py_sitedir}/cryptography/hazmat/backends/*.py[co]
197%dir %{py_sitedir}/cryptography/hazmat/backends/openssl
198%{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
199%dir %{py_sitedir}/cryptography/hazmat/bindings
200%{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
201%attr(755,root,root) %{py_sitedir}/cryptography/hazmat/bindings/_*.so
202%dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
203%{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
204%dir %{py_sitedir}/cryptography/hazmat/primitives
205%{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
206%dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
207%{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
208%dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
209%{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
210%dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
211%{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
212%dir %{py_sitedir}/cryptography/hazmat/primitives/serialization
213%{py_sitedir}/cryptography/hazmat/primitives/serialization/*.py[co]
214%dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
215%{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
216%dir %{py_sitedir}/cryptography/x509
217%{py_sitedir}/cryptography/x509/*.py[co]
218%{py_sitedir}/cryptography-%{version}-py*.egg-info
219%endif
220
221%if %{with python3}
222%files -n python3-cryptography
223%defattr(644,root,root,755)
224%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
225%dir %{py3_sitedir}/cryptography
226%{py3_sitedir}/cryptography/*.py
227%{py3_sitedir}/cryptography/__pycache__
228%dir %{py3_sitedir}/cryptography/hazmat
229%{py3_sitedir}/cryptography/hazmat/*.py
230%{py3_sitedir}/cryptography/hazmat/__pycache__
231%dir %{py3_sitedir}/cryptography/hazmat/backends
232%{py3_sitedir}/cryptography/hazmat/backends/*.py
233%{py3_sitedir}/cryptography/hazmat/backends/__pycache__
234%dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
235%{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
236%{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
237%dir %{py3_sitedir}/cryptography/hazmat/bindings
238%{py3_sitedir}/cryptography/hazmat/bindings/*.py
239%{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
240%attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
241%dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
242%{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
243%{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
244%dir %{py3_sitedir}/cryptography/hazmat/primitives
245%{py3_sitedir}/cryptography/hazmat/primitives/*.py
246%{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
247%dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
248%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
249%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
250%dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
251%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
252%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
253%dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
254%{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
255%{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
256%dir %{py3_sitedir}/cryptography/hazmat/primitives/serialization
257%{py3_sitedir}/cryptography/hazmat/primitives/serialization/*.py
258%{py3_sitedir}/cryptography/hazmat/primitives/serialization/__pycache__
259%dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
260%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
261%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
262%dir %{py3_sitedir}/cryptography/x509
263%{py3_sitedir}/cryptography/x509/*.py
264%{py3_sitedir}/cryptography/x509/__pycache__
265%{py3_sitedir}/cryptography-%{version}-py*.egg-info
266%endif
267
268%if %{with doc}
269%files apidocs
270%defattr(644,root,root,755)
271%doc docs/_build/html/{_downloads,_modules,_static,development,hazmat,x509,*.html,*.js}
272%endif
This page took 0.066445 seconds and 4 git commands to generate.