]> git.pld-linux.org Git - packages/python3-cryptography.git/blame - python-cryptography.spec
- updated dependencies
[packages/python3-cryptography.git] / python-cryptography.spec
CommitLineData
06232684
JB
1#
2# Conditional build:
049a803f
JB
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5%bcond_with tests # test target [not all dependencies are currently available in PLD]
06232684
JB
6
7Summary: Crypthography library for Python 2
8Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 2
9Name: python-cryptography
3e42f450 10Version: 2.4.2
606dca6b 11Release: 1
d6e7edf5 12License: Apache v2.0 or BSD
06232684 13Group: Libraries/Python
29d4b67b 14#Source0Download: https://pypi.org/simple/cryptography/
7df50b22 15Source0: https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
3e42f450 16# Source0-md5: 26bad6a40a373e2ad43dfa13dc4b162b
06232684 17URL: https://cryptography.io/
7df50b22 18BuildRequires: openssl-devel >= 1.0.1
d331861d 19BuildRequires: rpm-pythonprov >= 5.4.15-48
049a803f 20BuildRequires: rpmbuild(macros) >= 1.714
06232684 21%if %{with python2}
606dca6b 22BuildRequires: python-cffi >= 1.7
29d4b67b 23BuildRequires: python-devel >= 1:2.7
b2fc4ef3 24BuildRequires: python-enum34
29d4b67b
JB
25BuildRequires: python-pytz
26BuildRequires: python-setuptools >= 18.5
06232684 27BuildRequires: python-six >= 1.4.1
049a803f 28%if %{with tests}
29d4b67b 29BuildRequires: python-asn1crypto >= 0.21.0
049a803f
JB
30BuildRequires: python-cryptography_vectors
31%if "%{py_ver}" >= "2.7"
32BuildRequires: python-hypothesis >= 1.11.4
33%endif
29d4b67b 34BuildRequires: python-idna >= 2.1
049a803f
JB
35BuildRequires: python-ipaddress
36BuildRequires: python-iso8601
37BuildRequires: python-pretend
29d4b67b 38BuildRequires: python-pytest >= 3.6.0
049a803f 39%endif
06232684
JB
40%endif
41%if %{with python3}
606dca6b 42BuildRequires: python3-cffi >= 1.7
d331861d 43BuildRequires: python3-devel >= 1:3.4
29d4b67b 44BuildRequires: python3-setuptools >= 18.5
06232684 45BuildRequires: python3-six >= 1.4.1
049a803f 46%if %{with tests}
29d4b67b 47BuildRequires: python3-asn1crypto >= 0.21.0
049a803f
JB
48BuildRequires: python3-cryptography_vectors
49BuildRequires: python3-hypothesis >= 1.11.4
29d4b67b 50BuildRequires: python3-idna >= 2.1
049a803f
JB
51BuildRequires: python3-iso8601
52BuildRequires: python3-pretend
29d4b67b 53BuildRequires: python3-pytest >= 3.6.0
049a803f 54%endif
06232684 55%endif
7df50b22 56Requires: openssl >= 1.0.1
606dca6b 57Requires: python-cffi >= 1.7
06232684
JB
58Requires: python-six >= 1.4.1
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61%description
62cryptography is a package designed to expose cryptographic recipes and
63primitives to Python developers. Our goal is for it to be your
64"cryptographic standard library". It supports Python 2.6-2.7, Python
653.2+, and PyPy.
66
67cryptography includes both high level recipes, and low level
68interfaces to common cryptographic algorithms such as symmetric
69ciphers, message digests and key derivation functions.
70
71This package contains Python 2 modules.
72
73%description -l pl.UTF-8
74cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
75obiektów kryptograficznych programistom Pythona. Celem jest
76dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
77Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
78
79cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
80niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 81takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
82wyprowadzające klucze.
83
84Ten pakiet zawiera moduły Pythona 2.
85
86%package -n python3-cryptography
87Summary: Crypthography library for Python 3
88Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 3
89Group: Libraries/Python
7df50b22 90Requires: openssl >= 1.0.1
606dca6b 91Requires: python3-cffi >= 1.7
06232684
JB
92Requires: python3-six >= 1.4.1
93
94%description -n python3-cryptography
95cryptography is a package designed to expose cryptographic recipes and
96primitives to Python developers. Our goal is for it to be your
97"cryptographic standard library". It supports Python 2.6-2.7, Python
983.2+, and PyPy.
99
100cryptography includes both high level recipes, and low level
101interfaces to common cryptographic algorithms such as symmetric
102ciphers, message digests and key derivation functions.
103
104This package contains Python 3 modules.
105
106%description -n python3-cryptography -l pl.UTF-8
107cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
108obiektów kryptograficznych programistom Pythona. Celem jest
109dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
110Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
111
112cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
113niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 114takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
115wyprowadzające klucze.
116
117Ten pakiet zawiera moduły Pythona 3.
118
119%prep
120%setup -q -n cryptography-%{version}
121
122%build
123export CFLAGS="%{rpmcflags}"
124
125%if %{with python2}
049a803f 126%py_build %{?with_tests:test}
06232684
JB
127%endif
128
129%if %{with python2}
049a803f 130%py3_build %{?with_tests:test}
06232684
JB
131%endif
132
133%install
134rm -rf $RPM_BUILD_ROOT
135
136%if %{with python2}
6d1f8f74 137%py_install
06232684
JB
138
139%py_postclean
140%endif
141
142%if %{with python3}
6d1f8f74 143%py3_install
06232684
JB
144%endif
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%if %{with python2}
150%files
151%defattr(644,root,root,755)
049a803f 152%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
06232684 153%dir %{py_sitedir}/cryptography
06232684
JB
154%{py_sitedir}/cryptography/*.py[co]
155%dir %{py_sitedir}/cryptography/hazmat
156%{py_sitedir}/cryptography/hazmat/*.py[co]
157%dir %{py_sitedir}/cryptography/hazmat/backends
158%{py_sitedir}/cryptography/hazmat/backends/*.py[co]
06232684
JB
159%dir %{py_sitedir}/cryptography/hazmat/backends/openssl
160%{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
161%dir %{py_sitedir}/cryptography/hazmat/bindings
162%{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
d198b5a4 163%attr(755,root,root) %{py_sitedir}/cryptography/hazmat/bindings/_*.so
06232684
JB
164%dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
165%{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
166%dir %{py_sitedir}/cryptography/hazmat/primitives
167%{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
168%dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
169%{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
170%dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
171%{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
172%dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
173%{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
f7d88309
AM
174%dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
175%{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
d198b5a4
AM
176%dir %{py_sitedir}/cryptography/x509
177%{py_sitedir}/cryptography/x509/*.py[co]
06232684
JB
178%{py_sitedir}/cryptography-%{version}-py*.egg-info
179%endif
180
181%if %{with python3}
182%files -n python3-cryptography
183%defattr(644,root,root,755)
049a803f 184%doc AUTHORS.rst README.rst LICENSE LICENSE.APACHE LICENSE.BSD
06232684 185%dir %{py3_sitedir}/cryptography
06232684
JB
186%{py3_sitedir}/cryptography/*.py
187%{py3_sitedir}/cryptography/__pycache__
188%dir %{py3_sitedir}/cryptography/hazmat
189%{py3_sitedir}/cryptography/hazmat/*.py
190%{py3_sitedir}/cryptography/hazmat/__pycache__
191%dir %{py3_sitedir}/cryptography/hazmat/backends
192%{py3_sitedir}/cryptography/hazmat/backends/*.py
193%{py3_sitedir}/cryptography/hazmat/backends/__pycache__
06232684
JB
194%dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
195%{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
196%{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
197%dir %{py3_sitedir}/cryptography/hazmat/bindings
198%{py3_sitedir}/cryptography/hazmat/bindings/*.py
199%{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
d198b5a4 200%attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
06232684
JB
201%dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
202%{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
203%{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
204%dir %{py3_sitedir}/cryptography/hazmat/primitives
205%{py3_sitedir}/cryptography/hazmat/primitives/*.py
206%{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
207%dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
208%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
209%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
210%dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
211%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
212%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
213%dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
214%{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
215%{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
f7d88309
AM
216%dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
217%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
218%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
d198b5a4
AM
219%dir %{py3_sitedir}/cryptography/x509
220%{py3_sitedir}/cryptography/x509/*.py
221%{py3_sitedir}/cryptography/x509/__pycache__
06232684
JB
222%{py3_sitedir}/cryptography-%{version}-py*.egg-info
223%endif
This page took 0.210561 seconds and 4 git commands to generate.