]> git.pld-linux.org Git - packages/python3-cryptography.git/blame - python-cryptography.spec
remove sources to simplify detecting unpackaged files
[packages/python3-cryptography.git] / python-cryptography.spec
CommitLineData
06232684
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Crypthography library for Python 2
7Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 2
8Name: python-cryptography
d6e7edf5
ER
9Version: 0.8.2
10Release: 1
11License: Apache v2.0 or BSD
06232684
JB
12Group: Libraries/Python
13Source0: https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
d6e7edf5 14# Source0-md5: 7d33499e851300c194cbb0396de72462
06232684 15URL: https://cryptography.io/
cd19033e 16BuildRequires: openssl-devel >= 0.9.8
06232684 17%if %{with python2}
06232684 18BuildRequires: python-cffi >= 0.8
226a2f8d 19BuildRequires: python-devel >= 1:2.6
06232684 20BuildRequires: python-six >= 1.4.1
06232684
JB
21%endif
22%if %{with python3}
06232684 23BuildRequires: python3-cffi >= 0.8
226a2f8d 24BuildRequires: python3-devel >= 1:3.2
06232684
JB
25BuildRequires: python3-six >= 1.4.1
26%endif
27BuildRequires: rpm-pythonprov
ea4b6939 28BuildRequires: rpmbuild(macros) >= 1.612
06232684
JB
29Requires: python-cffi >= 0.8
30Requires: python-six >= 1.4.1
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34cryptography is a package designed to expose cryptographic recipes and
35primitives to Python developers. Our goal is for it to be your
36"cryptographic standard library". It supports Python 2.6-2.7, Python
373.2+, and PyPy.
38
39cryptography includes both high level recipes, and low level
40interfaces to common cryptographic algorithms such as symmetric
41ciphers, message digests and key derivation functions.
42
43This package contains Python 2 modules.
44
45%description -l pl.UTF-8
46cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
47obiektów kryptograficznych programistom Pythona. Celem jest
48dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
49Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
50
51cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
52niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 53takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
54wyprowadzające klucze.
55
56Ten pakiet zawiera moduły Pythona 2.
57
58%package -n python3-cryptography
59Summary: Crypthography library for Python 3
60Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 3
61Group: Libraries/Python
62Requires: python3-cffi >= 0.8
63Requires: python3-six >= 1.4.1
64
65%description -n python3-cryptography
66cryptography is a package designed to expose cryptographic recipes and
67primitives to Python developers. Our goal is for it to be your
68"cryptographic standard library". It supports Python 2.6-2.7, Python
693.2+, and PyPy.
70
71cryptography includes both high level recipes, and low level
72interfaces to common cryptographic algorithms such as symmetric
73ciphers, message digests and key derivation functions.
74
75This package contains Python 3 modules.
76
77%description -n python3-cryptography -l pl.UTF-8
78cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
79obiektów kryptograficznych programistom Pythona. Celem jest
80dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
81Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
82
83cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
84niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 85takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
86wyprowadzające klucze.
87
88Ten pakiet zawiera moduły Pythona 3.
89
90%prep
91%setup -q -n cryptography-%{version}
92
93%build
94export CFLAGS="%{rpmcflags}"
95
96%if %{with python2}
97%{__python} setup.py build \
98 --build-base build-2
99%endif
100
101%if %{with python2}
102%{__python3} setup.py build \
103 --build-base build-3
104%endif
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109%if %{with python2}
110%{__python} setup.py \
f7d88309
AM
111 build --build-base build-2 \
112 install --skip-build \
06232684
JB
113 --optimize=2 \
114 --root=$RPM_BUILD_ROOT
115
116%py_postclean
226a2f8d
ER
117%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/cryptography/hazmat/bindings/__pycache__/*.c
118%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/cryptography/hazmat/primitives/src/*.[ch]
06232684
JB
119%endif
120
121%if %{with python3}
122%{__python3} setup.py \
f7d88309
AM
123 build --build-base build-3 \
124 install --skip-build \
06232684
JB
125 --optimize=2 \
126 --root=$RPM_BUILD_ROOT
226a2f8d
ER
127
128%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/cryptography/hazmat/primitives/src/*.[ch]
06232684
JB
129%endif
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%if %{with python2}
135%files
136%defattr(644,root,root,755)
d6e7edf5 137%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
06232684 138%dir %{py_sitedir}/cryptography
f7d88309 139%attr(755,root,root) %{py_sitedir}/cryptography/_*_cffi_*.so
06232684
JB
140%{py_sitedir}/cryptography/*.py[co]
141%dir %{py_sitedir}/cryptography/hazmat
142%{py_sitedir}/cryptography/hazmat/*.py[co]
143%dir %{py_sitedir}/cryptography/hazmat/backends
144%{py_sitedir}/cryptography/hazmat/backends/*.py[co]
145%dir %{py_sitedir}/cryptography/hazmat/backends/commoncrypto
146%{py_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py[co]
147%dir %{py_sitedir}/cryptography/hazmat/backends/openssl
148%{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
149%dir %{py_sitedir}/cryptography/hazmat/bindings
150%{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
151%dir %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto
152%{py_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py[co]
153%dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
154%{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
155%dir %{py_sitedir}/cryptography/hazmat/primitives
156%{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
157%dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
158%{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
159%dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
160%{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
161%dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
162%{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
f7d88309
AM
163%dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
164%{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
06232684
JB
165%{py_sitedir}/cryptography-%{version}-py*.egg-info
166%endif
167
168%if %{with python3}
169%files -n python3-cryptography
170%defattr(644,root,root,755)
d6e7edf5 171%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
06232684 172%dir %{py3_sitedir}/cryptography
f7d88309 173%attr(755,root,root) %{py3_sitedir}/cryptography/_*_cffi_*.so
06232684
JB
174%{py3_sitedir}/cryptography/*.py
175%{py3_sitedir}/cryptography/__pycache__
176%dir %{py3_sitedir}/cryptography/hazmat
177%{py3_sitedir}/cryptography/hazmat/*.py
178%{py3_sitedir}/cryptography/hazmat/__pycache__
179%dir %{py3_sitedir}/cryptography/hazmat/backends
180%{py3_sitedir}/cryptography/hazmat/backends/*.py
181%{py3_sitedir}/cryptography/hazmat/backends/__pycache__
182%dir %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto
183%{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py
184%{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/__pycache__
185%dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
186%{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
187%{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
188%dir %{py3_sitedir}/cryptography/hazmat/bindings
189%{py3_sitedir}/cryptography/hazmat/bindings/*.py
190%{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
191%dir %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto
192%{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py
193%{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/__pycache__
194%dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
195%{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
196%{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
197%dir %{py3_sitedir}/cryptography/hazmat/primitives
198%{py3_sitedir}/cryptography/hazmat/primitives/*.py
199%{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
200%dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
201%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
202%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
203%dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
204%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
205%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
206%dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
207%{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
208%{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
f7d88309
AM
209%dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
210%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
211%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
06232684
JB
212%{py3_sitedir}/cryptography-%{version}-py*.egg-info
213%endif
This page took 0.097481 seconds and 4 git commands to generate.