]> git.pld-linux.org Git - packages/python3-click.git/commitdiff
- updated to 7.1.2
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 27 Jun 2020 12:14:31 +0000 (14:14 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 27 Jun 2020 12:14:31 +0000 (14:14 +0200)
- switch docs build to python3

python-click.spec

index f322327f7b139adf0fd83ebc09618421ce66aefa..23e3d813718fe460e0fae755a8bc8a598ec66d69 100644 (file)
@@ -9,16 +9,14 @@
 Summary:       A simple wrapper around optparse for powerful command line utilities
 Summary(pl.UTF-8):     Proste obudowanie optparse do tworzenia potężnych narzędzi linii poleceń
 Name:          python-%{module}
-Version:       7.0
-Release:       3
+Version:       7.1.2
+Release:       1
 License:       BSD
 Group:         Libraries/Python
 #Source0Download: https://github.com/pallets/click/releases
-# TODO: use:
-#Source0:      https://github.com/pallets/click/archive/%{version}/click-%{version}.tar.gz
-Source0:       https://github.com/pallets/click/archive/%{version}.tar.gz
-# Source0-md5: 1c000f4357bd04e49af568b51bc03c6a
-URL:           http://click.pocoo.org/
+Source0:       https://github.com/pallets/click/archive/%{version}/click-%{version}.tar.gz
+# Source0-md5: 11aa3cff9c99caadb2574fca12aabbdc
+URL:           https://click.palletsprojects.com/
 %if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
 BuildRequires: glibc-localedb-all
 %endif
@@ -26,18 +24,17 @@ BuildRequires:      glibc-localedb-all
 BuildRequires: python-modules >= 2
 BuildRequires: python-pytest
 BuildRequires: python-setuptools
-%{?with_doc:BuildRequires:     python-pallets-sphinx-themes}
 %endif
 %if %{with python3}
 BuildRequires: python3-modules >= 1:3.2
 BuildRequires: python3-pytest
 BuildRequires: python3-setuptools
-%{?with_doc:BuildRequires:     python3-pallets-sphinx-themes}
 %endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with doc}
-BuildRequires: sphinx-pdg-2
+BuildRequires: sphinx-pdg-3
+BuildRequires: python3-pallets-sphinx-themes
 %endif
 Requires:      python-modules >= 2
 BuildArch:     noarch
@@ -92,23 +89,27 @@ Dokumentacja do modułu Pythona click.
 %build
 %if %{with python2}
 %py_build
+
 %if %{with tests}
-PYTHONPATH=$(pwd) %{__python} -m pytest tests --tb=long --verbose
+LC_ALL=C.UTF-8 \
+PYTHONPATH=$(pwd)/src \
+%{__python} -m pytest tests --tb=long --verbose
 %endif
 %endif
 
 %if %{with python3}
 %py3_build
+
 %if %{with tests}
-LC_ALL=C.UTF-8 PYTHONPATH=$(pwd) %{__python3} -m pytest tests --tb=long --verbose
+PYTHONPATH=$(pwd)/src \
+%{__python3} -m pytest tests --tb=long --verbose
 %endif
 %endif
 
 %if %{with doc}
-# click-specific code is not python3 ready
-PYTHONPATH=$(pwd) \
+PYTHONPATH=$(pwd)/src \
 %{__make} -C docs html \
-       SPHINXBUILD=sphinx-build-2
+       SPHINXBUILD=sphinx-build-3
 %endif
 
 %install
@@ -116,6 +117,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
 %py_install
+
 %py_postclean
 %endif
 
@@ -130,16 +132,16 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc CHANGES.rst LICENSE.rst README.rst
-%{py_sitescriptdir}/%{module}
-%{py_sitescriptdir}/Click-%{version}-py*.egg-info
+%{py_sitescriptdir}/click
+%{py_sitescriptdir}/click-%{version}-py*.egg-info
 %endif
 
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
 %doc CHANGES.rst LICENSE.rst README.rst
-%{py3_sitescriptdir}/%{module}
-%{py3_sitescriptdir}/Click-%{version}-py*.egg-info
+%{py3_sitescriptdir}/click
+%{py3_sitescriptdir}/click-%{version}-py*.egg-info
 %endif
 
 %if %{with doc}
This page took 0.120771 seconds and 4 git commands to generate.