]> git.pld-linux.org Git - packages/python3-PyQt6-WebEngine.git/blobdiff - python-PyQtWebEngine.spec
rebuild with tests and docs
[packages/python3-PyQt6-WebEngine.git] / python-PyQtWebEngine.spec
index 77b6f607b667359fa8885a305d1ac1327bb7c956..bc2c941a36ad0aa7f489c88d59d069470dd10953 100644 (file)
@@ -9,23 +9,31 @@
 # %define              qt_ver  %{version}
 %define                qt_ver  5.12.0
 
+%define                _enable_debug_packages  0
+
 Summary:       Python 2 bindings for the Qt5WebEngine module
 Summary(pl.UTF-8):     Wiązania Pythona 2 do modułu Qt5WebEngine
 Name:          python-%{module}
-Version:       5.12
-Release:       1
+Version:       5.15.5
+Release:       4
 License:       GPL v3
 Group:         Libraries/Python
-Source0:       https://www.riverbankcomputing.com/static/Downloads/PyQtWebEngine/PyQtWebEngine_gpl-%{version}.tar.gz
-# Source0-md5: 06ce2b9a100cd5852581edb4f8133e20
+Source0:       https://pypi.python.org/packages/source/P/PyQtWebEngine/PyQtWebEngine-%{version}.tar.gz
+# Source0-md5: 935e8948c6e2a4b41faa0734367ead43
 Patch0:                install.patch
 URL:           http://www.riverbankcomputing.com/software/pyqtwebengine/
-BuildRequires: Qt5WebEngine-devel >= %{qt_ver}}
+BuildRequires: Qt5WebEngine-devel >= %{qt_ver}
 BuildRequires: pkgconfig
+%if %{with python2}
+BuildRequires: python-PyQt5
 BuildRequires: python-PyQt5-sip >= %{sip_ver}
 BuildRequires: python-sip-devel >= %{sip_ver}
+%endif
+%if %{with python3}
+BuildRequires: python3-PyQt5
 BuildRequires: python3-PyQt5-sip >= %{sip_ver}
 BuildRequires: python3-sip-devel >= %{sip_ver}
+%endif
 BuildRequires: qt5-build >= %{qt_ver}
 BuildRequires: qt5-qmake >= %{qt_ver}
 BuildRequires: rpm-pythonprov
@@ -85,7 +93,7 @@ QScintilla aby umożliwić automatyczne dopełnianie i podpowiedzi przy
 modyfikowaniu kodu wykorzystującego PyQtWebEngine.
 
 %prep
-%setup -q -n PyQtWebEngine_gpl-%{version}
+%setup -q -n PyQtWebEngine-%{version}
 %patch0 -p1
 
 %build
@@ -141,6 +149,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{py_sitedir}/PyQt5/QtWebEngine.so
 %attr(755,root,root) %{py_sitedir}/PyQt5/QtWebEngineCore.so
 %attr(755,root,root) %{py_sitedir}/PyQt5/QtWebEngineWidgets.so
+%{py_sitedir}/PyQt5/QtWebEngine.pyi
+%{py_sitedir}/PyQt5/QtWebEngineCore.pyi
+%{py_sitedir}/PyQt5/QtWebEngineWidgets.pyi
 %endif
 
 %if %{with python3}
@@ -149,6 +160,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebEngine.so
 %attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebEngineCore.so
 %attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebEngineWidgets.so
+%{py3_sitedir}/PyQt5/QtWebEngine.pyi
+%{py3_sitedir}/PyQt5/QtWebEngineCore.pyi
+%{py3_sitedir}/PyQt5/QtWebEngineWidgets.pyi
 %endif
 
 %files -n sip-PyQtWebEngine
This page took 0.197583 seconds and 4 git commands to generate.