]> git.pld-linux.org Git - packages/python-zope.interface.git/blob - python-zope.interface.spec
rebuild with separate debuginfo build-ids
[packages/python-zope.interface.git] / python-zope.interface.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6 %bcond_without  tests   # unit tests
7
8 %define         module  zope.interface
9 Summary:        Python 'interface' concept implementation
10 Summary(pl.UTF-8):      Implementacja interfejsów dla języka Python
11 Name:           python-%{module}
12 Version:        4.7.1
13 Release:        6
14 License:        ZPL v2.1
15 Group:          Libraries/Python
16 #Source0Download: https://pypi.org/simple/zope.interface/
17 Source0:        https://files.pythonhosted.org/packages/source/z/zope.interface/zope.interface-%{version}.tar.gz
18 # Source0-md5:  1bc66758275c5eb66d169acba3c8e50e
19 URL:            https://zopeinterface.readthedocs.io/
20 %if %{with python2}
21 BuildRequires:  python >= 1:2.7
22 BuildRequires:  python-devel >= 1:2.7
23 BuildRequires:  python-setuptools
24 %{?with_tests:BuildRequires:    python-zope.event}
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3 >= 1:3.5
28 BuildRequires:  python3-devel >= 1:3.5
29 BuildRequires:  python3-setuptools
30 %{?with_tests:BuildRequires:    python3-zope.event}
31 %endif
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.714
34 %if %{with doc}
35 BuildRequires:  python3-repoze.sphinx.autointerface
36 BuildRequires:  sphinx-pdg-3
37 %endif
38 Requires:       python-modules >= 1:2.7
39 Requires:       python-zope-base
40 Provides:       ZopeInterface
41 Provides:       Zope-Interface
42 Obsoletes:      ZopeInterface
43 Obsoletes:      Zope-Interface
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Python 'interface' concept implementation.
48
49 %description -l pl.UTF-8
50 Implementacja interfejsów (abstrakcyjnych reprezentacji klas) dla
51 języka Python.
52
53 %package -n python3-%{module}
54 Summary:        Python 'interface' concept implementation
55 Summary(pl.UTF-8):      Implementacja interfejsów dla języka Python
56 Group:          Libraries/Python
57 Requires:       python3-modules >= 1:3.5
58 Requires:       python3-zope-base
59
60 %description -n python3-%{module}
61 Python 'interface' concept implementation.
62
63 %description -n python3-%{module} -l pl.UTF-8
64 Implementacja interfejsów (abstrakcyjnych reprezentacji klas) dla
65 języka Python.
66
67 %package apidocs
68 Summary:        API documentation for Python zope.interface module
69 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona zope.interface
70 Group:          Documentation
71 BuildArch:      noarch
72
73 %description apidocs
74 API documentation for Python zope.interface module.
75
76 %description apidocs -l pl.UTF-8
77 Dokumentacja API modułu Pythona zope.interface.
78
79 %prep
80 %setup -q -n %{module}-%{version}
81
82 %build
83 %if %{with python2}
84 %py_build %{?with_tests:test}
85 %endif
86
87 %if %{with python3}
88 %py3_build %{?with_tests:test}
89 %endif
90
91 %if %{with doc}
92 PYTHONPATH=$(pwd)/src \
93 %{__make} -C docs html \
94         SPHINXBUILD=sphinx-build-3
95 %endif
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 %if %{with python2}
100 %py_install
101
102 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/zope/interface/*.c
103
104 %py_postclean
105 %endif
106
107 %if %{with python3}
108 %py3_install
109
110 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/zope/interface/*.c
111 %endif
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %if %{with python2}
117 %files
118 %defattr(644,root,root,755)
119 %doc CHANGES.rst COPYRIGHT.txt README.rst
120 %dir %{py_sitedir}/zope/interface
121 %{py_sitedir}/zope/interface/*.py[co]
122 %attr(755,root,root) %{py_sitedir}/zope/interface/_zope_interface_coptimizations.so
123 %{py_sitedir}/zope/interface/common
124 %{py_sitedir}/zope/interface/tests
125 %{py_sitedir}/zope.interface-%{version}-py*.egg-info
126 %{py_sitedir}/zope.interface-%{version}-py*-nspkg.pth
127 %endif
128
129 %if %{with python3}
130 %files -n python3-%{module}
131 %defattr(644,root,root,755)
132 %doc CHANGES.rst COPYRIGHT.txt README.rst
133 %dir %{py3_sitedir}/zope/interface
134 %{py3_sitedir}/zope/interface/*.py
135 %{py3_sitedir}/zope/interface/__pycache__
136 %attr(755,root,root) %{py3_sitedir}/zope/interface/_zope_interface_coptimizations*.so
137 %{py3_sitedir}/zope/interface/common
138 %{py3_sitedir}/zope/interface/tests
139 %{py3_sitedir}/zope.interface-%{version}-py*.egg-info
140 %{py3_sitedir}/zope.interface-%{version}-py*-nspkg.pth
141 %endif
142
143 %if %{with doc}
144 %files apidocs
145 %defattr(644,root,root,755)
146 %doc docs/_build/html/{_modules,_static,api,*.html,*.js}
147 %endif
This page took 0.074922 seconds and 4 git commands to generate.