]> git.pld-linux.org Git - packages/python-zope.interface.git/blob - python-zope.interface.spec
- python 3.6
[packages/python-zope.interface.git] / python-zope.interface.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 # NOTE: 'module' should match the python import path, not the egg name
7 %define         module  zope.interface
8 Summary:        Python 'interface' concept implementation
9 Summary(pl.UTF-8):      Implementacja interfejsów dla języka Python
10 Name:           python-%{module}
11 Version:        4.0.3
12 Release:        2
13 License:        ZPL 2.1
14 Group:          Libraries/Python
15 Source0:        http://pypi.python.org/packages/source/z/zope.interface/zope.interface-%{version}.tar.gz
16 # Source0-md5:  1ddd308f2c83703accd1696158c300eb
17 URL:            http://docs.zope.org/zope.interface/
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.710
20 %if %{with python2}
21 BuildRequires:  python
22 BuildRequires:  python-devel
23 BuildRequires:  python-setuptools
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3
27 BuildRequires:  python3-devel
28 BuildRequires:  python3-setuptools
29 %endif
30 Requires:       python-modules
31 Requires:       python-zope-base
32 Provides:       ZopeInterface
33 Provides:       Zope-Interface
34 Obsoletes:      ZopeInterface
35 Obsoletes:      Zope-Interface
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Python 'interface' concept implementation.
40
41 %description -l pl.UTF-8
42 Implementacja interfejsów (abstrakcyjnych reprezentacji klas) dla
43 języka Python.
44
45 %package -n python3-%{module}
46 Summary:        Python 'interface' concept implementation
47 Summary(pl.UTF-8):      Implementacja interfejsów dla języka Python
48 Group:          Libraries/Python
49 Requires:       python3-modules
50 Requires:       python3-zope-base
51
52 %description -n python3-%{module}
53 Python 'interface' concept implementation.
54
55 %description -n python3-%{module} -l pl.UTF-8
56 Implementacja interfejsów (abstrakcyjnych reprezentacji klas) dla
57 języka Python.
58
59 %prep
60 %setup -q -n %{module}-%{version}
61
62 %build
63 %if %{with python2}
64 %py_build %{?with_tests:test}
65 %endif
66
67 %if %{with python3}
68 %py3_build %{?with_tests:test}
69 %endif
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %if %{with python2}
74 %py_install
75
76 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/zope/interface/*.c
77
78 %py_postclean
79 %endif
80
81 %if %{with python3}
82 %py3_install
83
84 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/zope/interface/*.c
85 %endif
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %if %{with python2}
91 %files
92 %defattr(644,root,root,755)
93 %doc CHANGES.txt
94 %dir %{py_sitedir}/zope/interface
95 %{py_sitedir}/zope/interface/*.py[co]
96 %attr(755,root,root) %{py_sitedir}/zope/interface/_zope_interface_coptimizations.so
97 %{py_sitedir}/zope/interface/common
98 %{py_sitedir}/zope/interface/tests
99 %{py_sitedir}/zope.interface-*.egg-info
100 %{py_sitedir}/zope.interface-*-nspkg.pth
101 %endif
102
103 %if %{with python3}
104 %files -n python3-%{module}
105 %defattr(644,root,root,755)
106 %doc CHANGES.txt
107 %dir %{py3_sitedir}/zope/interface
108 %{py3_sitedir}/zope/interface/*.py
109 %{py3_sitedir}/zope/interface/__pycache__
110 %attr(755,root,root) %{py3_sitedir}/zope/interface/_zope_interface_coptimizations*.so
111 %{py3_sitedir}/zope/interface/common
112 %{py3_sitedir}/zope/interface/tests
113 %{py3_sitedir}/zope.interface-*.egg-info
114 %{py3_sitedir}/zope.interface-*-nspkg.pth
115 %endif
This page took 0.099752 seconds and 4 git commands to generate.