]> git.pld-linux.org Git - packages/python-zope.interface.git/blob - Zope-Interface.spec
- Up to 4.0.1
[packages/python-zope.interface.git] / Zope-Interface.spec
1 Summary:        Python 'interface' concept implementation
2 Summary(pl.UTF-8):      Implementacja interfejsów dla języka Python
3 Name:           Zope-Interface
4 Version:        4.0.1
5 Release:        1
6 License:        ZPL 2.1
7 Group:          Libraries/Python
8 Source0:        http://pypi.python.org/packages/source/z/zope.interface/zope.interface-%{version}.tar.gz
9 # Source0-md5:  d171f8f8a6997409c7680f1dbb3b7e45
10 URL:            http://www.zope.org/Products/ZopeInterface/
11 BuildRequires:  python
12 BuildRequires:  python-devel
13 BuildRequires:  python-setuptools
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.219
16 %pyrequires_eq  python-modules
17 # set this requirement explicitly, so people know where %py_sitedir/zope
18 # can be found
19 Requires:       Zope-dirs
20 Provides:       ZopeInterface
21 Obsoletes:      ZopeInterface
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Python 'interface' concept implementation.
26
27 %description -l pl.UTF-8
28 Implementacja interfejsów (abstrakcyjnych reprezentacji klas) dla
29 języka Python.
30
31 %prep
32 %setup -q -n zope.interface-%{version}
33
34 %build
35 export CFLAGS="%{rpmcflags}"
36 %{__python} ./setup.py build
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 %{__python} ./setup.py install \
41         --optimize 2 \
42         --root=$RPM_BUILD_ROOT
43
44 %py_postclean
45 rm $RPM_BUILD_ROOT%{py_sitedir}/zope/interface/*.c
46 rm -r $RPM_BUILD_ROOT%{py_sitedir}/zope/interface/common/tests
47 rm -r $RPM_BUILD_ROOT%{py_sitedir}/zope/interface/tests
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc CHANGES.txt
55 %dir %{py_sitedir}/zope/interface
56 %{py_sitedir}/zope/interface/*.py[co]
57 %attr(755,root,root) %{py_sitedir}/zope/interface/_zope_interface_coptimizations.so
58 %{py_sitedir}/zope/interface/common
59 %{py_sitedir}/zope.interface-*.egg-info
60 %{py_sitedir}/zope.interface-*-nspkg.pth
This page took 0.037723 seconds and 4 git commands to generate.