]> git.pld-linux.org Git - packages/python-webcolors.git/commitdiff
- release 3 (by relup.sh) master auto/th/python-webcolors-1.10-3
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 2 Mar 2021 06:31:07 +0000 (07:31 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 2 Mar 2021 06:31:07 +0000 (07:31 +0100)
python-webcolors.spec

index aa8c7f6b433bbd4d1ec8cff71a3566b1e75bd80b..8ce206af395e398eb30269be34421f787d23d659 100644 (file)
@@ -1,7 +1,8 @@
+# NOTE: for versions >= 1.11 (for python 3.5+) see python3-webcolors.spec
 #
 # Conditional build:
 %bcond_without python2 # CPython 2.x module
-%bcond_without python3 # CPython 3.x module
+%bcond_with    python3 # CPython 3.x module (built from python3-webcolors.spec)
 %bcond_without doc     # Sphinx documentation
 %bcond_without tests   # unit tests
 
 Summary:       Library for working with sRGB color specifications as used in HTML and CSS
 Summary(pl.UTF-8):     Biblioteka do pracy z definicjami kolorów sRGB używanymi w formatach HTML i CSS
 Name:          python-%{module}
-Version:       1.7
-Release:       1
+# keep 1.10.x here for python2 support
+Version:       1.10
+Release:       3
 License:       BSD
 Group:         Libraries/Python
-Source0:       https://pypi.python.org/packages/1c/11/d9fb5a7c872a941ad8b30a4be191253d5a9028834c4d69eab55bb6bc60be/%{module}-%{version}.tar.gz
-# Source0-md5: 4733fa1077f680bbdd918cdef1e32c11
+#Source0Download: https://github.com/ubernostrum/webcolors/releases
+Source0:       https://github.com/ubernostrum/webcolors/archive/%{version}/%{module}-%{version}.tar.gz
+# Source0-md5: 195e37e745a77609aca47ea22b01d8b1
 URL:           https://github.com/ubernostrum/webcolors
 %if %{with python2}
 BuildRequires: python-modules >= 1:2.7
+%if %{with tests}
+BuildRequires: python-six
+%endif
 %endif
 %if %{with python3}
-Requires:      python3-modules >= 1:3.3
+Requires:      python3-modules >= 1:3.5
+%if %{with tests}
+BuildRequires: python3-six
+%endif
 %endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with doc}
+BuildRequires: python3-sphinx_rtd_theme
 BuildRequires: sphinx-pdg
 %endif
 Requires:      python-modules >= 1:2.7
@@ -62,7 +72,7 @@ biblioteki standardowej Pythona):
 Summary:       Library for working with sRGB color specifications as used in HTML and CSS
 Summary(pl.UTF-8):     Biblioteka do pracy z definicjami kolorów sRGB używanymi w formatach HTML i CSS
 Group:         Libraries/Python
-Requires:      python3-modules >= 1:3.3
+Requires:      python3-modules >= 1:3.5
 
 %description -n python3-%{module}
 A library for working with color names and color value formats defined
@@ -109,17 +119,24 @@ Dokumentacja do modułu Pythona webcolors.
 %if %{with python2}
 %py_build
 
+%if %{with tests}
+PYTHONPATH=$(pwd)/build-2/lib \
 %{__python} -m unittest discover -s tests
 %endif
+%endif
 
 %if %{with python3}
 %py3_build
 
+%if %{with tests}
+PYTHONPATH=$(pwd)/build-3/lib \
 %{__python3} -m unittest discover -s tests
 %endif
+%endif
 
 %if %{with doc}
-%{__make} -C docs html
+%{__make} -C docs html \
+       SPHINXBUILD=sphinx-build-3
 %endif
 
 %install
This page took 0.077786 seconds and 4 git commands to generate.