]> git.pld-linux.org Git - packages/python-webcolors.git/blob - python-webcolors.spec
- release 1
[packages/python-webcolors.git] / python-webcolors.spec
1 %define         module  webcolors
2 Summary:        A library for working with color names and color value formats defined by the HTML and CSS specifications for use in documents on the Web
3 Name:           python-%module
4 Version:        1.3.1
5 Release:        1
6 License:        BSD License
7 Group:          Development/Languages
8 URL:            http://www.bitbucket.org/ubernostrum/webcolors/overview/
9 Source0:        http://bitbucket.org/ubernostrum/%{module}/downloads/%{module}-%{version}.tar.gz
10 # Source0-md5:  aeb4f33be6c26ec7f76a78c2d88cfb0c
11 BuildRequires:  rpmbuild(macros) >= 1.219
12 BuildRequires:  sed >= 4.0
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 A library for working with color names and color value formats defined
18 by the HTML and CSS specifications for use in documents on the Web.
19
20 Support is included for the following formats (RGB colorspace only;
21 conversion to/from HSL can be handled by the colorsys module in the
22 Python standard library):
23 - Specification-defined color names
24 - Six-digit hexadecimal
25 - Three-digit hexadecimal
26 - Integer rgb() triplet
27 - Percentage rgb() triple
28
29 %prep
30 %setup -q -n %{module}-%{version}
31 %{__sed} -i -e 's/^from ez_setup/#from ez_setup/' setup.py
32 %{__sed} -i -e 's/^use_setuptools()/#use_setuptools()/' setup.py
33
34 %build
35 %{__python} setup.py build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 %{__python} setup.py install \
40         --optimize=2 \
41         --skip-build \
42         --root $RPM_BUILD_ROOT
43
44 %py_postclean
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %{py_sitescriptdir}/%{module}*.py[co]
52 %if "%{py_ver}" > "2.4"
53 %{py_sitescriptdir}/%{module}-%{version}-*.egg-info
54 %endif
This page took 0.047009 seconds and 4 git commands to generate.