]> git.pld-linux.org Git - packages/python-webcolors.git/blob - python-webcolors.spec
- rel. 0.2,
[packages/python-webcolors.git] / python-webcolors.spec
1 %define         module  webcolors
2 Summary:        A library for working with color names and color value formats defined by the HTML and CSS specifications for use in documents on the Web.
3 Name:           python-%module
4 Version:        1.3.1
5 Release:        0.2
6 License:        BSD License
7 Group:          Development/Languages
8 URL:            http://www.bitbucket.org/ubernostrum/webcolors/overview/
9 Source0:        http://bitbucket.org/ubernostrum/%{module}/downloads/%{module}-%{version}.tar.gz
10 # Source0-md5:  aeb4f33be6c26ec7f76a78c2d88cfb0c
11 BuildRequires:  rpmbuild(macros) >= 1.219
12 BuildRequires:  sed >= 4.0
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 A library for working with color names and color value formats defined by the HTML and CSS specifications for use in documents on the Web.
18
19 Support is included for the following formats (RGB colorspace only; conversion to/from HSL can be handled by the colorsys module in the Python standard library):
20
21 - Specification-defined color names
22 - Six-digit hexadecimal
23 - Three-digit hexadecimal
24 - Integer rgb() triplet
25 - Percentage rgb() triple
26
27 %prep
28 %setup -q -n %{module}-%{version}
29 %{__sed} -i -e 's/^from ez_setup/#from ez_setup/' setup.py
30 %{__sed} -i -e 's/^use_setuptools()/#use_setuptools()/' setup.py
31
32 %build
33 %{__python} setup.py build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 %{__python} setup.py install \
38         --optimize=2 \
39         --skip-build \
40         --root $RPM_BUILD_ROOT
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %{py_sitescriptdir}/%{module}.*
48 %if "%{py_ver}" > "2.4"
49 %{py_sitescriptdir}/%{module}-%{version}-*.egg-info
50 %endif
This page took 0.054747 seconds and 4 git commands to generate.