]> git.pld-linux.org Git - packages/python-strict_rfc3339.git/blob - python-strict_rfc3339.spec
- new
[packages/python-strict_rfc3339.git] / python-strict_rfc3339.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Strict, simple, lightweight RFC3339 functions for Python 2
7 Summary(pl.UTF-8):      Ścisłe, proste, lekkie funkcje RFC3339 dla Pythona 2
8 Name:           python-strict_rfc3339
9 Version:        0.7
10 Release:        1
11 License:        GPL v3+
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.python.org/simple/strict-rfc3339/
14 Source0:        https://files.pythonhosted.org/packages/source/s/strict-rfc3339/strict-rfc3339-%{version}.tar.gz
15 # Source0-md5:  4d9b635b4df885bc37bc1189d66c9abc
16 URL:            https://pypi.python.org/pypi/strict-rfc3339/
17 %if %{with python2}
18 BuildRequires:  python-devel >= 1:2.5
19 BuildRequires:  python-modules >= 1:2.5
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-devel >= 1:3.2
23 BuildRequires:  python3-modules >= 1:3.2
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python-modules >= 1:2.5
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Strict, simple, lightweight RFC3339 functions for Python 2.
33
34 %description -l pl.UTF-8
35 Ścisłe, proste, lekkie funkcje RFC3339 dla Pythona 2.
36
37 %package -n python3-strict_rfc3339
38 Summary:        Strict, simple, lightweight RFC3339 functions for Python 3
39 Summary(pl.UTF-8):      Ścisłe, proste, lekkie funkcje RFC3339 dla Pythona 3
40 Group:          Libraries/Python
41 Requires:       python3-modules >= 1:3.2
42
43 %description -n python3-strict_rfc3339
44 Strict, simple, lightweight RFC3339 functions for Python 3.
45
46 %description -n python3-strict_rfc3339 -l pl.UTF-8
47 Ścisłe, proste, lekkie funkcje RFC3339 dla Pythona 3.
48
49 %prep
50 %setup -q -n strict-rfc3339-%{version}
51
52 %build
53 %if %{with python2}
54 %py_build
55 %endif
56
57 %if %{with python3}
58 %py3_build
59 %endif
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %if %{with python2}
65 %py_install
66
67 %py_postclean
68 %endif
69
70 %if %{with python3}
71 %py3_install
72 %endif
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc AUTHORS README.md
80 %{py_sitescriptdir}/strict_rfc3339.py[co]
81 %{py_sitescriptdir}/strict_rfc3339-%{version}-py*.egg-info
82
83 %files -n python3-strict_rfc3339
84 %defattr(644,root,root,755)
85 %doc AUTHORS README.md
86 %{py3_sitescriptdir}/strict_rfc3339.py
87 %{py3_sitescriptdir}/__pycache__/strict_rfc3339.cpython-*.py[co]
88 %{py3_sitescriptdir}/strict_rfc3339-%{version}-py*.egg-info
This page took 0.060825 seconds and 3 git commands to generate.