]> git.pld-linux.org Git - packages/python-stevedore.git/commitdiff
automatic change: use py_build/py_install macros
authorJacek Konieczny <jajcus@jajcus.net>
Sat, 28 Nov 2015 17:06:44 +0000 (18:06 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Sat, 28 Nov 2015 17:06:44 +0000 (18:06 +0100)
python-stevedore.spec

index 92beb99b2e9fc0418a912f8ebe2968ee4f2ff7fc..0c13bcb56d82a8db0d5aeeb9abc50092936e12b0 100644 (file)
@@ -59,7 +59,7 @@ Manage dynamic plugins for Python applications
 
 %build
 %if %{with python2}
-%{__python} setup.py build --build-base build-2
+%py_build
 
 %if %{with tests}
 PYTHONPATH=. nosetests-%{py_ver}
@@ -67,7 +67,7 @@ PYTHONPATH=. nosetests-%{py_ver}
 %endif
 
 %if %{with python3}
-%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%py3_build %{?with_tests:test}
 
 %if %{with tests}
 PYTHONPATH=. nosetests-%{py3_ver}
@@ -78,11 +78,7 @@ PYTHONPATH=. nosetests-%{py3_ver}
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
-%{__python} setup.py \
-       build --build-base build-2 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 
 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/stevedore/tests
 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/stevedore/example
@@ -91,11 +87,7 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %if %{with python3}
-%{__python3} setup.py \
-       build --build-base build-3 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 
 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/stevedore/tests
 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/stevedore/example
This page took 0.151644 seconds and 4 git commands to generate.