]> git.pld-linux.org Git - packages/python-stevedore.git/commitdiff
Version: 1.25.0 auto/th/python-stevedore-1.25.0-1
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Tue, 1 Aug 2017 08:34:18 +0000 (10:34 +0200)
committerJacek Konieczny <j.konieczny@eggsoft.pl>
Tue, 1 Aug 2017 08:34:18 +0000 (10:34 +0200)
python-stevedore.spec

index fc66767ab493ec10f302fdd7ab07e383c721fca5..bb547f9d25b386cdc9a0d81229f541d6e486b63d 100644 (file)
@@ -2,40 +2,47 @@
 # Conditional build:
 %bcond_with    tests   # do not perform "make test"
 %bcond_without python2 # CPython 2.x module
-%bcond_with    python3 # CPython 3.x module
+%bcond_without python3 # CPython 3.x module
 
 %define        module  stevedore
 Summary:       Manage dynamic plugins for Python applications
 Name:          python-%{module}
-Version:       1.1.0
+Version:       1.25.0
 Release:       1
 License:       Apache v2.0
 Group:         Development/Languages
-Source0:       http://pypi.python.org/packages/source/s/stevedore/stevedore-%{version}.tar.gz
-# Source0-md5: b7f30055c32410f8f9b6cf1b55bdc68a
-URL:           https://github.com/dreamhost/stevedore
+Source0:       https://pypi.python.org/packages/08/58/e21f4691e8e75a290bdbfa366f06b9403c653642ef31f879e07f6f9ad7db/stevedore-1.25.0.tar.gz
+# Source0-md5: 8de5610a69f8066191d3e4b9af82c437
+URL:           https://pypi.python.org/pypi/stevedore
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.710
 %if %{with python2}
 BuildRequires: python-setuptools
+BuildRequires: python-pbr >= 2.0.0
 %if %{with tests}
-#BuildRequires:  python-discover
-BuildRequires: python-mock
-#BuildRequires:  python-oslotest
-BuildRequires: python-pbr
-BuildRequires: python-six
-BuildRequires: python-testrepository
+BuildRequires: python-six >= 1.9.0
+BuildRequires:  python-pillow >= 2.4.0
+BuildRequires: sphinx-pdg-2 >= 1.6.2
+BuildRequires: python-mock >= 2.0
+BuildRequires:  python-coverage >=4.0
+BuildRequires:  python-testrepository >= 0.0.18
+BuildRequires: python-openstackdocstheme >=1.11.0
+BuildRequires: python-reno >=1.8.0
 %endif
 %endif
 %if %{with python3}
-BuildRequires: python3-devel
-#BuildRequires:  python3-discover
-BuildRequires: python3-mock
-#BuildRequires:  python3-oslotest
-BuildRequires: python3-pbr
 BuildRequires: python3-setuptools
-BuildRequires: python3-six
-#BuildRequires:  python3-testrepository
+BuildRequires: python3-pbr >= 2.0.0
+%if %{with tests}
+BuildRequires: python3-six >= 1.9.0
+BuildRequires:  python3-pillow >= 2.4.0
+BuildRequires: sphinx-pdg-3 >= 1.6.2
+BuildRequires: python3-mock >= 2.0
+BuildRequires:  python3-coverage >=4.0
+BuildRequires:  python3-testrepository >= 0.0.18
+BuildRequires: python3-openstackdocstheme >=1.11.0
+BuildRequires: python3-reno >=1.8.0
+%endif
 %endif
 Requires:      python-setuptools
 Requires:      python-six
@@ -59,19 +66,11 @@ Manage dynamic plugins for Python applications
 
 %build
 %if %{with python2}
-%py_build
-
-%if %{with tests}
-PYTHONPATH=. nosetests-%{py_ver}
-%endif
+%py_build %{?with_tests:test}
 %endif
 
 %if %{with python3}
 %py3_build %{?with_tests:test}
-
-%if %{with tests}
-PYTHONPATH=. nosetests-%{py3_ver}
-%endif
 %endif
 
 %install
This page took 0.157262 seconds and 4 git commands to generate.