]> git.pld-linux.org Git - packages/python-sqlalchemy.git/commitdiff
- do not test azure connection, rel 5 auto/th/python-sqlalchemy-1.3.23-5
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 28 Nov 2021 19:35:24 +0000 (20:35 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 28 Nov 2021 19:35:24 +0000 (20:35 +0100)
python-sqlalchemy-tests.patch
python-sqlalchemy.spec

index 0f361bf558bb823a74faaa0af19f163f843d794f..5e4a52bcda4547d699178b275b196c5a7341ea2c 100644 (file)
@@ -19,3 +19,32 @@ diff -urNp -x '*.orig' SQLAlchemy-1.3.23.org/setup.py SQLAlchemy-1.3.23/setup.py
              "pytest-xdist",
          ],
          long_description=readme,
+--- SQLAlchemy-1.3.23/test/dialect/mssql/test_engine.py~       2021-02-01 21:52:02.000000000 +0100
++++ SQLAlchemy-1.3.23/test/dialect/mssql/test_engine.py        2021-11-28 20:02:55.581556369 +0100
+@@ -158,26 +158,6 @@
+             True,
+         )
+-    def test_pyodbc_extra_connect_azure(self):
+-        # issue #5592
+-        dialect = pyodbc.dialect()
+-        u = url.make_url(
+-            "mssql+pyodbc://@server_name/db_name?"
+-            "driver=ODBC+Driver+17+for+SQL+Server;"
+-            "authentication=ActiveDirectoryIntegrated"
+-        )
+-        connection = dialect.create_connect_args(u)
+-        eq_(connection[1], {})
+-        eq_(
+-            connection[0][0]
+-            in (
+-                "DRIVER={ODBC Driver 17 for SQL Server};"
+-                "Server=server_name;Database=db_name;"
+-                "Authentication=ActiveDirectoryIntegrated",
+-            ),
+-            True,
+-        )
+-
+     def test_pyodbc_odbc_connect(self):
+         dialect = pyodbc.dialect()
+         u = url.make_url(
index 1b821db25302cdefe8c555cd898e121a2a498ea5..6f2900c9c3ef159d61a078dac712e3e79f3278d6 100644 (file)
@@ -9,7 +9,7 @@ Summary:        Database Abstraction Library for Python 2
 Summary(pl.UTF-8):     Biblioteka abstrakcji baz danych dla Pythona 2
 Name:          python-%{module}
 Version:       1.3.23
-Release:       4
+Release:       5
 License:       MIT
 Group:         Libraries/Python
 #Source0Download: https://pypi.org/simple/sqlalchemy/
This page took 0.04988 seconds and 4 git commands to generate.