]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blobdiff - python-sqlalchemy-tests.patch
- updated to 1.4.50
[packages/python-sqlalchemy.git] / python-sqlalchemy-tests.patch
index a404e2428e2338f618a960d88695a415c9e5411e..c25339295c49307ee30084510d15247015586009 100644 (file)
@@ -1,34 +1,30 @@
---- SQLAlchemy-1.2.7/setup.py.orig     2018-04-20 22:27:50.000000000 +0200
-+++ SQLAlchemy-1.2.7/setup.py  2018-05-26 11:23:38.674698725 +0200
-@@ -81,7 +81,7 @@
-     # not working at the time of this comment.
-     user_options = [('pytest-args=', 'a', "Arguments to pass to py.test")]
+--- SQLAlchemy-1.3.24/test/dialect/mssql/test_engine.py~       2021-03-31 00:58:18.000000000 +0200
++++ SQLAlchemy-1.3.24/test/dialect/mssql/test_engine.py        2022-03-31 08:03:00.006533320 +0200
+@@ -158,26 +158,6 @@ class ParseConnectTest(fixtures.TestBase
+             True,
+         )
  
--    default_options = ["-n", "4", "-q", "--nomemory"]
-+    default_options = ["-q", "--nomemory"]
-     def initialize_options(self):
-         TestCommand.initialize_options(self)
-@@ -121,6 +121,13 @@
-     readme = r_file.read()
-+def get_mock_dep():
-+    try:
-+        from unittest import mock
-+        return []
-+    except ImportError:
-+        return ['mock']
-+
- def run_setup(with_cext):
-     kwargs = {}
-     if with_cext:
-@@ -139,7 +146,7 @@
-         package_dir={'': 'lib'},
-         license="MIT License",
-         cmdclass=cmdclass,
--        tests_require=['pytest>=2.5.2,!=3.9.1,!=3.9.2', 'mock', 'pytest-xdist'],
-+        tests_require=['pytest>=2.5.2,!=3.9.1,!=3.9.2', 'pytest-xdist'] + get_mock_dep(),
-         long_description=readme,
-         classifiers=[
-             "Development Status :: 5 - Production/Stable",
+-    def test_pyodbc_extra_connect_azure(self):
+-        # issue #5592
+-        dialect = pyodbc.dialect()
+-        u = url.make_url(
+-            "mssql+pyodbc://@server_name/db_name?"
+-            "driver=ODBC+Driver+17+for+SQL+Server&"
+-            "authentication=ActiveDirectoryIntegrated"
+-        )
+-        connection = dialect.create_connect_args(u)
+-        eq_(connection[1], {})
+-        eq_(
+-            connection[0][0]
+-            in (
+-                "DRIVER={ODBC Driver 17 for SQL Server};"
+-                "Server=server_name;Database=db_name;"
+-                "Authentication=ActiveDirectoryIntegrated",
+-            ),
+-            True,
+-        )
+-
+     def test_pyodbc_odbc_connect(self):
+         dialect = pyodbc.dialect()
+         u = url.make_url(
+
This page took 0.027795 seconds and 4 git commands to generate.