]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blobdiff - python-sqlalchemy-tests.patch
rebuild with python 3.10
[packages/python-sqlalchemy.git] / python-sqlalchemy-tests.patch
index a00146f05561f884c9685b1f6662ec456cb36746..5e4a52bcda4547d699178b275b196c5a7341ea2c 100644 (file)
@@ -1,15 +1,16 @@
---- SQLAlchemy-1.2.7/setup.py.orig     2018-04-20 22:27:50.000000000 +0200
-+++ SQLAlchemy-1.2.7/setup.py  2018-05-26 11:23:38.674698725 +0200
-@@ -81,7 +81,7 @@
+diff -urNp -x '*.orig' SQLAlchemy-1.3.23.org/setup.py SQLAlchemy-1.3.23/setup.py
+--- SQLAlchemy-1.3.23.org/setup.py     2021-02-01 21:52:02.000000000 +0100
++++ SQLAlchemy-1.3.23/setup.py 2021-03-07 23:28:59.044650527 +0100
+@@ -89,7 +89,7 @@ class PyTest(TestCommand):
      # not working at the time of this comment.
-     user_options = [('pytest-args=', 'a', "Arguments to pass to py.test")]
+     user_options = [("pytest-args=", "a", "Arguments to pass to py.test")]
  
 -    default_options = ["-n", "4", "-q", "--nomemory"]
 +    default_options = ["-q", "--nomemory"]
  
      def initialize_options(self):
          TestCommand.initialize_options(self)
-@@ -159,7 +159,7 @@
+@@ -159,7 +159,7 @@ def run_setup(with_cext):
          cmdclass=cmdclass,
          tests_require=[
              "pytest>=2.5.2,!=3.9.1,!=3.9.2",
              "pytest-xdist",
          ],
          long_description=readme,
+--- SQLAlchemy-1.3.23/test/dialect/mssql/test_engine.py~       2021-02-01 21:52:02.000000000 +0100
++++ SQLAlchemy-1.3.23/test/dialect/mssql/test_engine.py        2021-11-28 20:02:55.581556369 +0100
+@@ -158,26 +158,6 @@
+             True,
+         )
+-    def test_pyodbc_extra_connect_azure(self):
+-        # issue #5592
+-        dialect = pyodbc.dialect()
+-        u = url.make_url(
+-            "mssql+pyodbc://@server_name/db_name?"
+-            "driver=ODBC+Driver+17+for+SQL+Server;"
+-            "authentication=ActiveDirectoryIntegrated"
+-        )
+-        connection = dialect.create_connect_args(u)
+-        eq_(connection[1], {})
+-        eq_(
+-            connection[0][0]
+-            in (
+-                "DRIVER={ODBC Driver 17 for SQL Server};"
+-                "Server=server_name;Database=db_name;"
+-                "Authentication=ActiveDirectoryIntegrated",
+-            ),
+-            True,
+-        )
+-
+     def test_pyodbc_odbc_connect(self):
+         dialect = pyodbc.dialect()
+         u = url.make_url(
This page took 0.160574 seconds and 4 git commands to generate.