]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blobdiff - python-sqlalchemy-tests.patch
rebuild with python 3.10
[packages/python-sqlalchemy.git] / python-sqlalchemy-tests.patch
index 0f361bf558bb823a74faaa0af19f163f843d794f..5e4a52bcda4547d699178b275b196c5a7341ea2c 100644 (file)
@@ -19,3 +19,32 @@ diff -urNp -x '*.orig' SQLAlchemy-1.3.23.org/setup.py SQLAlchemy-1.3.23/setup.py
              "pytest-xdist",
          ],
          long_description=readme,
+--- SQLAlchemy-1.3.23/test/dialect/mssql/test_engine.py~       2021-02-01 21:52:02.000000000 +0100
++++ SQLAlchemy-1.3.23/test/dialect/mssql/test_engine.py        2021-11-28 20:02:55.581556369 +0100
+@@ -158,26 +158,6 @@
+             True,
+         )
+-    def test_pyodbc_extra_connect_azure(self):
+-        # issue #5592
+-        dialect = pyodbc.dialect()
+-        u = url.make_url(
+-            "mssql+pyodbc://@server_name/db_name?"
+-            "driver=ODBC+Driver+17+for+SQL+Server;"
+-            "authentication=ActiveDirectoryIntegrated"
+-        )
+-        connection = dialect.create_connect_args(u)
+-        eq_(connection[1], {})
+-        eq_(
+-            connection[0][0]
+-            in (
+-                "DRIVER={ODBC Driver 17 for SQL Server};"
+-                "Server=server_name;Database=db_name;"
+-                "Authentication=ActiveDirectoryIntegrated",
+-            ),
+-            True,
+-        )
+-
+     def test_pyodbc_odbc_connect(self):
+         dialect = pyodbc.dialect()
+         u = url.make_url(
This page took 0.19112 seconds and 4 git commands to generate.