]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blobdiff - python-SQLAlchemy.spec
- updated to 0.6.7
[packages/python-sqlalchemy.git] / python-SQLAlchemy.spec
index 26b60600790acb72e448c99f05e4350f8b51b053..673219aed0ce87fd8a350b166610642ab40290af 100644 (file)
@@ -1,18 +1,36 @@
+# TODO:
+# - examples and docs for python3
+# - builds, but got syntax errors when buildings
+#
+%bcond_without python3
+%bcond_without python2
+%define                module  SQLAlchemy
+#
 Summary:       Database Abstraction Library
 Summary(pl.UTF-8):     Biblioteka abstrakcji baz danych
-Name:          python-SQLAlchemy
-Version:       0.4.1
-Release:       1
+Name:          python-%{module}
+Version:       0.6.7
+Release:       0.1
 License:       MIT
 Group:         Libraries/Python
-Source0:       http://cheeseshop.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-%{version}.tar.gz
-# Source0-md5: be6fe319806141d577f8ab02f90870a2
+Source0:       http://downloads.sourceforge.net/sqlalchemy/%{module}-%{version}.tar.gz
+# Source0-md5: 4fb693f436171d245e4e8688bab4c4a1
 URL:           http://www.sqlalchemy.org/
-BuildRequires: python-devel
+%if %{with python2}
+BuildRequires: python-devel >= 1:2.4
+BuildRequires: python-distribute
 BuildRequires: python-setuptools >= 0.6-0.a9.1
+%endif
+%if %{with python3}
+BuildRequires: python3-2to3
+BuildRequires: python3-devel
+BuildRequires: python3-modules
+%endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.219
+%if %{with python2}
 %pyrequires_eq  python-modules
+%endif
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -23,6 +41,8 @@ SQLAlchemy provides a full suite of well known enterprise-level
 persistence patterns, designed for efficient and high-performing
 database access, adapted into a simple and Pythonic domain language.
 
+Python 2.x version.
+
 %description -l pl.UTF-8
 Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
 dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
@@ -30,29 +50,79 @@ udostępnia pełny zbiór dobrze znanych wzorców trwałości,
 zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
 prostej, pythonowej domeny językowej.
 
+Wersja dla pythona 2.x.
+
+%package -n python3-%{module}
+Summary:       Database Abstraction Library
+Summary(pl.UTF-8):     Biblioteka abstrakcji baz danych
+Group:         Libraries/Python
+
+%description -n python3-%{module}
+The Python SQL toolkit and Object Relational Mapper that gives
+application developers the full power and flexibility of SQL.
+SQLAlchemy provides a full suite of well known enterprise-level
+persistence patterns, designed for efficient and high-performing
+database access, adapted into a simple and Pythonic domain language.
+
+Python 3.x version.
+
+%description -n python3-%{module} -l pl.UTF-8
+Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
+dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
+udostępnia pełny zbiór dobrze znanych wzorców trwałości,
+zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
+prostej, pythonowej domeny językowej.
+
+Wersja dla Pythona 3.x.
+
 %prep
-%setup -q -n SQLAlchemy-%{version}
+%setup -q -n %{module}-%{version}
 
 %build
-python setup.py build
+%if %{with python2}
+%{__python} setup.py build -b build-2
+%endif
+%if %{with python3}
+%{__python3} setup.py build -b build-3
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-python setup.py install \
+%if %{with python2}
+%{__python} setup.py build -b build-2 \
+       install \
        --single-version-externally-managed \
        --optimize=2 \
        --root=$RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %py_postclean
+%endif
+
+%if %{with python3}
+%{__python3} setup.py build -b build-3 \
+       install \
+       --root=$RPM_BUILD_ROOT \
+       --optimize=2
+
+%py3_postclean
+%endif
+
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README CHANGES doc/*html
+%doc CHANGES README* doc/*.html
 %{py_sitescriptdir}/SQLAlchemy*
 %{py_sitescriptdir}/sqlalchemy*
-%{_examplesdir}/%{name}-%{version}/
+%{_examplesdir}/%{name}-%{version}
+
+%if %{with python3}
+%files -n python3-%{module}
+%defattr(644,root,root,755)
+%{py3_sitescriptdir}/SQLAlchemy*
+%{py3_sitescriptdir}/sqlalchemy*
+%endif
This page took 0.097498 seconds and 4 git commands to generate.