]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blob - python-sqlalchemy.spec
- updated to 1.3.12
[packages/python-sqlalchemy.git] / python-sqlalchemy.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5 %bcond_without  tests   # unit tests
6
7 %define         module  sqlalchemy
8 Summary:        Database Abstraction Library for Python 2
9 Summary(pl.UTF-8):      Biblioteka abstrakcji baz danych dla Pythona 2
10 Name:           python-%{module}
11 Version:        1.3.12
12 Release:        1
13 License:        MIT
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/sqlalchemy/
16 Source0:        https://files.pythonhosted.org/packages/source/S/SQLAlchemy/SQLAlchemy-%{version}.tar.gz
17 # Source0-md5:  02a46be841903b60c52a83342d3ced8e
18 Patch0:         %{name}-tests.patch
19 URL:            http://www.sqlalchemy.org/
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.714
22 %if %{with python2}
23 BuildRequires:  python-devel >= 1:2.7
24 BuildRequires:  python-modules >= 1:2.7
25 BuildRequires:  python-setuptools >= 0.6-0.a9.1
26 %if %{with tests}
27 BuildRequires:  python-mock
28 BuildRequires:  python-pytest >= 2.5.2
29 BuildRequires:  python-pytest-xdist
30 %endif
31 %endif
32 %if %{with python3}
33 BuildRequires:  python3-devel >= 1:3.4
34 BuildRequires:  python3-modules >= 1:3.4
35 BuildRequires:  python3-setuptools >= 0.6-0.a9.1
36 %if %{with tests}
37 BuildRequires:  python3-pytest >= 2.5.2
38 BuildRequires:  python3-pytest-xdist
39 %endif
40 %endif
41 Requires:       python-modules
42 Provides:       python-SQLAlchemy = %{version}-%{release}
43 Obsoletes:      python-SQLAlchemy < 0.9.8
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 The Python SQL toolkit and Object Relational Mapper that gives
48 application developers the full power and flexibility of SQL.
49 SQLAlchemy provides a full suite of well known enterprise-level
50 persistence patterns, designed for efficient and high-performing
51 database access, adapted into a simple and Pythonic domain language.
52
53 Python 2.x version.
54
55 %description -l pl.UTF-8
56 Zestaw narzędzi SQL oraz odwzorowań obiektowo-relacyjnych dla Pythona,
57 dający programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
58 udostępnia pełny zbiór dobrze znanych wzorców trwałości,
59 zaprojektowanych z myślą o efektywny i wydajnym dostępem do baz
60 danych, zaadaptowanych do prostego, pythonowego języka.
61
62 Wersja dla pythona 2.x.
63
64 %package -n python3-%{module}
65 Summary:        Database Abstraction Library for Python 3
66 Summary(pl.UTF-8):      Biblioteka abstrakcji baz danych dla Pythona 3
67 Group:          Libraries/Python
68 Provides:       python3-SQLAlchemy = %{version}-%{release}
69 Obsoletes:      python3-SQLAlchemy < 0.9.8
70
71 %description -n python3-%{module}
72 The Python SQL toolkit and Object Relational Mapper that gives
73 application developers the full power and flexibility of SQL.
74 SQLAlchemy provides a full suite of well known enterprise-level
75 persistence patterns, designed for efficient and high-performing
76 database access, adapted into a simple and Pythonic domain language.
77
78 Python 3.x version.
79
80 %description -n python3-%{module} -l pl.UTF-8
81 Zestaw narzędzi SQL oraz odwzorowań obiektowo-relacyjnych dla Pythona,
82 dający programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
83 udostępnia pełny zbiór dobrze znanych wzorców trwałości,
84 zaprojektowanych z myślą o efektywny i wydajnym dostępem do baz
85 danych, zaadaptowanych do prostego, pythonowego języka.
86
87 Wersja dla Pythona 3.x.
88
89 %package apidocs
90 Summary:        API documentation for Python SQLAlchemy module
91 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona SQLAlchemy
92 Group:          Documentation
93 %if "%{_rpmversion}" >= "4.6"
94 BuildArch:      noarch
95 %endif
96
97 %description apidocs
98 API documentation for Python SQLAlchemy module.
99
100 %description apidocs -l pl.UTF-8
101 Dokumentacja API modułu Pythona SQLAlchemy.
102
103 %package examples
104 Summary:        Examples for Python SQLAlchemy module
105 Summary(pl.UTF-8):      Przykłady do modułu Pythona SQLAlchemy
106 Group:          Documentation
107 %if "%{_rpmversion}" >= "4.6"
108 BuildArch:      noarch
109 %endif
110
111 %description examples
112 Examples for Python SQLAlchemy module.
113
114 %description examples -l pl.UTF-8
115 Przykłady do modułu Pythona SQLAlchemy.
116
117 %prep
118 %setup -q -n SQLAlchemy-%{version}
119 %patch0 -p1
120
121 %build
122 %if %{with python2}
123 %py_build
124
125 %if %{with tests}
126 %{__python} -m pytest test
127 %endif
128 %endif
129
130 %if %{with python3}
131 %py3_build
132
133 %if %{with tests}
134 %{__python3} -m pytest test
135 %endif
136 %endif
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 %if %{with python2}
141 %py_install
142
143 %py_postclean
144 %endif
145
146 %if %{with python3}
147 %py3_install
148 %endif
149
150 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
151 cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %files
157 %defattr(644,root,root,755)
158 %doc AUTHORS CHANGES LICENSE README.rst
159 %dir %{py_sitedir}/sqlalchemy
160 %{py_sitedir}/sqlalchemy/connectors
161 %{py_sitedir}/sqlalchemy/databases
162 %{py_sitedir}/sqlalchemy/dialects
163 %{py_sitedir}/sqlalchemy/engine
164 %{py_sitedir}/sqlalchemy/event
165 %{py_sitedir}/sqlalchemy/ext
166 %{py_sitedir}/sqlalchemy/orm
167 %{py_sitedir}/sqlalchemy/pool
168 %{py_sitedir}/sqlalchemy/sql
169 %{py_sitedir}/sqlalchemy/testing
170 %{py_sitedir}/sqlalchemy/util
171 %attr(755,root,root) %{py_sitedir}/sqlalchemy/cprocessors.so
172 %attr(755,root,root) %{py_sitedir}/sqlalchemy/cresultproxy.so
173 %attr(755,root,root) %{py_sitedir}/sqlalchemy/cutils.so
174 %{py_sitedir}/sqlalchemy/*.py[co]
175 %{py_sitedir}/SQLAlchemy-%{version}-py*.egg-info
176
177 %if %{with python3}
178 %files -n python3-%{module}
179 %defattr(644,root,root,755)
180 %doc AUTHORS CHANGES LICENSE README.rst
181 %dir %{py3_sitedir}/sqlalchemy
182 %{py3_sitedir}/sqlalchemy/connectors
183 %{py3_sitedir}/sqlalchemy/databases
184 %{py3_sitedir}/sqlalchemy/dialects
185 %{py3_sitedir}/sqlalchemy/engine
186 %{py3_sitedir}/sqlalchemy/event
187 %{py3_sitedir}/sqlalchemy/ext
188 %{py3_sitedir}/sqlalchemy/orm
189 %{py3_sitedir}/sqlalchemy/pool
190 %{py3_sitedir}/sqlalchemy/sql
191 %{py3_sitedir}/sqlalchemy/testing
192 %{py3_sitedir}/sqlalchemy/util
193 %attr(755,root,root) %{py3_sitedir}/sqlalchemy/cprocessors.cpython-*.so
194 %attr(755,root,root) %{py3_sitedir}/sqlalchemy/cresultproxy.cpython-*.so
195 %attr(755,root,root) %{py3_sitedir}/sqlalchemy/cutils.cpython-*.so
196 %{py3_sitedir}/sqlalchemy/*.py
197 %{py3_sitedir}/sqlalchemy/__pycache__
198 %{py3_sitedir}/SQLAlchemy-%{version}-py*.egg-info
199 %endif
200
201 %files apidocs
202 %defattr(644,root,root,755)
203 %doc doc/{_images,_modules,_static,changelog,core,dialects,faq,orm,*.html,*.js}
204
205 %files examples
206 %defattr(644,root,root,755)
207 %{_examplesdir}/%{name}-%{version}
This page took 0.074873 seconds and 4 git commands to generate.