]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blob - python-sqlalchemy.spec
76f2f4d21871b09c7bb2b0d865acfefbadbb3848
[packages/python-sqlalchemy.git] / python-sqlalchemy.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5 %bcond_without  tests   # unit tests
6
7 %define         module  sqlalchemy
8 Summary:        Database Abstraction Library for Python 2
9 Summary(pl.UTF-8):      Biblioteka abstrakcji baz danych dla Pythona 2
10 Name:           python-%{module}
11 Version:        1.3.23
12 Release:        2
13 License:        MIT
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/sqlalchemy/
16 Source0:        https://files.pythonhosted.org/packages/source/S/SQLAlchemy/SQLAlchemy-%{version}.tar.gz
17 # Source0-md5:  179d25a8fea451f06539c12bb0a00081
18 Patch0:         %{name}-tests.patch
19 URL:            https://www.sqlalchemy.org/
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.714
22 %if %{with python2}
23 BuildRequires:  python-devel >= 1:2.7
24 BuildRequires:  python-modules >= 1:2.7
25 BuildRequires:  python-setuptools >= 0.6-0.a9.1
26 %if %{with tests}
27 BuildRequires:  python-mock
28 BuildRequires:  python-pytest >= 2.5.2
29 BuildRequires:  python-pytest-xdist
30 %endif
31 %endif
32 %if %{with python3}
33 BuildRequires:  python3-devel >= 1:3.4
34 BuildRequires:  python3-modules >= 1:3.4
35 BuildRequires:  python3-setuptools >= 0.6-0.a9.1
36 %if %{with tests}
37 BuildRequires:  python3-pytest >= 2.5.2
38 BuildRequires:  python3-pytest-xdist
39 %endif
40 %endif
41 Requires:       python-modules
42 Provides:       python-SQLAlchemy = %{version}-%{release}
43 Obsoletes:      python-SQLAlchemy < 0.9.8
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 The Python SQL toolkit and Object Relational Mapper that gives
48 application developers the full power and flexibility of SQL.
49 SQLAlchemy provides a full suite of well known enterprise-level
50 persistence patterns, designed for efficient and high-performing
51 database access, adapted into a simple and Pythonic domain language.
52
53 Python 2.x version.
54
55 %description -l pl.UTF-8
56 Zestaw narzędzi SQL oraz odwzorowań obiektowo-relacyjnych dla Pythona,
57 dający programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
58 udostępnia pełny zbiór dobrze znanych wzorców trwałości,
59 zaprojektowanych z myślą o efektywny i wydajnym dostępem do baz
60 danych, zaadaptowanych do prostego, pythonowego języka.
61
62 Wersja dla pythona 2.x.
63
64 %package -n python3-%{module}
65 Summary:        Database Abstraction Library for Python 3
66 Summary(pl.UTF-8):      Biblioteka abstrakcji baz danych dla Pythona 3
67 Group:          Libraries/Python
68 Provides:       python3-SQLAlchemy = %{version}-%{release}
69 Obsoletes:      python3-SQLAlchemy < 0.9.8
70
71 %description -n python3-%{module}
72 The Python SQL toolkit and Object Relational Mapper that gives
73 application developers the full power and flexibility of SQL.
74 SQLAlchemy provides a full suite of well known enterprise-level
75 persistence patterns, designed for efficient and high-performing
76 database access, adapted into a simple and Pythonic domain language.
77
78 Python 3.x version.
79
80 %description -n python3-%{module} -l pl.UTF-8
81 Zestaw narzędzi SQL oraz odwzorowań obiektowo-relacyjnych dla Pythona,
82 dający programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
83 udostępnia pełny zbiór dobrze znanych wzorców trwałości,
84 zaprojektowanych z myślą o efektywny i wydajnym dostępem do baz
85 danych, zaadaptowanych do prostego, pythonowego języka.
86
87 Wersja dla Pythona 3.x.
88
89 %package apidocs
90 Summary:        API documentation for Python SQLAlchemy module
91 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona SQLAlchemy
92 Group:          Documentation
93 BuildArch:      noarch
94
95 %description apidocs
96 API documentation for Python SQLAlchemy module.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API modułu Pythona SQLAlchemy.
100
101 %package examples
102 Summary:        Examples for Python SQLAlchemy module
103 Summary(pl.UTF-8):      Przykłady do modułu Pythona SQLAlchemy
104 Group:          Documentation
105 BuildArch:      noarch
106
107 %description examples
108 Examples for Python SQLAlchemy module.
109
110 %description examples -l pl.UTF-8
111 Przykłady do modułu Pythona SQLAlchemy.
112
113 %prep
114 %setup -q -n SQLAlchemy-%{version}
115 %patch0 -p1
116
117 %build
118 %if %{with python2}
119 %py_build
120
121 %if %{with tests}
122 %{__python} -m pytest test
123 %endif
124 %endif
125
126 %if %{with python3}
127 %py3_build
128
129 %if %{with tests}
130 %{__python3} -m pytest test
131 %endif
132 %endif
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 %if %{with python2}
137 %py_install
138
139 %py_postclean
140 %endif
141
142 %if %{with python3}
143 %py3_install
144 %endif
145
146 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
147 cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %files
153 %defattr(644,root,root,755)
154 %doc AUTHORS CHANGES LICENSE README.rst
155 %dir %{py_sitedir}/sqlalchemy
156 %{py_sitedir}/sqlalchemy/connectors
157 %{py_sitedir}/sqlalchemy/databases
158 %{py_sitedir}/sqlalchemy/dialects
159 %{py_sitedir}/sqlalchemy/engine
160 %{py_sitedir}/sqlalchemy/event
161 %{py_sitedir}/sqlalchemy/ext
162 %{py_sitedir}/sqlalchemy/orm
163 %{py_sitedir}/sqlalchemy/pool
164 %{py_sitedir}/sqlalchemy/sql
165 %{py_sitedir}/sqlalchemy/testing
166 %{py_sitedir}/sqlalchemy/util
167 %attr(755,root,root) %{py_sitedir}/sqlalchemy/cprocessors.so
168 %attr(755,root,root) %{py_sitedir}/sqlalchemy/cresultproxy.so
169 %attr(755,root,root) %{py_sitedir}/sqlalchemy/cutils.so
170 %{py_sitedir}/sqlalchemy/*.py[co]
171 %{py_sitedir}/SQLAlchemy-%{version}-py*.egg-info
172
173 %if %{with python3}
174 %files -n python3-%{module}
175 %defattr(644,root,root,755)
176 %doc AUTHORS CHANGES LICENSE README.rst
177 %dir %{py3_sitedir}/sqlalchemy
178 %{py3_sitedir}/sqlalchemy/connectors
179 %{py3_sitedir}/sqlalchemy/databases
180 %{py3_sitedir}/sqlalchemy/dialects
181 %{py3_sitedir}/sqlalchemy/engine
182 %{py3_sitedir}/sqlalchemy/event
183 %{py3_sitedir}/sqlalchemy/ext
184 %{py3_sitedir}/sqlalchemy/orm
185 %{py3_sitedir}/sqlalchemy/pool
186 %{py3_sitedir}/sqlalchemy/sql
187 %{py3_sitedir}/sqlalchemy/testing
188 %{py3_sitedir}/sqlalchemy/util
189 %attr(755,root,root) %{py3_sitedir}/sqlalchemy/cprocessors.cpython-*.so
190 %attr(755,root,root) %{py3_sitedir}/sqlalchemy/cresultproxy.cpython-*.so
191 %attr(755,root,root) %{py3_sitedir}/sqlalchemy/cutils.cpython-*.so
192 %{py3_sitedir}/sqlalchemy/*.py
193 %{py3_sitedir}/sqlalchemy/__pycache__
194 %{py3_sitedir}/SQLAlchemy-%{version}-py*.egg-info
195 %endif
196
197 %files apidocs
198 %defattr(644,root,root,755)
199 %doc doc/{_images,_modules,_static,changelog,core,dialects,faq,orm,*.html,*.js}
200
201 %files examples
202 %defattr(644,root,root,755)
203 %{_examplesdir}/%{name}-%{version}
This page took 0.072108 seconds and 2 git commands to generate.