]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blob - python-sqlalchemy.spec
correct obsoletes line
[packages/python-sqlalchemy.git] / python-sqlalchemy.spec
1 # TODO:
2 # - examples and docs for python3
3 #   builds, but got syntax errors when buildings
4 #
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module  sqlalchemy
9 Summary:        Database Abstraction Library
10 Summary(pl.UTF-8):      Biblioteka abstrakcji baz danych
11 Name:           python-%{module}
12 Version:        0.9.8
13 Release:        1
14 License:        MIT
15 Group:          Libraries/Python
16 Source0:        https://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-%{version}.tar.gz
17 # Source0-md5:  470ca4da4a0081efc830f0d90dd91682
18 URL:            http://www.sqlalchemy.org/
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.219
21 %if %{with python2}
22 BuildRequires:  python-devel >= 1:2.4
23 BuildRequires:  python-distribute
24 BuildRequires:  python-setuptools >= 0.6-0.a9.1
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-2to3
28 BuildRequires:  python3-devel
29 BuildRequires:  python3-modules
30 %endif
31 %if %{with python2}
32 Requires:       python-modules
33 %endif
34 Provides:       python-SQLAlchemy = %{version}-%{release}
35 Obsoletes:      python-SQLAlchemy < 0.9.8
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 The Python SQL toolkit and Object Relational Mapper that gives
40 application developers the full power and flexibility of SQL.
41 SQLAlchemy provides a full suite of well known enterprise-level
42 persistence patterns, designed for efficient and high-performing
43 database access, adapted into a simple and Pythonic domain language.
44
45 Python 2.x version.
46
47 %description -l pl.UTF-8
48 Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
49 dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
50 udostępnia pełny zbiór dobrze znanych wzorców trwałości,
51 zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
52 prostej, pythonowej domeny językowej.
53
54 Wersja dla pythona 2.x.
55
56 %package -n python3-%{module}
57 Summary:        Database Abstraction Library
58 Summary(pl.UTF-8):      Biblioteka abstrakcji baz danych
59 Group:          Libraries/Python
60 Provides:       python3-SQLAlchemy = %{version}-%{release}
61 Obsoletes:      python3-SQLAlchemy < 0.9.8
62
63 %description -n python3-%{module}
64 The Python SQL toolkit and Object Relational Mapper that gives
65 application developers the full power and flexibility of SQL.
66 SQLAlchemy provides a full suite of well known enterprise-level
67 persistence patterns, designed for efficient and high-performing
68 database access, adapted into a simple and Pythonic domain language.
69
70 Python 3.x version.
71
72 %description -n python3-%{module} -l pl.UTF-8
73 Zestaw narzędzi SQL dla Pythona oraz odwzorowań obiektowo-relacyjnych
74 dających programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
75 udostępnia pełny zbiór dobrze znanych wzorców trwałości,
76 zaprojektowanych do wydajnego dostępu do baz danych, zaadoptowanych do
77 prostej, pythonowej domeny językowej.
78
79 Wersja dla Pythona 3.x.
80
81 %prep
82 %setup -q -n SQLAlchemy-%{version}
83
84 %build
85 %if %{with python2}
86 CC="%{__cc}" \
87 CFLAGS="%{rpmcppflags} %{rpmcflags}" \
88 %{__python} setup.py build -b build-2
89 %endif
90 %if %{with python3}
91 CC="%{__cc}" \
92 CFLAGS="%{rpmcppflags} %{rpmcflags}" \
93 %{__python3} setup.py build -b build-3
94 %endif
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 %if %{with python2}
99 %{__python} setup.py build -b build-2 \
100         install \
101         --single-version-externally-managed \
102         --optimize=2 \
103         --root=$RPM_BUILD_ROOT
104
105 %py_postclean
106 %endif
107
108 %if %{with python3}
109 %{__python3} setup.py build -b build-3 \
110         install \
111         --root=$RPM_BUILD_ROOT \
112         --optimize=2
113 %endif
114
115 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
116 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %doc CHANGES README* doc/*.html
124 %{py_sitedir}/sqlalchemy
125 %{py_sitedir}/SQLAlchemy-%{version}-py*.egg-info
126 %{_examplesdir}/%{name}-%{version}
127
128 %if %{with python3}
129 %files -n python3-%{module}
130 %defattr(644,root,root,755)
131 %{py3_sitedir}/sqlalchemy
132 %{py3_sitedir}/SQLAlchemy-%{version}-py*.egg-info
133 %endif
This page took 0.060908 seconds and 3 git commands to generate.