]> git.pld-linux.org Git - packages/python-sqlalchemy.git/blame_incremental - python-sqlalchemy.spec
rebuild with separate debuginfo build-ids
[packages/python-sqlalchemy.git] / python-sqlalchemy.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5%bcond_without tests # unit tests
6
7%define module sqlalchemy
8Summary: Database Abstraction Library for Python 2
9Summary(pl.UTF-8): Biblioteka abstrakcji baz danych dla Pythona 2
10Name: python-%{module}
11Version: 1.3.23
12Release: 4
13License: MIT
14Group: Libraries/Python
15#Source0Download: https://pypi.org/simple/sqlalchemy/
16Source0: https://files.pythonhosted.org/packages/source/S/SQLAlchemy/SQLAlchemy-%{version}.tar.gz
17# Source0-md5: 179d25a8fea451f06539c12bb0a00081
18Patch0: %{name}-tests.patch
19URL: https://www.sqlalchemy.org/
20BuildRequires: rpm-pythonprov
21BuildRequires: rpmbuild(macros) >= 1.714
22%if %{with python2}
23BuildRequires: python-devel >= 1:2.7
24BuildRequires: python-modules >= 1:2.7
25BuildRequires: python-setuptools >= 0.6-0.a9.1
26%if %{with tests}
27BuildRequires: python-mock
28BuildRequires: python-pytest >= 2.5.2
29BuildRequires: python-pytest-xdist
30%endif
31%endif
32%if %{with python3}
33BuildRequires: python3-devel >= 1:3.4
34BuildRequires: python3-modules >= 1:3.4
35BuildRequires: python3-setuptools >= 0.6-0.a9.1
36%if %{with tests}
37BuildRequires: python3-pytest >= 2.5.2
38BuildRequires: python3-pytest-xdist
39%endif
40%endif
41Requires: python-modules
42Provides: python-SQLAlchemy = %{version}-%{release}
43Obsoletes: python-SQLAlchemy < 0.9.8
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47The Python SQL toolkit and Object Relational Mapper that gives
48application developers the full power and flexibility of SQL.
49SQLAlchemy provides a full suite of well known enterprise-level
50persistence patterns, designed for efficient and high-performing
51database access, adapted into a simple and Pythonic domain language.
52
53Python 2.x version.
54
55%description -l pl.UTF-8
56Zestaw narzędzi SQL oraz odwzorowań obiektowo-relacyjnych dla Pythona,
57dający programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
58udostępnia pełny zbiór dobrze znanych wzorców trwałości,
59zaprojektowanych z myślą o efektywny i wydajnym dostępem do baz
60danych, zaadaptowanych do prostego, pythonowego języka.
61
62Wersja dla pythona 2.x.
63
64%package -n python3-%{module}
65Summary: Database Abstraction Library for Python 3
66Summary(pl.UTF-8): Biblioteka abstrakcji baz danych dla Pythona 3
67Group: Libraries/Python
68Provides: python3-SQLAlchemy = %{version}-%{release}
69Obsoletes: python3-SQLAlchemy < 0.9.8
70
71%description -n python3-%{module}
72The Python SQL toolkit and Object Relational Mapper that gives
73application developers the full power and flexibility of SQL.
74SQLAlchemy provides a full suite of well known enterprise-level
75persistence patterns, designed for efficient and high-performing
76database access, adapted into a simple and Pythonic domain language.
77
78Python 3.x version.
79
80%description -n python3-%{module} -l pl.UTF-8
81Zestaw narzędzi SQL oraz odwzorowań obiektowo-relacyjnych dla Pythona,
82dający programistom całą potęgę i elastyczność SQL-a. SQLAlchemy
83udostępnia pełny zbiór dobrze znanych wzorców trwałości,
84zaprojektowanych z myślą o efektywny i wydajnym dostępem do baz
85danych, zaadaptowanych do prostego, pythonowego języka.
86
87Wersja dla Pythona 3.x.
88
89%package apidocs
90Summary: API documentation for Python SQLAlchemy module
91Summary(pl.UTF-8): Dokumentacja API modułu Pythona SQLAlchemy
92Group: Documentation
93BuildArch: noarch
94
95%description apidocs
96API documentation for Python SQLAlchemy module.
97
98%description apidocs -l pl.UTF-8
99Dokumentacja API modułu Pythona SQLAlchemy.
100
101%package examples
102Summary: Examples for Python SQLAlchemy module
103Summary(pl.UTF-8): Przykłady do modułu Pythona SQLAlchemy
104Group: Documentation
105BuildArch: noarch
106
107%description examples
108Examples for Python SQLAlchemy module.
109
110%description examples -l pl.UTF-8
111Przykłady do modułu Pythona SQLAlchemy.
112
113%prep
114%setup -q -n SQLAlchemy-%{version}
115%patch0 -p1
116
117%build
118%if %{with python2}
119%py_build
120
121%if %{with tests}
122%{__python} -m pytest test
123%endif
124%endif
125
126%if %{with python3}
127%py3_build
128
129%if %{with tests}
130%{__python3} -m pytest test
131%endif
132%endif
133
134%install
135rm -rf $RPM_BUILD_ROOT
136%if %{with python2}
137%py_install
138
139%py_postclean
140%endif
141
142%if %{with python3}
143%py3_install
144%endif
145
146install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
147cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%files
153%defattr(644,root,root,755)
154%doc AUTHORS CHANGES LICENSE README.rst
155%dir %{py_sitedir}/sqlalchemy
156%{py_sitedir}/sqlalchemy/connectors
157%{py_sitedir}/sqlalchemy/databases
158%{py_sitedir}/sqlalchemy/dialects
159%{py_sitedir}/sqlalchemy/engine
160%{py_sitedir}/sqlalchemy/event
161%{py_sitedir}/sqlalchemy/ext
162%{py_sitedir}/sqlalchemy/orm
163%{py_sitedir}/sqlalchemy/pool
164%{py_sitedir}/sqlalchemy/sql
165%{py_sitedir}/sqlalchemy/testing
166%{py_sitedir}/sqlalchemy/util
167%attr(755,root,root) %{py_sitedir}/sqlalchemy/cprocessors.so
168%attr(755,root,root) %{py_sitedir}/sqlalchemy/cresultproxy.so
169%attr(755,root,root) %{py_sitedir}/sqlalchemy/cutils.so
170%{py_sitedir}/sqlalchemy/*.py[co]
171%{py_sitedir}/SQLAlchemy-%{version}-py*.egg-info
172
173%if %{with python3}
174%files -n python3-%{module}
175%defattr(644,root,root,755)
176%doc AUTHORS CHANGES LICENSE README.rst
177%dir %{py3_sitedir}/sqlalchemy
178%{py3_sitedir}/sqlalchemy/connectors
179%{py3_sitedir}/sqlalchemy/databases
180%{py3_sitedir}/sqlalchemy/dialects
181%{py3_sitedir}/sqlalchemy/engine
182%{py3_sitedir}/sqlalchemy/event
183%{py3_sitedir}/sqlalchemy/ext
184%{py3_sitedir}/sqlalchemy/orm
185%{py3_sitedir}/sqlalchemy/pool
186%{py3_sitedir}/sqlalchemy/sql
187%{py3_sitedir}/sqlalchemy/testing
188%{py3_sitedir}/sqlalchemy/util
189%attr(755,root,root) %{py3_sitedir}/sqlalchemy/cprocessors.cpython-*.so
190%attr(755,root,root) %{py3_sitedir}/sqlalchemy/cresultproxy.cpython-*.so
191%attr(755,root,root) %{py3_sitedir}/sqlalchemy/cutils.cpython-*.so
192%{py3_sitedir}/sqlalchemy/*.py
193%{py3_sitedir}/sqlalchemy/__pycache__
194%{py3_sitedir}/SQLAlchemy-%{version}-py*.egg-info
195%endif
196
197%files apidocs
198%defattr(644,root,root,755)
199%doc doc/{_images,_modules,_static,changelog,core,dialects,faq,orm,*.html,*.js}
200
201%files examples
202%defattr(644,root,root,755)
203%{_examplesdir}/%{name}-%{version}
This page took 0.043772 seconds and 4 git commands to generate.